Add py-oslo.messaging10 10.5.0 (copied from py-oslo.messaging)
- Add PORTSCOUT
This commit is contained in:
parent
e2c35d97fe
commit
4f41a9b230
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=525565
5 changed files with 74 additions and 0 deletions
|
@ -4669,6 +4669,7 @@
|
|||
SUBDIR += py-oslo.limit
|
||||
SUBDIR += py-oslo.log
|
||||
SUBDIR += py-oslo.messaging
|
||||
SUBDIR += py-oslo.messaging10
|
||||
SUBDIR += py-oslo.middleware
|
||||
SUBDIR += py-oslo.policy
|
||||
SUBDIR += py-oslo.privsep
|
||||
|
|
52
devel/py-oslo.messaging10/Makefile
Normal file
52
devel/py-oslo.messaging10/Makefile
Normal file
|
@ -0,0 +1,52 @@
|
|||
# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= oslo.messaging
|
||||
PORTVERSION= 10.5.0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
PKGNAMESUFFIX= 10
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Oslo Messaging API
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}amqp>=2.5.2:net/py-amqp@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}debtcollector>=1.2.0:devel/py-debtcollector@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}futurist>=1.2.0:devel/py-futurist@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}kombu>=4.6.6:net/py-kombu@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}oslo.config>=5.2.0:devel/py-oslo.config@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}oslo.log>=3.36.0:devel/py-oslo.log@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}oslo.middleware>=3.31.0:devel/py-oslo.middleware@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}oslo.serialization>=2.18.0:devel/py-oslo.serialization@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}oslo.service>=1.24.0:devel/py-oslo.service@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.37.0:devel/py-oslo.utils@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}yaml>=3.12:devel/py-yaml@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}stevedore>=1.20.0:devel/py-stevedore@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}webob>=1.7.1:www/py-webob@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
PORTSCOUT= limit:^10\.
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PYTHON_REL} < 3300
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}monotonic>=0.6:devel/py-monotonic@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
.if ${PYTHON_REL} < 3500
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cachetools3>=2.0.0:devel/py-cachetools3@${PY_FLAVOR}
|
||||
.else
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cachetools>=2.0.0:devel/py-cachetools@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
devel/py-oslo.messaging10/distinfo
Normal file
3
devel/py-oslo.messaging10/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1580000699
|
||||
SHA256 (oslo.messaging-10.5.0.tar.gz) = e00d2c6fdf96c6742990f5363d0da35ebb57dcc36acb460cb01061f97955f1c1
|
||||
SIZE (oslo.messaging-10.5.0.tar.gz) = 254381
|
|
@ -0,0 +1,13 @@
|
|||
--- oslo_messaging/_drivers/impl_rabbit.py.orig 2018-03-27 18:46:38 UTC
|
||||
+++ oslo_messaging/_drivers/impl_rabbit.py
|
||||
@@ -919,8 +919,8 @@ class Connection(object):
|
||||
% (self.connection_id, str(e)))
|
||||
else:
|
||||
sock.settimeout(timeout)
|
||||
- # TCP_USER_TIMEOUT is not defined on Windows and Mac OS X
|
||||
- if sys.platform != 'win32' and sys.platform != 'darwin':
|
||||
+ # TCP_USER_TIMEOUT is not defined on FreeBSD, Windows and Mac OS X
|
||||
+ if sys.platform[0:7] != 'freebsd' and sys.platform != 'win32' and sys.platform != 'darwin':
|
||||
try:
|
||||
timeout = timeout * 1000 if timeout is not None else 0
|
||||
# NOTE(gdavoian): only integers and strings are allowed
|
5
devel/py-oslo.messaging10/pkg-descr
Normal file
5
devel/py-oslo.messaging10/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
The Oslo messaging API supports RPC and notifications over a number of
|
||||
different messaging transports.
|
||||
|
||||
WWW: https://docs.openstack.org/oslo.messaging/latest/
|
||||
WWW: https://github.com/openstack/oslo.messaging
|
Loading…
Reference in a new issue