Add port sysutils/ts:
task spooler is a Unix batch system where the tasks spooled run one after the other. Each user in each system has his own job queue. The tasks are run in the correct context (that of enqueue) from any shell/process, and its output/results can be easily watched. It is very useful when you know that your commands depend on a lot of RAM, a lot of disk use, give a lot of output, or for whatever reason it's better not to run them at the same time. WWW: http://vicerveza.homeunix.net/~viric/soft/ts/ Author: Lluis Batlle i Rossell <viric_at_vicerveza_dot_homeunix_dot_net>
This commit is contained in:
parent
2d22371adc
commit
4f5dc96cd2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=189081
5 changed files with 71 additions and 0 deletions
|
@ -613,6 +613,7 @@
|
|||
SUBDIR += toshctl
|
||||
SUBDIR += tracker
|
||||
SUBDIR += tree
|
||||
SUBDIR += ts
|
||||
SUBDIR += tss
|
||||
SUBDIR += ttyload
|
||||
SUBDIR += tua
|
||||
|
|
31
sysutils/ts/Makefile
Normal file
31
sysutils/ts/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# New ports collection makefile for: ts
|
||||
# Date created: 3 April 2007
|
||||
# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ts
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://vicerveza.homeunix.net/~viric/soft/ts/ CENKES
|
||||
|
||||
MAINTAINER= infofarmer@FreeBSD.org
|
||||
COMMENT= Serial task spooler
|
||||
|
||||
WRKSRC= ${WRKDIR}/ts
|
||||
ALL_TARGET= ts
|
||||
PLIST_BIN= bin/${PORTNAME}
|
||||
PORTDOCS= OBJECTIVES PROTOCOL README TODO TRICKS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|$$^|$${.ALLSRC}|' ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
|
||||
.ifndef NOPORTDOCS
|
||||
@${INSTALL} -d ${DOCSDIR}/
|
||||
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
sysutils/ts/distinfo
Normal file
3
sysutils/ts/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (ts-0.3.tar.gz) = fc7d79bf36ed06ff2046aecfcfd9de0b
|
||||
SHA256 (ts-0.3.tar.gz) = 852b0a9cbacddd7ac0ed7ba7c1f3d7a44b6eb8775d59256ba88c42e8bd20006d
|
||||
SIZE (ts-0.3.tar.gz) = 31545
|
26
sysutils/ts/files/patch-execute.c
Normal file
26
sysutils/ts/files/patch-execute.c
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- ./execute.c.orig Tue Apr 3 15:07:38 2007
|
||||
+++ ./execute.c Tue Apr 3 15:07:48 2007
|
||||
@@ -16,7 +16,6 @@
|
||||
#include "msg.h"
|
||||
#include "main.h"
|
||||
|
||||
-static void program_signal();
|
||||
|
||||
/* Returns errorlevel */
|
||||
static int run_parent(int fd_read_filename, int pid)
|
||||
@@ -204,15 +203,3 @@
|
||||
{
|
||||
}
|
||||
|
||||
-static void program_signal()
|
||||
-{
|
||||
- struct sigaction act;
|
||||
-
|
||||
- act.sa_handler = sigchld_handler;
|
||||
- /* Reset the mask */
|
||||
- memset(&act.sa_mask,0,sizeof(act.sa_mask));
|
||||
- act.sa_flags = SA_NOCLDSTOP;
|
||||
- act.sa_restorer = NULL;
|
||||
-
|
||||
- sigaction(SIGCHLD, &act, NULL);
|
||||
-}
|
10
sysutils/ts/pkg-descr
Normal file
10
sysutils/ts/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
task spooler is a Unix batch system where the tasks spooled run one
|
||||
after the other. Each user in each system has his own job queue. The
|
||||
tasks are run in the correct context (that of enqueue) from any
|
||||
shell/process, and its output/results can be easily watched. It is
|
||||
very useful when you know that your commands depend on a lot of RAM,
|
||||
a lot of disk use, give a lot of output, or for whatever reason it's
|
||||
better not to run them at the same time.
|
||||
|
||||
WWW: http://vicerveza.homeunix.net/~viric/soft/ts/
|
||||
Author: Lluis Batlle i Rossell <viric_at_vicerveza_dot_homeunix_dot_net>
|
Loading…
Reference in a new issue