devel/trompeloeil: update 45 → 46
Reported by: portscout
This commit is contained in:
parent
ea57038f9a
commit
4f98833394
3 changed files with 7 additions and 17 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= trompeloeil
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 45
|
||||
DISTVERSION= 46
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -13,11 +13,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
|
|||
TEST_DEPENDS= ${LOCALBASE}/include/catch2/catch.hpp:devel/catch \
|
||||
criterion>0:devel/criterion
|
||||
|
||||
USES= cmake:testing
|
||||
USES= cmake:testing compiler:c++14-lang
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= rollbear
|
||||
|
||||
CMAKE_TESTING_ON= TROMPELOEIL_BUILD_TESTS
|
||||
CMAKE_TESTING_TARGET= self_test thread_terror custom_recursive_mutex # see the README
|
||||
|
||||
NO_BUILD= yes
|
||||
|
@ -33,7 +34,7 @@ post-install:
|
|||
${MV} docs/* . && \
|
||||
${RMDIR} docs
|
||||
|
||||
post-test: # run tests
|
||||
post-test: # run tests (tests fail to compile, see https://github.com/rollbear/trompeloeil/issues/322)
|
||||
.for exe in ${CMAKE_TESTING_TARGET}
|
||||
${ECHO} "==> Running tests executable ${exe}"
|
||||
@cd ${TEST_WRKSRC} && test/${exe}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1690004321
|
||||
SHA256 (rollbear-trompeloeil-v45_GH0.tar.gz) = 124b0aa45d84415193719376b6557fc1f1180cbfebf4dc4f7ca247cb404d6bd8
|
||||
SIZE (rollbear-trompeloeil-v45_GH0.tar.gz) = 308207
|
||||
TIMESTAMP = 1699375057
|
||||
SHA256 (rollbear-trompeloeil-v46_GH0.tar.gz) = dc2c856ab7716ef659f8df7fc5f6740a40e736089f05e0a8251d4ad3ad17ad83
|
||||
SIZE (rollbear-trompeloeil-v46_GH0.tar.gz) = 316447
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2023-06-18 08:43:43 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -37,7 +37,7 @@ endif()
|
||||
option(TROMPELOEIL_INSTALL_TARGETS "Sets whether trompeloeil should be installed" ${MASTER_PROJECT})
|
||||
option(TROMPELOEIL_INSTALL_DOCS "Install documentation" ${TROMPELOEIL_INSTALL_TARGETS})
|
||||
|
||||
-if (MASTER_PROJECT AND CMAKE_BUILD_TYPE MATCHES Debug)
|
||||
+if (BUILD_TESTING)
|
||||
add_subdirectory(test)
|
||||
|
||||
endif() # MASTER_PROJECT AND CMAKE_BUILD_TYPE MATCHES Debug
|
Loading…
Reference in a new issue