Fix build on gcc-based architectures by removing the assumption that FreeBSD
must imply clang. While here, remove duplicate definition from USES. PR: 234580 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
This commit is contained in:
parent
fba35c89f6
commit
4fbae2d211
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=490083
2 changed files with 16 additions and 3 deletions
|
@ -22,7 +22,7 @@ LIB_DEPENDS= libevent.so:devel/libevent \
|
|||
|
||||
SLAVEDIRS= databases/percona57-client \
|
||||
databases/percona57-pam-for-mysql
|
||||
USES= bison:build cmake:insource,noninja compiler:c11 compiler:c++11-lib \
|
||||
USES= bison:build cmake:insource,noninja compiler:c11 \
|
||||
cpe libedit localbase perl5 shebangfix
|
||||
|
||||
MY_DBDIR= /var/db/mysql
|
||||
|
@ -83,8 +83,6 @@ USES+= libedit
|
|||
.else
|
||||
LIB_DEPENDS+= libcurl.so:ftp/curl
|
||||
|
||||
BROKEN_powerpc64= Does not configure: CMake Error at cmake/os/FreeBSD.cmake:34 (MESSAGE): Unsupported compiler!
|
||||
|
||||
# MySQL-Server part
|
||||
OPTIONS_DEFINE= OPENSSL FASTMTX INNODBMEMCACHED TOKUDB
|
||||
OPTIONS_DEFAULT= OPENSSL INNODBMEMCACHED
|
||||
|
@ -151,6 +149,10 @@ post-patch:
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${CHOSEN_COMPILER_TYPE} == gcc
|
||||
CXXFLAGS+= -fpermissive
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "arm"
|
||||
BROKEN= Does not compile on arm
|
||||
.endif
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- cmake/os/FreeBSD.cmake.orig 2018-12-16 19:27:57 UTC
|
||||
+++ cmake/os/FreeBSD.cmake
|
||||
@@ -30,8 +30,6 @@ IF(NOT FORCE_UNSUPPORTED_COMPILER)
|
||||
IF(NOT HAVE_SUPPORTED_CLANG_VERSION)
|
||||
MESSAGE(FATAL_ERROR "Clang 3.3 or newer is required!")
|
||||
ENDIF()
|
||||
- ELSE()
|
||||
- MESSAGE(FATAL_ERROR "Unsupported compiler!")
|
||||
ENDIF()
|
||||
ENDIF()
|
||||
|
Loading…
Reference in a new issue