x11-fonts/py-cffsubr: Update to 0.3.0

- Remove PY_SETUPTOOLS: py-setuptools should be used rather than PY_SETUPTOOLS

Changes:	https://github.com/adobe-type-tools/cffsubr/releases
This commit is contained in:
Po-Chuan Hsieh 2024-03-23 22:23:51 +08:00
parent 63b5f8fea9
commit 4fdef02afc
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
4 changed files with 18 additions and 27 deletions

View File

@ -1,6 +1,5 @@
PORTNAME= cffsubr
PORTVERSION= 0.2.9.post1
PORTREVISION= 2
PORTVERSION= 0.3.0
CATEGORIES= x11-fonts python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -12,8 +11,7 @@ WWW= https://github.com/adobe-type-tools/cffsubr
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
${PYTHON_PKGNAMEPREFIX}setuptools_git_ls_files>=0:devel/py-setuptools_git_ls_files@${PY_FLAVOR} \
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= tx:x11-fonts/afdko \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1646057862
SHA256 (cffsubr-0.2.9.post1.tar.gz) = 6b31412dcf49c8fa84664bda867e2eddc55b6fe6fa696ff253c4f13a9ff2fc5c
SIZE (cffsubr-0.2.9.post1.tar.gz) = 12671095
TIMESTAMP = 1710712574
SHA256 (cffsubr-0.3.0.tar.gz) = 7745150bdb81679facdd11c1f3b87096c4f4dbd4957e8fcebb88c45687952efb
SIZE (cffsubr-0.3.0.tar.gz) = 17830033

View File

@ -0,0 +1,11 @@
--- pyproject.toml.orig 2024-01-18 11:25:11 UTC
+++ pyproject.toml
@@ -3,8 +3,5 @@ requires = [
"setuptools",
"setuptools_scm",
]
-# https://setuptools.pypa.io/en/latest/build_meta.html#dynamic-build-dependencies-and-other-build-meta-tweaks
-build-backend = "backend"
-backend-path = ["_custom_build"]
[tool.setuptools_scm]
write_to = "src/cffsubr/_version.py"

View File

@ -1,16 +1,6 @@
--- setup.py.orig 2021-11-25 15:57:49 UTC
--- setup.py.orig 2024-01-18 11:25:11 UTC
+++ setup.py
@@ -107,6 +107,9 @@ elif platform.system() == "Darwin":
elif platform.system() == "Windows":
plat = "win"
compiler = "visualstudio"
+elif platform.system() == "FreeBSD":
+ plat = "freebsd"
+ compiler = "cc"
else:
raise NotImplementedError(platform.system())
@@ -136,7 +139,6 @@ setup(
@@ -104,7 +104,6 @@ setup(
package_dir={"": "src"},
packages=find_packages("src"),
entry_points={"console_scripts": ["cffsubr = cffsubr.__main__:main"]},
@ -18,11 +8,3 @@
zip_safe=False,
cmdclass=cmdclass,
install_requires=[
@@ -146,7 +148,6 @@ setup(
setup_requires=[
"setuptools_scm",
# finds all git tracked files including submodules when making sdist MANIFEST
- "setuptools-git-ls-files",
],
extras_require={"testing": ["pytest"]},
python_requires=">=3.6",