multimedia/dvdrip: Remove expired port:

2023-03-31 multimedia/dvdrip: Depends on broken transcode port
This commit is contained in:
Muhammad Moinur Rahman 2023-03-25 09:11:58 -05:00
parent 1d5138a718
commit 4fdf527101
12 changed files with 1 additions and 332 deletions

1
MOVED
View file

@ -17854,3 +17854,4 @@ devel/phpunit7||2023-03-31|Has expired: End of Life since February 7, 2020
emulators/pcsxr||2023-03-31|Has expired: Abandoned upstream and no development in 5+ years, consider using games/retroarch
games/acm||2023-03-31|Has expired: Abandoned upstream. Does not work.
mail/horde-webmail||2023-03-31|Has expired: Requires php74
multimedia/dvdrip||2023-03-31|Has expired: Depends on broken transcode port

View file

@ -51,7 +51,6 @@
SUBDIR += dvdauthor
SUBDIR += dvdid
SUBDIR += dvdread
SUBDIR += dvdrip
SUBDIR += dvdstyler
SUBDIR += elementary-videos
SUBDIR += emby-server

View file

@ -1,69 +0,0 @@
PORTNAME= dvdrip
PORTVERSION= 0.98.11
PORTREVISION= 12
CATEGORIES= multimedia
MASTER_SITES= CPAN http://www.exit1.org/dvdrip/dist/
MASTER_SITE_SUBDIR= CPAN:JRED
MAINTAINER= se@FreeBSD.org
COMMENT= Perl Gtk+ based dvd-ripper
WWW= https://www.exit1.org/dvdrip/
LICENSE= ART10 GPLv1 # (ART10 or GPLv1) and CC-BY-SA-2.5
LICENSE_COMB= dual
DEPRECATED= Depends on broken transcode port
EXPIRATION_DATE= 2023-03-31
BUILD_DEPENDS= p5-Gtk2>=0:x11-toolkits/p5-Gtk2 \
p5-AnyEvent>=0:devel/p5-AnyEvent \
p5-Event-ExecFlow>=0:devel/p5-Event-ExecFlow \
p5-Gtk2-Ex-FormFactory>=0:x11-toolkits/p5-Gtk2-Ex-FormFactory \
p5-Event-RPC>=0:devel/p5-Event-RPC \
p5-Locale-libintl>=0:devel/p5-Locale-libintl
RUN_DEPENDS= p5-Gtk2>=0:x11-toolkits/p5-Gtk2 \
p5-AnyEvent>=0:devel/p5-AnyEvent \
p5-Event-ExecFlow>=0:devel/p5-Event-ExecFlow \
p5-Gtk2-Ex-FormFactory>=0:x11-toolkits/p5-Gtk2-Ex-FormFactory \
p5-Event-RPC>=0:devel/p5-Event-RPC \
p5-Locale-libintl>=0:devel/p5-Locale-libintl \
cdrdao:sysutils/cdrdao \
mplayer:multimedia/mplayer \
pstree:sysutils/pstree \
transcode:multimedia/transcode \
vcdimager:multimedia/vcdimager \
${LOCALBASE}/sbin/fping:net/fping \
cdrecord:sysutils/cdrtools
USES= gettext magick:6,run perl5 shebangfix
USE_PERL5= configure patch
SHEBANG_FILES= bin/dvdrip*
CONFIGURE_ENV= SKIP_UNPACK_REQUIRED_MODULES=1
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= VORBIS SUBTITLE RAR
OPTIONS_DEFAULT= VORBIS SUBTITLE
RAR_DESC= Support RAR-compressed vobsub subtitles
SUBTITLE_DESC= Enable support for getting subtitles
RAR_RUN_DEPENDS= rar:archivers/rar
SUBTITLE_RUN_DEPENDS= subtitle2pgm:multimedia/subtitleripper
VORBIS_RUN_DEPENDS= oggenc:audio/vorbis-tools \
ogmmerge:multimedia/ogmtools
post-patch:
@${PERL} -pi -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#' \
${WRKSRC}/lib/Video/DVDRip/Cluster/Master.pm \
${WRKSRC}/lib/Video/DVDRip/Depend.pm
@${FIND} ${WRKSRC} -name \*.orig -delete
post-install:
.for f in dvdrip-progress dvdrip-splitpipe
@${CHMOD} u+w ${STAGEDIR}${PREFIX}/bin/${f}
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
@${CHMOD} u-w ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1619892059
SHA256 (dvdrip-0.98.11.tar.gz) = 586c20968b2daa55c0afaaf334d5b9b8b6896d6ea45078a577e165806858c3a5
SIZE (dvdrip-0.98.11.tar.gz) = 2075302

View file

@ -1,11 +0,0 @@
--- lib/Video/DVDRip/Cluster/Master.pm.orig 2010-04-24 17:21:50.000000000 -0300
+++ lib/Video/DVDRip/Cluster/Master.pm 2010-04-24 17:25:30.000000000 -0300
@@ -122,7 +122,7 @@
sub check_prerequisites {
my $class = shift;
- foreach my $path ( "/usr/bin", "/usr/sbin" ) {
+ foreach my $path ( "/usr/bin", "/usr/sbin", "/usr/local/sbin" ) {
if ( -f "$path/fping" and -x "$path/fping" ) {
$FPING = "$path/fping";
last;

View file

@ -1,40 +0,0 @@
--- lib/Video/DVDRip/Config.pm.orig Sun Aug 20 07:56:01 2006
+++ lib/Video/DVDRip/Config.pm Sat Sep 23 13:58:03 2006
@@ -193,16 +193,16 @@
dvd_device => {
label => __ "Default DVD device",
type => 'file',
- value => "",
+ value => "/cdrom",
dvd_button => 1,
},
selected_dvd_device => {
- value => "/dev/dvd",
+ value => "/cdrom",
},
eject_command => {
label => __ "Eject Command",
type => 'string',
- value => "eject",
+ value => "cdcontrol",
rules => "executable-command",
},
play_dvd_command => {
@@ -226,7 +226,7 @@
play_stdin_command => {
label => __ "STDIN player command",
type => 'string',
- value => 'xine stdin://mpeg2 -g -pq -a %a',
+ value => 'mplayer -aid %(%a+128) -',
presets => [
'mplayer -aid %(%a+128) -', 'xine stdin://mpeg2 -g -pq -a %a',
],
@@ -274,7 +274,7 @@
default_video_codec => {
label => __ "Default video codec",
type => 'string',
- value => 'xvid',
+ value => 'xvid4',
presets => [
"SVCD", "VCD", "XSVCD", "XVCD", "CVD", "divx4",
"divx5", "xvid", "xvidcvs", "xvid2", "xvid3", "xvid4",

View file

@ -1,11 +0,0 @@
--- lib/Video/DVDRip/FilterList.pm.orig Fri Sep 22 16:05:34 2006
+++ lib/Video/DVDRip/FilterList.pm Fri Sep 22 16:06:07 2006
@@ -220,7 +220,7 @@
"[filterlist] (re)scanning transcode's module path $modpath...\n";
my @filter_names = grep !/^(pv|preview)$/,
- map {m!/filter_([^/]+)\.so$!} glob("$modpath/filter_*");
+ map {m!/filter_([^/]+)\.so$/!} glob("$modpath/filter_*");
my %filters;
foreach my $filter_name (@filter_names) {

View file

@ -1,15 +0,0 @@
--- lib/Video/DVDRip/GUI/Project/Storage.pm.orig Sat Sep 23 16:06:43 2006
+++ lib/Video/DVDRip/GUI/Project/Storage.pm Sat Sep 23 16:15:30 2006
@@ -144,6 +144,12 @@
."Either it's the filename of a physical DVD "
."device or the path of a full DVD image copy."
),
+ Gtk2::Ex::FormFactory::Label->new(
+ label =>
+ __"Important: On FreeBSD, please mount your DVD disc first\n"
+ ."(eg 'mount /cdrom'), and then specify the mountpoint above\n"
+ ."(click \"Choose DVD image directory\" and select '/cdrom').\n"
+ ),
],
),
],

View file

@ -1,27 +0,0 @@
--- lib/Video/DVDRip/GUI/Project/Title.pm.orig Fri Sep 22 15:53:09 2006
+++ lib/Video/DVDRip/GUI/Project/Title.pm Fri Sep 22 15:56:35 2006
@@ -433,8 +433,10 @@
my $title = $self->selected_title;
my $command
- = $self->config('eject_command') . " " .
- $title->project->dvd_device;
+ = $self->config('eject_command') . " -f " .
+ $title->project->dvd_device .
+ " eject";
+
system("$command &");
@@ -446,8 +448,9 @@
my $title = $self->selected_title;
- my $command = $self->config('eject_command') . " -t "
- . $title->project->dvd_device;
+ my $command = $self->config('eject_command') . " -f " .
+ $title->project->dvd_device .
+ " close";
system("$command &");

View file

@ -1,51 +0,0 @@
--- lib/Video/DVDRip/Project.pm.orig Wed Aug 16 16:34:38 2006
+++ lib/Video/DVDRip/Project.pm Sat Sep 23 15:32:16 2006
@@ -345,24 +345,27 @@
return \%symlinks;
}
-sub get_mount_dir_from_mtab {
+sub get_mount_dir_from_fstab {
my $self = shift;
- my ( $dvd_device, $mtab_file ) = @_;
+ my ( $dvd_device, $fstab_file ) = @_;
my $symlinks_href = $self->resolve_symlinks($dvd_device);
- open( my $fh, $mtab_file )
- or die "can't read $mtab_file";
+ open(FSTABINPUT, $fstab_file )
+ or die "can't read $fstab_file";
my $mount_dir;
- while ( my $line = <$fh> ) {
- my ( $device, $dir ) = split( /\s+/, $line );
- if ( $symlinks_href->{$device} ) {
- $mount_dir = $dir;
- last;
- }
+ while (<FSTABINPUT>) {
+ my ($dev, $mnt, $fstyp, $opt, $dump, $pass) = split;
+ next if $dev =~ /^#/;
+ if (( $dev eq $symlinks_href->{$dev} ) ||
+ ( $mnt eq $symlinks_href->{$dev} ) ||
+ ( $fstyp eq 'cd9660' )) {
+ $mount_dir = $mnt;
+ last;
+ }
}
- close $fh;
+ close (FSTABINPUT);
return $mount_dir;
}
@@ -373,8 +376,7 @@
my $dvd_device = $self->dvd_device;
my $dvd_mount_point
- = $self->get_mount_dir_from_mtab( $dvd_device, "/etc/mtab" )
- || $self->get_mount_dir_from_mtab( $dvd_device, "/etc/fstab" );
+ = $self->get_mount_dir_from_fstab( $dvd_device, "/etc/fstab" );
return $dvd_mount_point;
}

View file

@ -1,4 +0,0 @@
This is dvd::rip, a Perl Gtk+ based dvd-ripper. It serves as a
convenient frontend to transcode and makes ripping and encoding
DVDs a breeze. It also features a cluster daemon, which can distribute
encoding jobs over multiple machines.

View file

@ -1,100 +0,0 @@
bin/dvdrip
bin/dvdrip-exec
bin/dvdrip-master
bin/dvdrip-multitee
bin/dvdrip-progress
bin/dvdrip-replex
bin/dvdrip-splash
bin/dvdrip-splitpipe
bin/dvdrip-subpng
bin/dvdrip-thumb
%%PERL5_MAN1%%/dvdrip.1.gz
%%PERL5_MAN1%%/dvdrip-progress.1.gz
%%PERL5_MAN1%%/dvdrip-splitpipe.1.gz
%%PERL5_MAN3%%/Video::DVDRip.3.gz
%%PERL5_MAN3%%/Video::DVDRip::CPAN::Scanf.3.gz
%%SITE_PERL%%/LocaleData/cs/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/da/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/de/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/es/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/fr/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/it/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/sr/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/LocaleData/sr@Latn/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/Video/DVDRip.pm
%%SITE_PERL%%/Video/DVDRip/Audio.pm
%%SITE_PERL%%/Video/DVDRip/Base.pm
%%SITE_PERL%%/Video/DVDRip/BitrateCalc.pm
%%SITE_PERL%%/Video/DVDRip/CPAN/Scanf.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/ExecFlowFrontend.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/JobPlanner.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/Master.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/Node.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/PSU.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/Pipe.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/Project.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/Scheduler.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/Title.pm
%%SITE_PERL%%/Video/DVDRip/Cluster/Webserver.pm
%%SITE_PERL%%/Video/DVDRip/Config.pm
%%SITE_PERL%%/Video/DVDRip/Content.pm
%%SITE_PERL%%/Video/DVDRip/Convert.pm
%%SITE_PERL%%/Video/DVDRip/Depend.pm
%%SITE_PERL%%/Video/DVDRip/FilterList.pm
%%SITE_PERL%%/Video/DVDRip/FilterSettings.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Base.pm
%%SITE_PERL%%/Video/DVDRip/GUI/BitrateCalc.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Cluster/Control.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Cluster/Node.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Cluster/Title.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Context.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Depend.pm
%%SITE_PERL%%/Video/DVDRip/GUI/ExecFlow.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Filters.pm
%%SITE_PERL%%/Video/DVDRip/GUI/FormFactory/ClipImage.pm
%%SITE_PERL%%/Video/DVDRip/GUI/FormFactory/SubtitlePreviews.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Icons/dvdrip-audio-matrix.png
%%SITE_PERL%%/Video/DVDRip/GUI/Icons/dvdrip-calc-height.png
%%SITE_PERL%%/Video/DVDRip/GUI/Icons/dvdrip-calc-width.png
%%SITE_PERL%%/Video/DVDRip/GUI/Icons/dvdrip-clip-move.png
%%SITE_PERL%%/Video/DVDRip/GUI/Icons/dvdrip-play-movie.png
%%SITE_PERL%%/Video/DVDRip/GUI/Icons/dvdrip-scan-volume.png
%%SITE_PERL%%/Video/DVDRip/GUI/Main.pm
%%SITE_PERL%%/Video/DVDRip/GUI/MultiAudio.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Pipe.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Preferences.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Preview.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Progress.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Project/ClipZoom.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Project/Logging.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Project/Storage.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Project/Subtitle.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Project/Title.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Project/Transcode.pm
%%SITE_PERL%%/Video/DVDRip/GUI/Rules.pm
%%SITE_PERL%%/Video/DVDRip/GUI/ZoomCalculator.pm
%%SITE_PERL%%/Video/DVDRip/InfoFile.pm
%%SITE_PERL%%/Video/DVDRip/JobPlanner.pm
%%SITE_PERL%%/Video/DVDRip/Logger.pm
%%SITE_PERL%%/Video/DVDRip/PSU.pm
%%SITE_PERL%%/Video/DVDRip/Preset.pm
%%SITE_PERL%%/Video/DVDRip/Probe.pm
%%SITE_PERL%%/Video/DVDRip/Project.pm
%%SITE_PERL%%/Video/DVDRip/SrtxFile.pm
%%SITE_PERL%%/Video/DVDRip/Subtitle.pm
%%SITE_PERL%%/Video/DVDRip/Term/ExitTask.pm
%%SITE_PERL%%/Video/DVDRip/Term/Main.pm
%%SITE_PERL%%/Video/DVDRip/Term/Progress.pm
%%SITE_PERL%%/Video/DVDRip/Title.pm
%%SITE_PERL%%/Video/DVDRip/TranscodeRC.pm
%%SITE_PERL%%/Video/DVDRip/icon.xpm
%%SITE_PERL%%/Video/DVDRip/license.txt
%%SITE_PERL%%/Video/DVDRip/splash.ca.png
%%SITE_PERL%%/Video/DVDRip/splash.da.png
%%SITE_PERL%%/Video/DVDRip/splash.de.png
%%SITE_PERL%%/Video/DVDRip/splash.en.png
%%SITE_PERL%%/Video/DVDRip/splash.es.png
%%SITE_PERL%%/Video/DVDRip/splash.it.png
%%SITE_PERL%%/Video/DVDRip/splash.sr@Latn.png
%%SITE_PERL%%/Video/DVDRip/splash.sr.png
%%SITE_PERL%%/Video/DVDRip/translators.txt