Maitainer update: Fix security/pam-pgsql on -current
Noticed on: bento PR: ports/45652 Submitted by: Mathieu Arnold <m@absolight.fr>
This commit is contained in:
parent
f5dcab2de3
commit
4fe8f1b22b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70977
2 changed files with 18 additions and 5 deletions
|
@ -14,7 +14,7 @@ MASTER_SITES= ${MASTER_SITE_DEBIAN} \
|
|||
MASTER_SITE_SUBDIR= pool/non-US/main/p/pam-pgsql
|
||||
DISTFILES= ${PORTNAME}_${PORTVERSION}.orig${EXTRACT_SUFX}
|
||||
|
||||
PATCHFILES= pam-pgsql_${PORTVERSION}-5.diff.gz
|
||||
PATCHFILES= ${PORTNAME}_${PORTVERSION}-5.diff.gz
|
||||
PATCH_SITES= ${MASTER_SITES}
|
||||
|
||||
MAINTAINER= m@absolight.fr
|
||||
|
@ -33,7 +33,7 @@ MASTER_SITE_DEBIAN+= http://ftp.au.debian.org/pub/debian-non-US/${MASTER_SITE_SU
|
|||
ftp://ftp.bora.net/pub/linux/debian-non-US/${MASTER_SITE_SUBDIR}/
|
||||
|
||||
MAKEFILE= ${FILESDIR}/Makefile.bsd
|
||||
MAKE_ARGS+= -j 2 FILESDIR=${FILESDIR}
|
||||
MAKE_ARGS+= FILESDIR=${FILESDIR}
|
||||
|
||||
post-install:
|
||||
${CAT} ${PKGMESSAGE}
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
--- pam_get_pass.c.orig Mon Jan 14 17:45:55 2002
|
||||
+++ pam_get_pass.c Tue Aug 13 18:31:56 2002
|
||||
@@ -33,70 +33,7 @@
|
||||
/* $Id: pam_get_pass.c,v 1.2 2000/06/25 09:39:28 ljb Exp $ */
|
||||
+++ pam_get_pass.c Sat Nov 23 20:26:10 2002
|
||||
@@ -34,68 +34,5 @@
|
||||
#include <stdlib.h>
|
||||
#include <security/pam_modules.h>
|
||||
-#include "pam_mod_misc.h"
|
||||
|
@ -71,3 +70,17 @@
|
|||
+#include <security/pam_mod_misc.h>
|
||||
|
||||
int
|
||||
@@ -125,8 +62,11 @@
|
||||
return retval;
|
||||
|
||||
+#ifdef PAM_AUTHTOK_RECOVER_ERR
|
||||
+#define PAM_AUTHTOK_RECOVERY_ERR PAM_AUTHTOK_RECOVER_ERR
|
||||
+#endif
|
||||
if(!resp)
|
||||
- return PAM_AUTHTOK_RECOVER_ERR;
|
||||
+ return PAM_AUTHTOK_RECOVERY_ERR;
|
||||
if(strcmp(resp[0].resp, resp[1].resp) != 0)
|
||||
- return PAM_AUTHTOK_RECOVER_ERR;
|
||||
+ return PAM_AUTHTOK_RECOVERY_ERR;
|
||||
|
||||
retval = pam_set_item(pamh, PAM_AUTHTOK, resp[0].resp);
|
||||
|
|
Loading…
Reference in a new issue