Remove expired leaf ports:
2006-04-07 mail/prom-mew 2006-04-07 mail/rmoldmail 2006-04-07 mail/ruby-mime-types
This commit is contained in:
parent
7a2bbf0106
commit
500a7f58db
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=158998
18 changed files with 3 additions and 413 deletions
3
MOVED
3
MOVED
|
@ -2237,3 +2237,6 @@ devel/upp602|devel/upp|2006-04-05|Was created in a bad directory
|
|||
mail/mulberry||2006-04-06|Has expired: mastersite disappeared, no longer maintained by author
|
||||
textproc/pyenchant|textproc/py-enchant|2006-04-06|Rename to consistency with other Python ports
|
||||
security/skip||2006-04-06|Port has become obsolete
|
||||
mail/prom-mew||2006-04-07|Has expired: mastersite disappeared, no longer maintained by author
|
||||
mail/rmoldmail||2006-04-07|Has expired: mastersite disappeared, no longer maintained by author
|
||||
mail/ruby-mime-types||2006-04-07|Has expired: mastersite disappeared, no longer maintained by author
|
||||
|
|
|
@ -397,7 +397,6 @@
|
|||
SUBDIR += prayer
|
||||
SUBDIR += premail
|
||||
SUBDIR += procmail
|
||||
SUBDIR += prom-mew
|
||||
SUBDIR += prom-wl
|
||||
SUBDIR += pronto
|
||||
SUBDIR += proxsmtp
|
||||
|
@ -457,10 +456,8 @@
|
|||
SUBDIR += ripmime
|
||||
SUBDIR += rlytest
|
||||
SUBDIR += rmime
|
||||
SUBDIR += rmoldmail
|
||||
SUBDIR += roundcube
|
||||
SUBDIR += rssyl
|
||||
SUBDIR += ruby-mime-types
|
||||
SUBDIR += ruby-rfilter
|
||||
SUBDIR += ruby-rmail
|
||||
SUBDIR += ruby-tmail
|
||||
|
|
|
@ -1,45 +0,0 @@
|
|||
# New ports collection makefile for: prom-mew
|
||||
# Date created: 28 Jun 1999
|
||||
# Whom: KIRIYAMA Kazuhiko<kiri@pis.toba-cmt.ac.jp>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= prom-mew
|
||||
PORTVERSION= 1.93.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mail elisp
|
||||
MASTER_SITES= #
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Procmail reader for Mew on GNU Emacs
|
||||
|
||||
# This port requires Mew. But we can't decide which mew to depends, there is
|
||||
# NO RUN_DEPENDS mail/mew*.
|
||||
RUN_DEPENDS= procmail:${PORTSDIR}/mail/procmail
|
||||
|
||||
BROKEN= Incomplete pkg-plist
|
||||
DEPRECATED= mastersite disappeared, no longer maintained by author
|
||||
EXPIRATION_DATE= 2006-04-07
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
ELISPDIR= ${PREFIX}/share/emacs/site-lisp
|
||||
SITEPKGDIR= ${PREFIX}/lib/xemacs/site-packages
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${ELISPDIR} ${PREFIX}/share/doc/prom-mew \
|
||||
${PREFIX}/share/examples/prom-mew
|
||||
@cd ${WRKSRC}; \
|
||||
${INSTALL_DATA} prom-mew.el ${ELISPDIR}; \
|
||||
${INSTALL_DATA} ChangeLog prom-usage.jis ${PREFIX}/share/doc/prom-mew
|
||||
@cd ${FILESDIR}; \
|
||||
${INSTALL_SCRIPT} byte-compile ${PREFIX}/share/doc/prom-mew; \
|
||||
${INSTALL_DATA} dot.emacs dot.procmailrc ${PREFIX}/share/examples/prom-mew
|
||||
# For xemacs package install configuration
|
||||
@${MKDIR} ${SITEPKGDIR}/lisp/prom-mew ${SITEPKGDIR}/pkginfo
|
||||
@${LN} -sf ${ELISPDIR}/prom-mew.el ${SITEPKGDIR}/lisp/prom-mew/prom-mew.el
|
||||
@${ECHO_CMD} 'pkginfo/MANIFEST.prom-mew' > ${SITEPKGDIR}/pkginfo/MANIFEST.prom-mew
|
||||
@${ECHO_CMD} 'lisp/prom-mew/prom-mew.el' >> ${SITEPKGDIR}/pkginfo/MANIFEST.prom-mew
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (prom-mew-1.93.4.tar.gz) = 28b1427ab7a1fbd7397f9a36ef789b46
|
||||
SHA256 (prom-mew-1.93.4.tar.gz) = d78d56f8e9c031696498b261d434f57b89774b7e0e0fbc23ba7b6e144bfc3f0a
|
||||
SIZE (prom-mew-1.93.4.tar.gz) = 24679
|
|
@ -1,139 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
PREFIX=${PREFIX:-/usr/local}
|
||||
WRKDIR=${WRKDIR:-`pwd`}
|
||||
|
||||
tmprfx=`basename $0`
|
||||
|
||||
Usage="\
|
||||
byte_compile [options] emacs_name port_name [files]
|
||||
-l load_el : load *.el file when byte-compile
|
||||
-h : show this message
|
||||
emacs_name : should be one of below
|
||||
\"emacs\", \"emacs20\", \"mule\", \"xemacs19\", \"xemacs20\",
|
||||
\"xemacs21\", \"xemacs-mule\"
|
||||
port_name : port name(replaced port_name.el when files not specified)
|
||||
files : *.el files should be compiled"
|
||||
|
||||
while [ -z "`getopts "l: h" opt > /tmp/${tmprfx}:getopt_err.log`" \
|
||||
-a X"${opt}" != "X?" ]; do
|
||||
case ${opt} in
|
||||
l)
|
||||
load_el=${OPTARG}
|
||||
break
|
||||
;;
|
||||
h)
|
||||
echo "${Usage}"
|
||||
exit 1
|
||||
;;
|
||||
*)
|
||||
;;
|
||||
esac
|
||||
# echo "opt=${opt},OPTARG=${OPTARG}"
|
||||
done
|
||||
|
||||
if [ -s /tmp/${tmprfx}:getopt_err.log ]; then
|
||||
cat /tmp/${tmprfx}:getopt_err.log
|
||||
rm -f /tmp/${tmprfx}:getopt_err.log
|
||||
exit 1
|
||||
fi
|
||||
rm -f /tmp/${tmprfx}:getopt_err.log
|
||||
|
||||
shift `expr ${OPTIND} - 1`
|
||||
|
||||
if [ -z "$1" -o -z "$2" ]; then
|
||||
echo "${Usage}"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
emacs_name=$1
|
||||
shift
|
||||
port_name=$1
|
||||
|
||||
if [ $# -le 1 ]; then
|
||||
files=${port_name}.el
|
||||
else
|
||||
files=`echo $* | sed -e "s/${port_name} *//"`
|
||||
fi
|
||||
|
||||
#echo "emacs_name=${emacs_name}"
|
||||
#echo "port_name=${port_name}"
|
||||
#echo "files=${files}"
|
||||
#echo "load_el=${load_el}"
|
||||
#exit 1
|
||||
|
||||
case ${emacs_name} in
|
||||
emacs)
|
||||
elispdir=${PREFIX}/share/emacs/site-lisp
|
||||
load_path=${PREFIX}/share/emacs/site-lisp/${load_el}
|
||||
emacscmd=emacs
|
||||
;;
|
||||
emacs20)
|
||||
elispdir=${PREFIX}/share/emacs/site-lisp
|
||||
load_path=${PREFIX}/share/emacs/site-lisp/${load_el}
|
||||
emacscmd=emacs20
|
||||
;;
|
||||
mule)
|
||||
elispdir=${PREFIX}/share/mule/site-lisp
|
||||
load_path=${PREFIX}/share/mule/site-lisp/${load_el}
|
||||
emacscmd=mule
|
||||
;;
|
||||
xemacs19)
|
||||
elispdir=${PREFIX}/lib/xemacs/site-lisp
|
||||
load_path=${PREFIX}/lib/xemacs/site-lisp/${load_el}
|
||||
emacscmd=xemacs
|
||||
;;
|
||||
xemacs20)
|
||||
elispdir=${PREFIX}/lib/xemacs/site-lisp
|
||||
load_path=${PREFIX}/lib/xemacs/site-lisp/${load_el}
|
||||
emacscmd=xemacs
|
||||
;;
|
||||
xemacs21)
|
||||
elispdir=${PREFIX}/lib/xemacs/site-packages/lisp/${port_name}
|
||||
load_path=${PREFIX}/lib/xemacs/site-packages/lisp/${load_el}
|
||||
pkg_path=${PREFIX}/lib/xemacs/site-packages
|
||||
emacscmd=xemacs
|
||||
package_install=yes
|
||||
;;
|
||||
xemacs-mule)
|
||||
elispdir=${PREFIX}/lib/xemacs/site-packages/lisp/${port_name}
|
||||
load_path=${PREFIX}/lib/xemacs/site-packages/lisp/${load_el}
|
||||
pkg_path=${PREFIX}/lib/xemacs/site-packages
|
||||
emacscmd=xemacs
|
||||
package_install=yes
|
||||
;;
|
||||
*)
|
||||
echo "${Usage}"
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
if [ -n "${load_el}" ]; then
|
||||
echo "(setq load-path (cons \"${load_path}\" load-path))" > /tmp/${tmprfx}:load.el
|
||||
fi
|
||||
for f in ${files}; do
|
||||
if [ -f ${WRKDIR}/${f} ]; then
|
||||
f_elc=`basename ${f} .el`.elc
|
||||
if [ -n "${load_el}" ]; then
|
||||
${emacscmd} -batch -l /tmp/${tmprfx}:load.el -q -no-site-file \
|
||||
-f batch-byte-compile ${WRKDIR}/${f}
|
||||
else
|
||||
${emacscmd} -batch -q -no-site-file -f batch-byte-compile ${WRKDIR}/${f}
|
||||
fi
|
||||
if [ X"${WRKDIR}" != "X${elispdir}" -a -d ${elispdir} ]; then
|
||||
rm -f ${elispdir}/${f_elc}
|
||||
ln -sf ${WRKDIR}/${f} ${elispdir}/${f}
|
||||
install -c -m 444 -g bin -o bin ${WRKDIR}/${f_elc} ${elispdir}/${f_elc}
|
||||
rm -f ${WRKDIR}/${f_elc}
|
||||
fi
|
||||
if [ $? -eq 0 -a -n "${package_install}" -a -d ${elispdir} ]; then
|
||||
cp ${pkg_path}/pkginfo/MANIFEST.${port_name} /tmp/${tmprfx}:tempfile
|
||||
grep -v "${f_elc}" /tmp/${tmprfx}:tempfile \
|
||||
> ${pkg_path}/pkginfo/MANIFEST.${port_name}
|
||||
echo "lisp/${port_name}/${f_elc}" >> ${pkg_path}/pkginfo/MANIFEST.${port_name}
|
||||
fi
|
||||
else
|
||||
echo "\"${WRKDIR}/${f}\": file not found!"
|
||||
fi
|
||||
done
|
||||
|
||||
rm -f /tmp/${tmprfx}:load.el /tmp/${tmprfx}:tempfile
|
|
@ -1,8 +0,0 @@
|
|||
;;;
|
||||
;;; Prom-Mew
|
||||
;;;
|
||||
(autoload 'prom-mew "prom-mew" "mew for using procmail" t)
|
||||
(setq proc-log-list (list "~/Mail/from-log"))
|
||||
;; logfile name that procmail output (LOGFILE in ~/.procmail)
|
||||
(setq proc-keep-log "~/Mail/listlog") ;; logfile name for preserve
|
||||
(setq proc-lock-file "~/Mail/.lock") ;; lockfile name (LOCKFILE in ~/.procmail)
|
|
@ -1,41 +0,0 @@
|
|||
MAILDIR=$HOME/Mail # Mew folder directory (indispensable for Prom-Mew)
|
||||
LOGFILE=$MAILDIR/from-log # log file (indispensable for Prom-Mew)
|
||||
LOCKFILE=$MAILDIR/.lock # global lockfile (indispensable for Prom-Mew)
|
||||
|
||||
# trash
|
||||
|
||||
:0
|
||||
* ^To: *undisclosed-recipients
|
||||
trash/.
|
||||
|
||||
#
|
||||
# Daily outputs
|
||||
#
|
||||
|
||||
# daily output - fbsd
|
||||
|
||||
:0
|
||||
* ^Subject: +daily *run *output$
|
||||
* ^From: *Charlie *Root *.*$
|
||||
daily/.
|
||||
|
||||
#
|
||||
# Mailing Lists
|
||||
#
|
||||
|
||||
:0
|
||||
* ^Subject: *\[FreeBSD-users-jp *[0-9]+\]
|
||||
* ^To:.*[Ff]ree[Bb][Ss][Dd]-users-jp@jp\.freebsd\.org
|
||||
ML/FreeBSD-users-jp/.
|
||||
|
||||
:0
|
||||
* ^Subject: *\[Mew-dist *[0-9]+\]
|
||||
ML/Mew/.
|
||||
|
||||
#
|
||||
# Miscs
|
||||
#
|
||||
|
||||
:0
|
||||
* ^Cc:.*sinet-.*@
|
||||
maintain/.
|
|
@ -1,31 +0,0 @@
|
|||
--- prom-mew.el.orig Mon Aug 16 16:14:37 1999
|
||||
+++ prom-mew.el Thu Sep 9 22:37:49 1999
|
||||
@@ -296,6 +296,11 @@
|
||||
))
|
||||
))
|
||||
|
||||
+(if mew-xemacs-p
|
||||
+ (if (<= emacs-major-version 20)
|
||||
+ (setq mew-cs-binary mew-cs-noconv))
|
||||
+)
|
||||
+
|
||||
(defun prom-mew-setup ()
|
||||
(if prom-mew-setup
|
||||
nil
|
||||
@@ -948,6 +953,7 @@
|
||||
nil)
|
||||
))
|
||||
|
||||
+
|
||||
(defun prom-mew-cache-lastnum (folder &optional cache)
|
||||
(let ((mew-folder-buffer (get-buffer folder))
|
||||
(mew-cache (or cache
|
||||
@@ -958,7 +964,7 @@
|
||||
(set-buffer (get-buffer-create prom-buffer-tmp))
|
||||
(erase-buffer)
|
||||
(if (file-exists-p mew-cache)
|
||||
- (mew-frwlet mew-cs-scan mew-cs-noconv
|
||||
+ (mew-frwlet mew-cs-scan mew-cs-binary
|
||||
(insert-file-contents mew-cache))))
|
||||
(goto-char (point-max))
|
||||
(if (bobp)
|
|
@ -1,29 +0,0 @@
|
|||
Prom-Mew is a procmail reader for Mew on GNU Emacs.
|
||||
|
||||
If you want to install quickly, you shoud do following steps:
|
||||
|
||||
(1) add dot.emacs to your ~/.emacs file and change it suitable for your site
|
||||
|
||||
% cat /usr/local/share/examples/prom-mew/dot.emacs >> ~/.emacs
|
||||
% vi ~/.emacs
|
||||
|
||||
(2) copy dot.procmailrc to ~/.procmailrc and change it suitable for your site
|
||||
|
||||
% cp /usr/local/share/examples/prom-mew/dot.promailrc ~/.promailrc
|
||||
% vi ~/.promailrc
|
||||
|
||||
(3) byte-compile with "byte-comile" script if you want
|
||||
|
||||
# cd /usr/local/share/emacs/site-lisp
|
||||
# /usr/local/share/doc/prom-mew/byte_compile -l mew xemacs-mule prom-mew
|
||||
|
||||
Where detail specification for .emacs and .procmailrc may be shown in
|
||||
/usr/local/share/doc/prom-mew/prom-usage.jis or procmail(1). And for
|
||||
usage of byte_compile scripts, run byte_compile with -h option.
|
||||
|
||||
Run with "M-x prom-mew" in your emacs editors, Mew will be invoked and then
|
||||
search unread mails from procmail log to show unread message from top of
|
||||
entries that you specfied in ~/.pronmailrc.
|
||||
|
||||
-KIRIYAMA Kazuhiko
|
||||
<kiri@pis.toba-cmt.ac.jp>
|
|
@ -1,11 +0,0 @@
|
|||
share/emacs/site-lisp/prom-mew.el
|
||||
lib/xemacs/site-packages/lisp/prom-mew/prom-mew.el
|
||||
lib/xemacs/site-packages/pkginfo/MANIFEST.prom-mew
|
||||
share/doc/prom-mew/ChangeLog
|
||||
share/doc/prom-mew/prom-usage.jis
|
||||
share/doc/prom-mew/byte-compile
|
||||
share/examples/prom-mew/dot.emacs
|
||||
share/examples/prom-mew/dot.procmailrc
|
||||
@dirrm lib/xemacs/site-packages/lisp/prom-mew
|
||||
@dirrm share/doc/prom-mew
|
||||
@dirrm share/examples/prom-mew
|
|
@ -1,33 +0,0 @@
|
|||
# New ports collection makefile for: rmoldmail
|
||||
# Date created: 7 June 2001
|
||||
# Whom: petef@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= rmoldmail
|
||||
PORTVERSION= 0.1.0
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= #
|
||||
|
||||
MAINTAINER= petef@FreeBSD.org
|
||||
COMMENT= Prune a mailbox of messages older than a set number of days
|
||||
|
||||
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc
|
||||
|
||||
DEPRECATED= mastersite disappeared, no longer maintained by author
|
||||
EXPIRATION_DATE= 2006-04-07
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
USE_PERL5= yes
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/rmoldmail.RUNconfigure.pl \
|
||||
${PREFIX}/sbin/rmoldmail
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/rmoldmail
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/rmoldmail
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (rmoldmail-0.1.0.tar.gz) = 94cbe1f2c995c36ae58426858d24965e
|
||||
SHA256 (rmoldmail-0.1.0.tar.gz) = ab6f57c42fa7d630d62d6b747abec0d9dd92aac2790c01406493032154b24521
|
||||
SIZE (rmoldmail-0.1.0.tar.gz) = 3159
|
|
@ -1,7 +0,0 @@
|
|||
rmoldmail is a Perl script which removes all mail messages older
|
||||
than a configurable number of months from a mailbox file. It is
|
||||
possible to use rmoldmail on a running mailserver; it shouldn't
|
||||
confuse your MTA or IMAP- or POP3-server.
|
||||
|
||||
- Pete
|
||||
petef@databits.net
|
|
@ -1,3 +0,0 @@
|
|||
sbin/rmoldmail
|
||||
%%PORTDOCS%%share/doc/rmoldmail/README
|
||||
%%PORTDOCS%%@dirrm share/doc/rmoldmail
|
|
@ -1,36 +0,0 @@
|
|||
# New ports collection makefile for: MIME::Types for Ruby
|
||||
# Date created: 24 October 2002
|
||||
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mime-types
|
||||
PORTVERSION= 1.13.1
|
||||
CATEGORIES= mail ruby
|
||||
MASTER_SITES= http://www.halostatue.ca/files/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= MIME::Types for Ruby
|
||||
|
||||
DEPRECATED= mastersite disappeared, no longer maintained by author
|
||||
EXPIRATION_DATE=2006-04-07
|
||||
|
||||
USE_RUBY= yes
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
DOCS= ChangeLog Readme
|
||||
|
||||
do-install:
|
||||
${CP} -R ${WRKSRC}/lib/* ${RUBY_SITELIBDIR}/
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_MODDOCDIR}
|
||||
.for f in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (ruby/mime-types-1.13.1.tar.gz) = 49fb7abf6730ebae1e32fc2d8ccc928e
|
||||
SHA256 (ruby/mime-types-1.13.1.tar.gz) = 9945dec83d19b8641d851225b6357a3935b1fea347f6431a26fa4fa2f913ed45
|
||||
SIZE (ruby/mime-types-1.13.1.tar.gz) = 17772
|
|
@ -1,12 +0,0 @@
|
|||
MIME::Types provides the ability for detailed information about MIME
|
||||
entities to be determined and used programmatically.
|
||||
|
||||
This is based on Perl MIME::Types and reflects this heritage in the
|
||||
existence of both MIME::Types and MIME::Type (which is the definition
|
||||
of a single MIME type). As with the Perl version, this module is
|
||||
built to conform with MIME types in RFC 2045 and 2231. This library
|
||||
follows the collection of MIME types at the USC Information Sciences
|
||||
Institute.
|
||||
|
||||
Author: Austin Ziegler <austin@halostatue.ca>
|
||||
WWW: http://www.halostatue.ca/ruby/MIME__Types.html
|
|
@ -1,6 +0,0 @@
|
|||
%%RUBY_SITELIBDIR%%/mime/type.rb
|
||||
%%RUBY_SITELIBDIR%%/mime/types.rb
|
||||
@dirrm %%RUBY_SITELIBDIR%%/mime
|
||||
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Readme
|
||||
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
|
Loading…
Reference in a new issue