update www/plugger: 4.0_2 --> 4.0_3

* Patch to make plugger work better with mplayer
  * Sort dependencies in pkg_sort order
  * Cleanup pkg-descr
  * Create pkg-message-mplayer for special handling with mozilla
  * Patch pluggerrc for smoother operation

PR:		53664
Submitted by:	John Merryweather Cooper <coop9211@uidaho.edu> (maintainer)
This commit is contained in:
Daichi GOTO 2003-06-27 03:40:26 +00:00
parent 4e870334c1
commit 500b39afc2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=83700
4 changed files with 167 additions and 49 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= plugger
PORTVERSION= 4.0
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= www audio graphics multimedia
MASTER_SITES= http://fredrik.hubbe.net/plugger/ \
${MASTER_SITE_NETSCAPE}
@ -17,16 +17,16 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unix-sdk-3.0b5.tar.Z
MAINTAINER= coop9211@uidaho.edu
COMMENT= A multimedia front-end plugin for Mozilla or Opera
RUN_DEPENDS= ${X11BASE}/bin/xanim:${PORTSDIR}/multimedia/xanim \
${LOCALBASE}/bin/timidity:${PORTSDIR}/audio/timidity++ \
RUN_DEPENDS= ${LOCALBASE}/bin/nspptview:${PORTSDIR}/textproc/xlhtml \
${LOCALBASE}/bin/mpg123:${PORTSDIR}/audio/mpg123 \
${LOCALBASE}/bin/sidplay:${PORTSDIR}/audio/sidplay \
${LOCALBASE}/bin/wavplay:${PORTSDIR}/audio/wavplay \
${LOCALBASE}/bin/xmp:${PORTSDIR}/audio/xmp \
${LOCALBASE}/bin/sidplay:${PORTSDIR}/audio/sidplay \
${LOCALBASE}/bin/display:${PORTSDIR}/graphics/ImageMagick \
${X11BASE}/bin/gqview:${PORTSDIR}/graphics/gqview \
${LOCALBASE}/bin/display:${PORTSDIR}/graphics/ImageMagick \
${LOCALBASE}/bin/timidity:${PORTSDIR}/audio/timidity++ \
${X11BASE}/bin/gv:${PORTSDIR}/print/gv \
${X11BASE}/bin/abiword:${PORTSDIR}/editors/AbiWord \
${X11BASE}/bin/xanim:${PORTSDIR}/multimedia/xanim \
${LOCALBASE}/bin/acroread5:${PORTSDIR}/print/acroread5
USE_X_PREFIX= yes
@ -46,7 +46,7 @@ WITH_MPLAYER = yes
WITH_MTV = yes
.endif
.if exists(${X11BASE}/lib/libgnomeprintui-2.so.0)
.if exists(${X11BASE}/lib/libgnomeprintui-2-2.so.0)
WITH_GNOME2 = yes
.endif
@ -59,9 +59,11 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/mtvp:${PORTSDIR}/multimedia/mtv
.endif
.if defined(WITH_GNOME2)
RUN_DEPENDS+= ${X11BASE}/bin/gnumeric:${PORTSDIR}/math/gnumeric2
RUN_DEPENDS+= ${X11BASE}/bin/gnumeric:${PORTSDIR}/math/gnumeric2 \
${X11BASE}/bin/abiword:${PORTSDIR}/editors/AbiWord2
.else
RUN_DEPENDS+= ${X11BASE}/bin/gnumeric:${PORTSDIR}/math/gnumeric
RUN_DEPENDS+= ${X11BASE}/bin/gnumeric:${PORTSDIR}/math/gnumeric \
${X11BASE}/bin/abiword:${PORTSDIR}/editors/AbiWord
.endif
pre-extract:
@ -98,5 +100,8 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
.if defined(WITH_MPLAYER)
@${CAT} ${PKGMESSAGE}-mplayer
.endif
.include <bsd.port.post.mk>

View file

@ -1,70 +1,159 @@
--- pluggerrc.orig Wed Dec 5 11:14:01 2001
+++ pluggerrc Wed Apr 3 08:05:35 2002
@@ -58,12 +58,12 @@
--- pluggerrc.orig Sun Jun 22 14:48:34 2003
+++ pluggerrc Sun Jun 22 15:06:47 2003
@@ -1,4 +1,4 @@
-# Configure file for plugger version 4.0
+# Configure file for plugger version 4.0 (FreeBSD modified)
# Commands which are not installed on your system will not
# be used.
#
@@ -6,16 +6,15 @@
video/x-mpeg: mpeg, mpg, mpe: MPEG animation
video/x-mpeg2: mpv2, mp2ve: MPEG2 animation
stream: mtvp -W$window - 2>/dev/null 1>/dev/null
- ignore_errors maxaspect swallow(MPlayer):mplayer "$file" >/dev/null 2>/dev/null </dev/null
+ nokill, ignore_errors: mplayer -really-quiet -framedrop -wid $window -aop list=volume:volume=64 "$file" >/dev/null 2>/dev/null
loop:mtvp -l -W$window "$file"
:mtvp -W$window "$file"
loop: xanim +Av100 -Zr +W$window +q +f "$file"
: xanim +Av100 -Zr +W$window +q +Ze +f "$file"
-
video/msvideo: avi: AVI animation
video/x-msvideo: avi: AVI animation
- ignore_errors maxaspect swallow(MPlayer):if mplayer -autoq 3 "$file" 2>&1 | grep 'Sorry,' >/dev/null ; then mplayer -vo x11 -autoq 3 "$file" >/dev/null 2>/dev/null ; fi </dev/null
+ nokill, ignore_errors: mplayer -really-quiet -framedrop -wid $window -aop list=volume:volume=64 "$file" >/dev/null 2>/dev/null
loop:xanim +Av100 -Zr +W$window +q +f "$file"
:xanim +Av100 -Zr +W$window +q +Ze +f "$file"
@@ -37,18 +36,11 @@
audio/midi: midi,mid: MIDI audio file
audio/x-midi: midi,mid: MIDI audio file
: timidity -s 48000 -a -idqqqqqqq "$file" >/dev/null 2>/dev/null
- : playmidi $file
audio/mod: mod: Soundracker audio Module
audio/x-mod: mod: Soundracker audio Module
- repeat swallow(alsaplayer): alsaplayer -q "$file" >/dev/null
loop: xmp -l --nocmd "$file" 2>/dev/null
: xmp --nocmd "$file" 2>/dev/null
- loop: nspmod -r "$file" 2>/dev/null 1>/dev/null
- repeat: nspmod -l $repeat "$file" 2>/dev/null 1>/dev/null
- : tracker -q -frequency 65000 "$file"
- loop: mikmod -i -r "$file" 2>/dev/null 1>/dev/null
- : mikmod -i "$file" 2>/dev/null 1>/dev/null
audio/mp3: mp3: MPEG audio
audio/x-mp3: mp3: MPEG audio
@@ -58,15 +50,8 @@
audio/x-mpeg3: mp3: MPEG audio
audio/mpeg: mpa,abs,mpega: MPEG audio
audio/x-mpeg: mpa,abs,mpega: MPEG audio
- stream, preload: splay -t 200 -M
- stream, preload: mpg123 -q -b 128 -
+ stream, preload: mpg123 -q -b 1024 -
+ stream, preload: splay -M -t 200
repeat swallow(alsaplayer): alsaplayer -q "$file" >/dev/null
- repeat swallow(alsaplayer): alsaplayer -q "$file" >/dev/null
- : mpg123 -q -b 128 "$file"
- nokill exits:xmms "$file"
- : splay -t 200 "$file"
- : amp -b 200 -q "$file"
- : maplay "$file"
- : mpeg3play "$file"
+ stream, preload: mpg123 -q -b 1024 -
+ : mpg123 -q -b 1024 "$file"
+# nokill exits:xmms "$file" # immortal on FreeBSD
+ : splay "$file" -t 200
: amp -b 200 -q "$file"
: maplay "$file"
: mpeg3play "$file"
@@ -89,12 +89,21 @@
stream preload: bplay 1>/dev/null 2>/dev/null
: bplay 1>/dev/null 2>/dev/null "$file"
: splay "$file"
audio/x-sidtune: sid,psid,dat: Commodore 64 audio
audio/sidtune: sid,psid,dat: Commodore 64 audio
@@ -74,7 +59,6 @@
audio/x-psid: psid,sid,dat: Commodore 64 audio
stream: sidplay -16 -f44100 -a - >/dev/null 2>/dev/null
-
audio/basic: au,snd: Basic audio file
audio/x-basic: au,snd: Basic audio file
loop: xanim +Av100 -Zr +W$window +q +f "$file"
@@ -83,13 +67,7 @@
audio/wav:wav:Microsoft wave file
audio/x-wav:wav:Microsoft wave file
- stream preload: splay -W
- repeat swallow(alsaplayer): alsaplayer -q "$file" >/dev/null
: wavplay -q "$file"
- stream preload: bplay 1>/dev/null 2>/dev/null
- : bplay 1>/dev/null 2>/dev/null "$file"
- : splay "$file"
- nokill exits:xmms "$file"
+# nokill exits:xmms "$file" # immortal on FreeBSD
loop: xanim +Av100 -Zr +W$window +q +f "$file"
: xanim +Av100 -Zr +W$window +q +f +Ze "$file"
image/tiff: tiff,tif: TIFF image
image/x-tiff: tiff,tif: TIFF image
+ repeat swallow(display) fill: display "$file"
+ repeat swallow(Sdtimage) fill: sdtimage "$file"
+ repeat swallow(gqview) fill: gqview -t "$file" >/dev/null 2>/dev/null
+ repeat swallow(xli) fill: xli -quiet "$file" >/dev/null 2>/dev/null
+ repeat swallow(xloadimage) fill: xloadimage -quiet "$file" >/dev/null 2>/dev/null
+ exits: xli -quiet -windowid $window "$file"
+ exits: xloadimage -quiet -windowid $window "$file"
+ exits: display -window $window -backdrop $file
+
image/png: png: PNG image
@@ -99,12 +77,7 @@
image/x-png: png: PNG image
repeat swallow(gqview) fill: gqview -t "$file" >/dev/null 2>/dev/null
@@ -132,7 +141,7 @@
repeat swallow(display) fill: display "$file"
- repeat swallow(Sdtimage) fill: sdtimage "$file"
- repeat swallow(xli) fill: xli -quiet "$file" >/dev/null 2>/dev/null
- repeat swallow(xloadimage) fill: xloadimage -quiet "$file" >/dev/null 2>/dev/null
- exits: xloadimage -quiet -windowid $window "$file"
exits: display -window $window -backdrop $file
- exits: xli -quiet -windowid $window "$file"
image/sun-raster: rs: SUN raster image
image/x-sun-raster: rs: SUN raster image
@@ -117,54 +90,34 @@
image/x-portable-bitmap: pbm: PBM Image
image/x-portable-anymap: pnm: PBM Image
repeat swallow(display) fill: display "$file"
- repeat swallow(Sdtimage) fill: sdtimage "$file"
repeat swallow(gqview) fill: gqview -t "$file" >/dev/null 2>/dev/null
- repeat swallow(xli) fill: xli -quiet "$file" >/dev/null 2>/dev/null
- repeat swallow(xloadimage) fill: xloadimage -quiet "$file" >/dev/null 2>/dev/null
- exits: xli -quiet -windowid $window "$file"
- exits: xloadimage -quiet -windowid $window "$file"
exits: display -window $window -backdrop $file
-# This does not work :(
-# swallow(XVroot) maxaspect: xv -nopos "$file"
-
audio/mpeg-url: m3u: MPEG music resource locator
audio/x-mpeg-url: m3u: MPEG music resource locator
audio/mpegurl: m3u: MPEG music resource locator
audio/x-mpegurl: m3u: MPEG music resource locator
- nokill exits:xmms "$file"
+# nokill exits:xmms "$file" # immortal on FreeBSD
+ ignore_errors: mplayer -really-quiet -framedrop -demuxer 17 -playlist "$file" >/dev/null 2>/dev/null
:internal:url
audio/x-pn-realaudio-plugin:rpm:Realaudio-plugin resource locator
@@ -142,7 +151,7 @@
-audio/x-pn-realaudio-plugin:rpm:Realaudio-plugin resource locator
- exits nokill: realplay "$file"
-
application/pdf: pdf: PDF file
application/x-pdf: pdf: PDF file
text/pdf: pdf: PDF file
text/x-pdf: pdf: PDF file
- repeat swallow(documentShell) fill: acroread -geometry +9000+9000 -xrm '*userFrontEndProgram: FALSE' "$file"
+ repeat swallow(documentShell) fill: acroread5 -geometry +9000+9000 -xrm '*userFrontEndProgram: FALSE' "$file"
repeat swallow(gv) fill: gv -safer -quiet -antialias -geometry +9000+9000 "$file" 2>/dev/null
repeat swallow(xpdf) fill: xpdf -g +9000+9000 -err "$file"
- repeat swallow(xpdf) fill: xpdf -g +9000+9000 -err "$file"
-
-
-application/x-dvi: dvi: DVI file
- repeat swallow(xdvi) fill: xdvi -safer -hush -geometry +9000+9000 "$file"
application/x-postscript: ps: PostScript file
application/postscript: ps: PostScript file
repeat swallow(gv) fill: gv -safer -quiet -antialias -geometry +9000+9000 "$file" 2>/dev/null
- repeat swallow(Pageview) fill: pageview "$file"
-
@@ -159,7 +168,7 @@
application/rtf: rtf: Rich Text Format
application/x-msword: doc, dot: Microsoft Word Document
application/msword: doc, dot: Microsoft Word Document
- repeat swallow(AbiWord) fill: abiword -nosplash -geometry +9000+9000 "$file" >/dev/null 2>/dev/null
+ repeat swallow(AbiWord) fill: abiword --nosplash --geometry=+9000+9000 "$file" >/dev/null 2>/dev/null
repeat swallow(PCFileViewer) fill: sdtpcv "$file"
repeat swallow(PCFileViewer) fill: /opt/SUNWdtpcv/bin/sdtpcv "$file"
repeat swallow(AbiWord) fill: abiword -nosplash -geometry +9000+9000 "$file" >/dev/null 2>/dev/null
- repeat swallow(PCFileViewer) fill: sdtpcv "$file"
- repeat swallow(PCFileViewer) fill: /opt/SUNWdtpcv/bin/sdtpcv "$file"
-
application/vnd.ms-excel: xls, xlb: Microsoft Excel Document
repeat swallow(PluggerGnumeric) fill: gnumeric --class PluggerGnumeric "$file"
- repeat swallow(PCFileViewer) fill: sdtpcv "$file"
- repeat swallow(PCFileViewer) fill: /opt/SUNWdtpcv/bin/sdtpcv "$file"
+
+application/vnd.ms-powerpoint: ppt: Microsoft PowerPoint Document
+ : nspptview "$file"

View file

@ -1,7 +1,7 @@
Plugger is a multimedia plugin for Unix Netscape 3.0 or later that
handles Quicktime, MPEG, MP2, AVI, SGI-movie, Tiff, DL, IFF-anim,
MIDI, Soundtracker, AU, WAV and Commodore 64 audio files. Since
Plugger 3.0, MPEG audio and video can be streamed played.
Plugger 3.0, MPEG audio and video can be streamed.
Plugger is a very small plugin, because plugger uses external programs
to show/play the different formats.
@ -9,4 +9,4 @@ to show/play the different formats.
WWW: http://www.hubbe.net/~hubbe/plugger.html
--jmc
jmcoopr@webmail.bmi.net
coop9211@uidaho.edu

View file

@ -0,0 +1,24 @@
####################################################################
######################## MPLAYER NOTE ##############################
####################################################################
#
# Since mplayer is run with "nokill" by plugger, it is necessary to
# kill off the remaining mplayer processes. Something like the
# following diff will do the trick. It's not perfect but it works.
#
# As suggested by D.J. Hawkey Jr.<hawkeyd@visi.com>
#
####################################################################
--- run-mozilla.sh.orig Sun Jun 22 09:57:27 2003
+++ run-mozilla.sh Sun Jun 22 10:00:25 2003
@@ -193,6 +193,10 @@
##
"$prog" ${1+"$@"}
exitcode=$?
+ ##
+ ## Kill any plugger artifacts
+ ##
+ ps -axww | awk '/mplayer.*-wid/ {print $1}' | xargs kill -9
if [ "$DEBUG_CORE_FILES" ]
then
if [ -f core ]