Migrate over to using gnu-{libtool,autoconf,automake} as a runtime

dependency, rather than using the build-only versioned ports, in an
almost identical manner to devel/anjuta.

Tested by:	tap on #kde-freebsd
Approved by:	lofi
This commit is contained in:
Ade Lovett 2005-06-16 17:24:27 +00:00
parent fcd20f7eb1
commit 504cc3c4cc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=137571
4 changed files with 24 additions and 39 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= kdevelop
PORTVERSION= 3.2.0
PORTREVISION= 1
CATEGORIES?= devel kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${KDE_VERSION:S/.0//}/src
@ -19,7 +20,11 @@ COMMENT= Powerful IDE for developing KDE/Qt-based apps
BUILD_DEPENDS= cervisia:${PORTSDIR}/devel/kdesdk3 \
msgfmt:${PORTSDIR}/devel/gettext
RUN_DEPENDS= extractrc:${PORTSDIR}/devel/kdesdk3 \
gmake:${PORTSDIR}/devel/gmake
gmake:${PORTSDIR}/devel/gmake \
${LOCALBASE}/gnu-autotools/bin/automake:${PORTSDIR}/devel/gnu-automake \
${LOCALBASE}/gnu-autotools/bin/autoconf:${PORTSDIR}/devel/gnu-autoconf \
${LOCALBASE}/gnu-autotools/bin/libtool:${PORTSDIR}/devel/gnu-libtool
.if defined(WITH_OPTIONAL_DEPENDS)
RUN_DEPENDS+= kiconedit:${PORTSDIR}/graphics/kdegraphics3 \
ark:${PORTSDIR}/misc/kdeutils3 \
@ -29,15 +34,12 @@ RUN_DEPENDS+= kiconedit:${PORTSDIR}/graphics/kdegraphics3 \
# KDE_DISTNAME= ${PORTNAME}-${PORTVERSION}_for_KDE_3.1
WANT_AUTOMAKE_VER= 19
WANT_AUTOMAKE_RUN= yes
WANT_AUTOCONF_VER= 259
WANT_AUTOCONF_RUN= yes
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-qtdoc-dir=${X11BASE}/share/doc/qt/html
CONFIGURE_ENV+= PATH=${LOCALBASE}/gnu-autotools/bin:${PATH}
USE_REINPLACE= yes
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
@ -52,12 +54,19 @@ pre-everything::
.endif
post-patch:
${TOUCH} -t 200401230000 ${WRKSRC}/Makefile.am.in
@${TOUCH} -t 200401230000 ${WRKSRC}/Makefile.am.in
.if ${ARCH} == "amd64"
post-configure:
${REINPLACE_CMD} -e "s,-O2,${CFLAGS} -fPIC," \
@${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%PREFIX%%|${PREFIX}|g' < ${FILESDIR}/kdevelop \
> ${WRKDIR}/kdevelop
.if ${ARCH} == "amd64"
@${REINPLACE_CMD} -e "s,-O2,${CFLAGS} -fPIC," \
${WRKSRC}/bdb/build_unix/Makefile ${WRKSRC}/bdb/Makefile
.endif
post-install:
@${MV} ${PREFIX}/bin/kdevelop ${PREFIX}/bin/kdevelop-bin
@${INSTALL_SCRIPT} ${WRKDIR}/kdevelop ${PREFIX}/bin
.include <bsd.port.post.mk>

View file

@ -0,0 +1,6 @@
#!/bin/sh
export PATH=%%LOCALBASE%%/gnu-autotools/bin:${PATH}
export ACLOCAL_FLAGS="-I %%LOCALBASE%%/share/aclocal ${ACLOCAL_FLAGS}"
exec "%%PREFIX%%/bin/kdevelop-bin" "$@"

View file

@ -1,31 +0,0 @@
--- parts/appwizard/common/admin/detect-autoconf.sh.orig Wed Mar 3 22:22:59 2004
+++ parts/appwizard/common/admin/detect-autoconf.sh Wed Mar 3 21:47:49 2004
@@ -17,6 +17,8 @@
AUTOCONF="`$WHICH autoconf-2.5x`"
elif test -x "`$WHICH autoconf-2.57 2>/dev/null`" ; then
AUTOCONF="`$WHICH autoconf-2.57`"
+ elif test -x "`$WHICH autoconf259 2>/dev/null`" ; then
+ AUTOCONF="`$WHICH autoconf259`"
elif test -x "`$WHICH autoconf-2.56 2>/dev/null`" ; then
AUTOCONF="`$WHICH autoconf-2.56`"
elif test -x "`$WHICH autoconf-2.55 2>/dev/null`" ; then
@@ -42,6 +44,9 @@
elif test -x "`$WHICH autoheader-2.57 2>/dev/null`" ; then
AUTOHEADER="`$WHICH autoheader-2.57`"
AUTOM4TE="`$WHICH autom4te-2.57`"
+ elif test -x "`$WHICH autoheader259 2>/dev/null`" ; then
+ AUTOHEADER="`$WHICH autoheader259`"
+ AUTOM4TE="`$WHICH autom4te259`"
elif test -x "`$WHICH autoheader-2.56 2>/dev/null`" ; then
AUTOHEADER="`$WHICH autoheader-2.56`"
AUTOM4TE="`$WHICH autom4te-2.56`"
@@ -72,6 +77,9 @@
elif test -x "`$WHICH automake-1.7 2>/dev/null`" ; then
AUTOMAKE="`$WHICH automake-1.7`"
ACLOCAL="`$WHICH aclocal-1.7`"
+ elif test -x "`$WHICH automake19 2>/dev/null`" ; then
+ AUTOMAKE="`$WHICH automake19`"
+ ACLOCAL="`$WHICH aclocal19`"
fi
if test -n "$UNSERMAKE"; then
AUTOMAKE="$UNSERMAKE"

View file

@ -1,6 +1,7 @@
bin/kdevassistant
bin/kdevdesigner
bin/kdevelop
bin/kdevelop-bin
bin/kdevelop-htdig
bin/kdevprj2kdevelop
bin/kdevprofileeditor