Upgrade to 1.6.
PR: 44482 Submitted by: KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
parent
ab7e557d65
commit
505f32f85a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68862
6 changed files with 29 additions and 63 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= nas
|
||||
PORTVERSION= 1.5
|
||||
PORTVERSION= 1.6
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://radscan.com/nas/
|
||||
EXTRACT_SUFX= .src.tar.gz
|
||||
|
@ -20,10 +20,6 @@ ALL_TARGET= World
|
|||
XMKMF= xmkmf
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.include "${.CURDIR}/Makefile.man"
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} \
|
||||
${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
|
||||
|
@ -31,4 +27,5 @@ post-patch:
|
|||
post-install:
|
||||
@${SED} -e 's:/usr/X11R6:${PREFIX}:g' ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include "Makefile.man"
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (nas-1.5.src.tar.gz) = 0726f5537b576d4d2c80208ae8b24946
|
||||
MD5 (nas-1.6.src.tar.gz) = 08b54fbf3af8c2ffab39f6f84f2ab337
|
||||
|
|
|
@ -1,6 +1,15 @@
|
|||
--- ./server/dda/voxware/auvoxware.c.orig Sun Apr 29 17:11:08 2001
|
||||
+++ ./server/dda/voxware/auvoxware.c Sat Sep 7 17:02:34 2002
|
||||
@@ -154,16 +154,11 @@
|
||||
--- server/dda/voxware/auvoxware.c.orig Thu Jul 25 09:42:28 2002
|
||||
+++ server/dda/voxware/auvoxware.c Sat Oct 26 02:54:26 2002
|
||||
@@ -133,7 +133,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
-#ifndef SVR4
|
||||
+#if !defined(SVR4) && !defined(__FreeBSD__)
|
||||
#include <getopt.h>
|
||||
#endif
|
||||
#include <sys/types.h>
|
||||
@@ -171,16 +171,11 @@
|
||||
#include <sys/param.h>
|
||||
#include <assert.h>
|
||||
|
||||
|
@ -21,38 +30,38 @@
|
|||
#endif
|
||||
|
||||
#include <audio/audio.h>
|
||||
@@ -624,7 +619,11 @@
|
||||
|
||||
@@ -659,7 +654,11 @@
|
||||
if(sndStatOut.fd == -1)
|
||||
{
|
||||
+#ifdef __FreeBSD__
|
||||
+ while ((sndStatOut.fd = open(sndStatOut.device, sndStatOut.howToOpen, 0666)) == -1 && wait)
|
||||
while ((sndStatOut.fd = open(sndStatOut.device,
|
||||
+#if defined(__FreeBSD__)
|
||||
+ sndStatOut.howToOpen|extramode,
|
||||
+#else
|
||||
while ((sndStatOut.fd = open(sndStatOut.device, sndStatOut.howToOpen|O_SYNC, 0666)) == -1 && wait)
|
||||
sndStatOut.howToOpen|O_SYNC|extramode,
|
||||
+#endif
|
||||
0666)) == -1 && wait)
|
||||
{
|
||||
osLogMsg("openDevice: waiting on output device\n");
|
||||
sleep(1);
|
||||
@@ -1269,6 +1268,11 @@
|
||||
@@ -1310,6 +1309,11 @@
|
||||
/*
|
||||
* Setup soundcard at maximum audio quality.
|
||||
*/
|
||||
+
|
||||
+#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__)
|
||||
+#define NO_16_BIT_SAMPLING
|
||||
+#endif
|
||||
+
|
||||
static void setupSoundcard(sndStatPtr)
|
||||
SndStat* sndStatPtr;
|
||||
{
|
||||
@@ -1425,7 +1429,11 @@
|
||||
osLogMsg("openDevice OUT %s mode %d\n",
|
||||
@@ -1472,7 +1476,11 @@
|
||||
sndStatOut.device, sndStatOut.howToOpen);
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+ if ((fd = open(sndStatOut.device, sndStatOut.howToOpen, 0)) == -1)
|
||||
if ((fd = open(sndStatOut.device,
|
||||
+#if defined(__FreeBSD__)
|
||||
+ sndStatOut.howToOpen|extramode, 0)) == -1)
|
||||
+#else
|
||||
if ((fd = open(sndStatOut.device, sndStatOut.howToOpen|O_SYNC, 0)) == -1)
|
||||
sndStatOut.howToOpen|O_SYNC|extramode, 0)) == -1)
|
||||
+#endif
|
||||
{
|
||||
UNIDENTMSG;
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- lib/audio/Astreams.c.orig Sun May 9 10:10:05 1999
|
||||
+++ lib/audio/Astreams.c Sat Mar 25 15:20:42 2000
|
||||
@@ -52,7 +52,9 @@
|
||||
#include <sys/stropts.h>
|
||||
|
||||
extern int errno;
|
||||
+#if !defined(BSD)
|
||||
extern char *sys_errlist[];
|
||||
+#endif
|
||||
|
||||
/* stolen from <X11/Xproto.h> */
|
||||
typedef struct {
|
|
@ -1,12 +0,0 @@
|
|||
--- ./lib/audio/Alibint.c.orig Sat Sep 7 17:07:48 2002
|
||||
+++ ./lib/audio/Alibint.c Sat Sep 7 17:07:58 2002
|
||||
@@ -1349,8 +1349,8 @@
|
||||
{
|
||||
#if !defined(__FreeBSD__) && !defined(__linux__) && !defined(__NetBSD__)
|
||||
extern char *sys_errlist[];
|
||||
-#endif
|
||||
extern int sys_nerr;
|
||||
+#endif
|
||||
char *s = (char *)((n >= 0 && n < sys_nerr) ? sys_errlist[n] : "unknown error");
|
||||
|
||||
return (s ? s : "no such error");
|
|
@ -1,16 +0,0 @@
|
|||
$FreeBSD$
|
||||
|
||||
utils.c:124: conflicting types for `sbrk'
|
||||
/usr/include/unistd.h:212: previous declaration of `sbrk'
|
||||
|
||||
--- server/os/utils.c.orig Sat May 25 10:07:51 2002
|
||||
+++ server/os/utils.c Sat May 25 10:21:48 2002
|
||||
@@ -120,7 +120,7 @@ static mutex print_lock
|
||||
|
||||
void ddxUseMsg(void);
|
||||
|
||||
-#if !defined(SVR4) && !defined(hpux) && !defined(linux) && !defined(AMOEBA) && !defined(_MINIX)
|
||||
+#if !defined(SVR4) && !defined(hpux) && !defined(linux) && !defined(AMOEBA) && !defined(_MINIX) && !defined(__FreeBSD__)
|
||||
extern char *sbrk();
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue