Oops. The libc_r weirdness of 4-STABLE and prior prevents this from
working. Mark as broken for systems < 500018.
This commit is contained in:
parent
469addae1f
commit
50a862a7b9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40408
2 changed files with 13 additions and 5 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= sdl
|
||||
PORTVERSION= 0.3
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel graphics audio ruby
|
||||
MASTER_SITES= http://www.kmc.kyoto-u.ac.jp/~ohai/rubysdl/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
|
@ -23,9 +24,16 @@ LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl-devel \
|
|||
USE_RUBY= yes
|
||||
USE_RUBY_EXTCONF= yes
|
||||
|
||||
CONFIGURE_ARGS= --with-sdl-config="sdl11-config"
|
||||
CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
|
||||
--with-cflags="-pthread" \
|
||||
--with-ldflags="-lc_r"
|
||||
INSTALL_TARGET= site-install
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.if ${OSVERSION} < 500018
|
||||
BROKEN= "libc_r conflicts with libc on your system. (Ruby/SDL can be used on 5-CURRENT only)"
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
|
||||
|
@ -34,4 +42,4 @@ post-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/ja/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- extconf.rb.orig Sun Mar 25 17:10:56 2001
|
||||
+++ extconf.rb Tue Mar 27 01:16:54 2001
|
||||
+++ extconf.rb Tue Mar 27 02:56:07 2001
|
||||
@@ -1,7 +1,9 @@
|
||||
require 'mkmf'
|
||||
|
||||
|
@ -7,8 +7,8 @@
|
|||
-$LDFLAGS += `sdl-config --libs`.chomp
|
||||
+sdl_config = with_config('sdl-config', 'sdl-config')
|
||||
+
|
||||
+$CFLAGS += `#{sdl_config} --cflags`.chomp
|
||||
+$LDFLAGS += `#{sdl_config} --libs`.chomp
|
||||
+$CFLAGS += ' ' + `#{sdl_config} --cflags`.chomp
|
||||
+$LDFLAGS += ' ' + `#{sdl_config} --libs`.chomp
|
||||
|
||||
if have_library("SDL_mixer","Mix_OpenAudio") then
|
||||
$CFLAGS+= " -D HAVE_SDL_MIXER "
|
||||
|
|
Loading…
Reference in a new issue