Update to 1.5.0

PR:		ports/190644
Submitted by:	maintainer
This commit is contained in:
Xin LI 2014-07-08 00:52:37 +00:00
parent c634b98f20
commit 511be198a1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=361149
4 changed files with 34 additions and 65 deletions

View file

@ -2,79 +2,43 @@
# $FreeBSD$
PORTNAME= ibus-pinyin
PORTVERSION= 1.4.0
PORTREVISION= 4
PORTVERSION= 1.5.0
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= henry.hu.sh@gmail.com
COMMENT= PinYin engine for IBus
BUILD_DEPENDS= ibus-daemon:${PORTSDIR}/textproc/ibus \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
RUN_DEPENDS= ibus-daemon:${PORTSDIR}/textproc/ibus \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>0:${PORTSDIR}/devel/py-xdg \
${LOCALBASE}/share/gir-1.0/IBus-1.0.gir:${PORTSDIR}/textproc/ibus
LIB_DEPENDS= libpyzy-1.0.so:${PORTSDIR}/chinese/pyzy \
libibus-1.0.so:${PORTSDIR}/textproc/ibus \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
USE_PYTHON= yes
USE_GNOME= pygtk2
USES= gmake pkgconfig compiler:c++0x
USES= gmake pkgconfig compiler:c++11-lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking --disable-lua-extension
PROJECTHOST= ibus
OPTIONS_DEFINE= ANDROID_DB OPENPHRASE_DB OPENCC NLS
OPTIONS_DEFAULT= ANDROID_DB
ANDROID_DB_DESC= Build Android DB
OPENPHRASE_DB_DESC= Build Open Phrase DB
OPENCC_DESC= Use opencc
OPTIONS_DEFINE= NLS
OPTIONS_DEFAULT= NLS
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MANDROID_DB}
CONFIGURE_ARGS+= --enable-db-android
PLIST_SUB+= ANDROID_DB=""
.else
CONFIGURE_ARGS+= --disable-db-android
PLIST_SUB+= ANDROID_DB="@comment "
.endif
OPENPHRASE_DBVER= 1.2.99
OPENPHRASE_DBFILE= pinyin-database-${OPENPHRASE_DBVER}.tar.bz2
.if ${PORT_OPTIONS:MOPENPHRASE_DB}
CONFIGURE_ARGS+= --enable-db-open-phrase
DISTFILES+= ${OPENPHRASE_DBFILE}
PLIST_SUB+= OPENPHRASE_DB=""
.else
CONFIGURE_ARGS+= --disable-db-open-phrase
PLIST_SUB+= OPENPHRASE_DB="@comment "
.endif
.if ${PORT_OPTIONS:MOPENCC}
CONFIGURE_ARGS+= --enable-opencc
LIB_DEPENDS+= libopencc.so:${PORTSDIR}/chinese/opencc
.else
CONFIGURE_ARGS+= --disable-opencc
.endif
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
USE_GNOME+= intltool
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
post-extract:
.if ${PORT_OPTIONS:MOPENPHRASE_DB}
@${CP} ${DISTDIR}/${OPENPHRASE_DBFILE} ${WRKSRC}/data/db/open-phrase
.endif
post-patch:
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' ${WRKSRC}/configure

View file

@ -1,4 +1,2 @@
SHA256 (ibus-pinyin-1.4.0.tar.gz) = 4fcaef6ac0533945c7feb4cb36fc72c102aae63b3fb4cbf338cdcc816182c24a
SIZE (ibus-pinyin-1.4.0.tar.gz) = 1813003
SHA256 (pinyin-database-1.2.99.tar.bz2) = 32c7d07b9f41e1dfc0f9008f54eca8e6cb367e7f2b19ac94c49754442694c321
SIZE (pinyin-database-1.2.99.tar.bz2) = 9977983
SHA256 (ibus-pinyin-1.5.0.tar.gz) = a85d458dcc51ea9fd65849e63002428b3fcb3b39adcbea9214b5cb4a4cbdbc96
SIZE (ibus-pinyin-1.5.0.tar.gz) = 692516

View file

@ -0,0 +1,12 @@
diff --git a/src/PYConfig.cc b/src/PYConfig.cc
index 7e24b2c..1ef0b99 100644
--- src/PYConfig.cc
+++ src/PYConfig.cc
@@ -114,6 +114,7 @@ Config::initDefaultValues (void)
m_init_full_punct = TRUE;
m_init_simp_chinese = TRUE;
m_special_phrases = TRUE;
+ m_double_pinyin = FALSE;
updateContext (PyZy::InputContext::PROPERTY_SPECIAL_PHRASE,
PyZy::Variant::fromBool (m_special_phrases));
}

View file

@ -1,13 +1,8 @@
%%NLS%%share/locale/ru/LC_MESSAGES/ibus-pinyin.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-pinyin.mo
%%NLS%%share/locale/zh_HK/LC_MESSAGES/ibus-pinyin.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/ibus-pinyin.mo
libexec/ibus-engine-pinyin
libexec/ibus-setup-pinyin
%%ANDROID_DB%%%%DATADIR%%/db/android.db
%%OPENPHRASE_DB%%%%DATADIR%%/db/open-phrase.db
share/applications/ibus-setup-bopomofo.desktop
share/applications/ibus-setup-pinyin.desktop
%%DATADIR%%/db/english.db
%%DATADIR%%/db/create_index.sql
%%DATADIR%%/icons/chinese.svg
%%DATADIR%%/icons/english.svg
%%DATADIR%%/icons/full-punct.svg
@ -27,14 +22,14 @@ libexec/ibus-setup-pinyin
%%DATADIR%%/setup/version.pyc
%%DATADIR%%/setup/version.pyo
share/ibus/component/pinyin.xml
%%NLS%%@dirrmtry share/locale/zh_CN/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/zh_CN
%%NLS%%@dirrmtry share/locale/ru/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ru
%%NLS%%@dirrmtry share/locale
%%NLS%%share/locale/fr/LC_MESSAGES/ibus-pinyin.mo
%%NLS%%share/locale/ru/LC_MESSAGES/ibus-pinyin.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-pinyin.mo
%%NLS%%share/locale/zh_HK/LC_MESSAGES/ibus-pinyin.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/ibus-pinyin.mo
@dirrmtry share/ibus/component
@dirrmtry share/ibus
@dirrm %%DATADIR%%/setup
@dirrm %%DATADIR%%/icons
@dirrmtry %%DATADIR%%/db
@dirrm %%DATADIR%%/db
@dirrm %%DATADIR%%