www/wabt: Update 1.0.29 -> 1.0.30

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2022-10-05 08:25:44 -07:00
parent f08c70e219
commit 5195e00c6a
4 changed files with 91 additions and 14 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= wabt
DISTVERSION= 1.0.29
DISTVERSION= 1.0.30
CATEGORIES= www
MAINTAINER= yuri@FreeBSD.org
@ -15,7 +15,7 @@ USES= cmake:testing localbase:ldflags python
USE_GITHUB= yes
GH_ACCOUNT= WebAssembly
GH_TUPLE= WebAssembly:testsuite:d42da0117f7a93c6a9127e2b9eec64749152c4c1:WebAssembly_testsuite/third_party/testsuite \
GH_TUPLE= WebAssembly:testsuite:4f77306bb63151631d84f58dedf67958eb9911b9:WebAssembly_testsuite/third_party/testsuite \
dabeaz:ply:d776a2ece6c12bf8f8b6a0e65b48546ac6078765:dabeaz_ply/third_party/ply \
WebAssembly:wasm-c-api:d9a80099d496b5cdba6f3fe8fc77586e0e505ddc:WebAssembly_wasm_c_api/third_party/wasm-c-api \
nodejs:uvwasi:55eff19f4c7e69ec151424a037f951e0ad006ed6:nodejs_uvwasi/third_party/uvwasi

View file

@ -1,8 +1,8 @@
TIMESTAMP = 1660702795
SHA256 (WebAssembly-wabt-1.0.29_GH0.tar.gz) = f770e2a68822d6f42441a911983d231e8637c17162415f599fd3f3415ef35d42
SIZE (WebAssembly-wabt-1.0.29_GH0.tar.gz) = 1150946
SHA256 (WebAssembly-testsuite-d42da0117f7a93c6a9127e2b9eec64749152c4c1_GH0.tar.gz) = 7fe2b4c620372bc5804671c6e88c02291d24c11f8721ad9535f0fcd4ca25becc
SIZE (WebAssembly-testsuite-d42da0117f7a93c6a9127e2b9eec64749152c4c1_GH0.tar.gz) = 639216
TIMESTAMP = 1664983116
SHA256 (WebAssembly-wabt-1.0.30_GH0.tar.gz) = 27891167abad1e35e180dc1cfbc33dbc345a25bccf44218a902e12bc03e605a0
SIZE (WebAssembly-wabt-1.0.30_GH0.tar.gz) = 1175828
SHA256 (WebAssembly-testsuite-4f77306bb63151631d84f58dedf67958eb9911b9_GH0.tar.gz) = 9afc0e7c250b5f0dcf32e9a95860b99a392ab78a653fcf3705778e8a9357f3c4
SIZE (WebAssembly-testsuite-4f77306bb63151631d84f58dedf67958eb9911b9_GH0.tar.gz) = 601571
SHA256 (dabeaz-ply-d776a2ece6c12bf8f8b6a0e65b48546ac6078765_GH0.tar.gz) = d9c0be0a3bd2ac09f81700bc808526f91e6e80d87ff619a8cab47c9417c4180d
SIZE (dabeaz-ply-d776a2ece6c12bf8f8b6a0e65b48546ac6078765_GH0.tar.gz) = 149974
SHA256 (WebAssembly-wasm-c-api-d9a80099d496b5cdba6f3fe8fc77586e0e505ddc_GH0.tar.gz) = aea8cd095e9937f1e14f2c93e026317b197eb2345e7a817fe3932062eb7b792c

View file

@ -1,18 +1,24 @@
--- CMakeLists.txt.orig 2022-08-16 23:13:55 UTC
--- CMakeLists.txt.orig 2022-09-30 21:24:30 UTC
+++ CMakeLists.txt
@@ -359,17 +359,17 @@ set(WABT_LIBRARY_SRC
src/interp/istream.cc
)
@@ -333,7 +333,7 @@ set(WABT_LIBRARY_H
set(WABT_LIBRARY_SRC ${WABT_LIBRARY_CC} ${WABT_LIBRARY_H})
-add_library(wabt STATIC ${WABT_LIBRARY_SRC})
+add_library(wabt ${WABT_LIBRARY_SRC})
add_library(wabt::wabt ALIAS wabt)
target_compile_features(wabt PUBLIC cxx_std_17)
@@ -358,7 +358,7 @@ if (WABT_INSTALL_RULES)
endif ()
IF (NOT WIN32)
- add_library(wasm-rt-impl STATIC wasm2c/wasm-rt-impl.c wasm2c/wasm-rt-impl.h)
+ add_library(wasm-rt-impl wasm2c/wasm-rt-impl.c wasm2c/wasm-rt-impl.h)
install(TARGETS wasm-rt-impl DESTINATION ${CMAKE_INSTALL_LIBDIR})
install(FILES wasm2c/wasm-rt.h wasm2c/wasm-rt-impl.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
endif ()
add_library(wabt::wasm-rt-impl ALIAS wasm-rt-impl)
if (WABT_BIG_ENDIAN)
target_compile_definitions(wasm-rt-impl PUBLIC WABT_BIG_ENDIAN=1)
@@ -381,7 +381,7 @@ endif ()
if (BUILD_FUZZ_TOOLS)
set(FUZZ_FLAGS "-fsanitize=fuzzer,address")

View file

@ -11,8 +11,79 @@ bin/wasm2wat
bin/wast2json
bin/wat-desugar
bin/wat2wasm
include/wabt/apply-names.h
include/wabt/base-types.h
include/wabt/binary-reader-ir.h
include/wabt/binary-reader-logging.h
include/wabt/binary-reader-nop.h
include/wabt/binary-reader-objdump.h
include/wabt/binary-reader-opcnt.h
include/wabt/binary-reader.h
include/wabt/binary-writer-spec.h
include/wabt/binary-writer.h
include/wabt/binary.h
include/wabt/binding-hash.h
include/wabt/c-writer.h
include/wabt/cast.h
include/wabt/circular-array.h
include/wabt/color.h
include/wabt/common.h
include/wabt/config.h
include/wabt/decompiler-ast.h
include/wabt/decompiler-ls.h
include/wabt/decompiler-naming.h
include/wabt/decompiler.h
include/wabt/error-formatter.h
include/wabt/error.h
include/wabt/expr-visitor.h
include/wabt/feature.def
include/wabt/feature.h
include/wabt/filenames.h
include/wabt/generate-names.h
include/wabt/interp/binary-reader-interp.h
include/wabt/interp/interp-inl.h
include/wabt/interp/interp-math.h
include/wabt/interp/interp-util.h
include/wabt/interp/interp-wasi.h
include/wabt/interp/interp.h
include/wabt/interp/istream.h
include/wabt/interp/wasi_api.def
include/wabt/intrusive-list.h
include/wabt/ir-util.h
include/wabt/ir.h
include/wabt/leb128.h
include/wabt/lexer-source-line-finder.h
include/wabt/lexer-source.h
include/wabt/literal.h
include/wabt/make-unique.h
include/wabt/opcode-code-table.h
include/wabt/opcode.def
include/wabt/opcode.h
include/wabt/option-parser.h
include/wabt/range.h
include/wabt/resolve-names.h
include/wabt/result.h
include/wabt/shared-validator.h
include/wabt/stream.h
include/wabt/string-format.h
include/wabt/string-util.h
include/wabt/token.def
include/wabt/token.h
include/wabt/tracing.h
include/wabt/type-checker.h
include/wabt/type.h
include/wabt/utf8.h
include/wabt/validator.h
include/wabt/wast-lexer.h
include/wabt/wast-parser.h
include/wabt/wat-writer.h
include/wasm-rt-impl.h
include/wasm-rt.h
lib/cmake/wabt/wabt-config-version.cmake
lib/cmake/wabt/wabt-config.cmake
lib/cmake/wabt/wabt-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/wabt/wabt-targets.cmake
lib/libwabt.so
lib/libwasm-rt-impl.so
share/man/man1/spectest-interp.1.gz
share/man/man1/wasm-decompile.1.gz