- Unbreak Code_Saturne;
- Adapt to the new infrastructure. Note: these ports should be upgraded - this is on my todo list.
This commit is contained in:
parent
02eb598200
commit
51bd54d267
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=349307
7 changed files with 58 additions and 51 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= ecs
|
||||
PORTVERSION= 2.0.2
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= http://research.edf.com/fichiers/fckeditor/Commun/Innovation/logiciels/code_saturne/Releases/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
|
@ -13,66 +13,62 @@ COMMENT= Code_Saturne Preprocessor
|
|||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= med.5:${PORTSDIR}/french/med \
|
||||
bft.1:${PORTSDIR}/science/bft \
|
||||
hdf5.7:${PORTSDIR}/science/hdf5-18 \
|
||||
cgns.3:${PORTSDIR}/science/cgnslib
|
||||
LIB_DEPENDS= libmed.so:${PORTSDIR}/french/med \
|
||||
libbft.so:${PORTSDIR}/science/bft \
|
||||
libhdf5.so.7:${PORTSDIR}/science/hdf5-18\
|
||||
libcgns.so:${PORTSDIR}/science/cgnslib
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
USES= gmake zip
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS= -I${LOCALBASE}/include
|
||||
CONFIGURE_ARGS= --with-bft=${LOCALBASE} \
|
||||
--with-hdf5=${LOCALBASE} \
|
||||
--with-cgns=${LOCALBASE} \
|
||||
--with-med=${LOCALBASE} \
|
||||
--with-metis=${LOCALBASE} \
|
||||
--with-metis-include=${LOCALBASE}/include/metis
|
||||
CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
|
||||
CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} CPPFLAGS="${CPPFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.if defined(WITH_CCMIO)
|
||||
LIB_DEPENDS+= adf.5:${PORTSDIR}/science/libccmio \
|
||||
ccmio.2:${PORTSDIR}/science/libccmio
|
||||
LIB_DEPENDS+= libadf.so:${PORTSDIR}/science/libccmio \
|
||||
libccmio.so:${PORTSDIR}/science/libccmio
|
||||
CONFIGURE_ARGS+=--with-adf=${LOCALBASE} \
|
||||
--with-ccm=${LOCALBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-adf --without-ccm
|
||||
.endif
|
||||
|
||||
NO_STAGE= yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS NLS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
NLS_USES= gettext iconv
|
||||
NLS_CONFIGURE_ENABLE= nls
|
||||
|
||||
DOCS_USE= TEX=tex:build
|
||||
DOCS_BUILD_DEPENDS= fig2dev:${PORTSDIR}/print/transfig
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MNLS}
|
||||
USES+= gettext iconv
|
||||
PLIST_SUB+= NLS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-nls
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
USE_TEX= tex:build
|
||||
BUILD_DEPENDS+= fig2dev:${PORTSDIR}/print/transfig
|
||||
PORTDOCS= mi_ecs.pdf mt_ecs.pdf
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
.endif
|
||||
|
||||
MAN1= cs_io_dump.1 cs_partition.1 cs_preprocess-config.1 cs_preprocess.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${LOCALBASE}/bin/partdmesh)
|
||||
.if exists(${LOCALBASE}/bin/graphchk)
|
||||
# The regular metis is present, so we cannot depend on metis-edf
|
||||
LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4
|
||||
LIB_DEPENDS+= libmetis.so.1:${PORTSDIR}/math/metis4
|
||||
.else
|
||||
# Prefer metis-edf to avoid conflict with Code_Aster
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/onmetis.exe:${PORTSDIR}/math/metis-edf
|
||||
LIB_DEPENDS+= libmetis.so.0:${PORTSDIR}/math/metis-edf
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "i386"
|
||||
|
@ -87,8 +83,8 @@ pre-configure:
|
|||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -2,4 +2,8 @@ bin/cs_preprocess-config
|
|||
bin/cs_preprocess
|
||||
bin/cs_partition
|
||||
bin/cs_io_dump
|
||||
man/man1/cs_io_dump.1.gz
|
||||
man/man1/cs_partition.1.gz
|
||||
man/man1/cs_preprocess-config.1.gz
|
||||
man/man1/cs_preprocess.1.gz
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/cs_preprocess.mo
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= fvm
|
||||
PORTVERSION= 0.15.3
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= science parallel
|
||||
MASTER_SITES= http://research.edf.com/fichiers/fckeditor/Commun/Innovation/logiciels/code_saturne/Releases/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
|
@ -13,10 +13,10 @@ COMMENT= Code_Saturne Finite Volume Mesh
|
|||
|
||||
LICENSE= LGPL21
|
||||
|
||||
LIB_DEPENDS= med.5:${PORTSDIR}/french/med \
|
||||
bft.1:${PORTSDIR}/science/bft \
|
||||
hdf5.7:${PORTSDIR}/science/hdf5-18 \
|
||||
cgns.3:${PORTSDIR}/science/cgnslib
|
||||
LIB_DEPENDS= libmed.so:${PORTSDIR}/french/med \
|
||||
libbft.so:${PORTSDIR}/science/bft \
|
||||
libhdf5.so.7:${PORTSDIR}/science/hdf5-18\
|
||||
libcgns.so:${PORTSDIR}/science/cgnslib
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
|
@ -47,11 +47,8 @@ CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}
|
|||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
MAN1= fvm-config.1
|
||||
|
||||
TESTSBIN= fvm_file_test fvm_interface_test fvm_selector_postfix_test fvm_selector_test
|
||||
|
||||
NO_STAGE= yes
|
||||
pre-configure:
|
||||
${REINPLACE_CMD} -e 's|-lmpich|-lmpich -lmpl|' \
|
||||
${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
|
|
|
@ -35,3 +35,4 @@ lib/libfvm_coupl.a
|
|||
lib/libfvm_coupl.la
|
||||
lib/libfvm_coupl.so
|
||||
lib/libfvm_coupl.so.0
|
||||
man/man1/fvm-config.1.gz
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= ncs
|
||||
PORTVERSION= 2.0.4
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= science parallel
|
||||
MASTER_SITES= http://research.edf.com/fichiers/fckeditor/Commun/Innovation/logiciels/code_saturne/Releases/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
|
@ -16,18 +16,19 @@ LICENSE= GPLv2
|
|||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=0:${PORTSDIR}/devel/py-qt4 \
|
||||
cs_preprocess:${PORTSDIR}/science/ecs \
|
||||
pyrcc4:${PORTSDIR}/textproc/py-qt4-xml
|
||||
LIB_DEPENDS= fvm.0:${PORTSDIR}/science/fvm \
|
||||
mei.0:${PORTSDIR}/science/mei
|
||||
LIB_DEPENDS= libfvm.so:${PORTSDIR}/science/fvm \
|
||||
libmei.so:${PORTSDIR}/science/mei
|
||||
RUN_DEPENDS= xmgrace:${PORTSDIR}/math/grace \
|
||||
bash:${PORTSDIR}/shells/bash \
|
||||
xterm:${PORTSDIR}/x11/xterm \
|
||||
cs_preprocess:${PORTSDIR}/science/ecs
|
||||
|
||||
USES= fortran gettext gmake iconv zip
|
||||
USES= fortran gettext gmake iconv zip shebangfix
|
||||
USE_GNOME= libxml2
|
||||
USE_PYTHON= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/libxml2
|
||||
SHEBANG_FILES= bin/runcase.in
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= MPI_LIBS="${MPI_LIBS}" \
|
||||
PYEXE="${PYTHON_CMD}"
|
||||
|
@ -35,6 +36,7 @@ MAKE_ENV= NOM_ARCH=${OPSYS} CS_MPI_PATH=${MPI_HOME}/bin \
|
|||
PTHREAD_LIBS=${PTHREAD_LIBS} TERM=${TERM} \
|
||||
MPI_HOME=${MPI_HOME} MPI_LIBS="${MPI_LIBS}"
|
||||
USE_LDCONFIG= yes
|
||||
NEED_ROOT= yes
|
||||
|
||||
FORTRANLIBDIR= `${DIRNAME} \\`${FC} -print-libgcc-file-name\\``
|
||||
FORTRANLIBDIR2= `${DIRNAME} \\`${FC} -print-libgcc-file-name\\``/../../../
|
||||
|
@ -51,8 +53,6 @@ BIN_SCRIPTS= autovalid check_mesh compiler_version cree_sat cs.exe gracehst \
|
|||
BIN_DATAS= Makefile SaturneGUI autovalid.xml cs_profile lance lance.help \
|
||||
macros_FreeBSD.mk
|
||||
|
||||
MAN1= code_saturne.1 cs_solver.1
|
||||
|
||||
.if defined(WITH_LAM)
|
||||
MPI_HOME= ${LOCALBASE}
|
||||
BUILD_DEPENDS+= ${MPI_HOME}/lib/liblam.a:${PORTSDIR}/net/lam
|
||||
|
@ -78,17 +78,16 @@ INSTALL_TARGET= install install-pdf
|
|||
DOCS= AUTHORS COMPATIBILITY ChangeLog README
|
||||
.endif
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
|
||||
WITH_ATLAS= yes
|
||||
.endif
|
||||
.if defined(WITH_ATLAS) && !defined(WITHOUT_ATLAS)
|
||||
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
|
||||
LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
|
||||
BLAS_LIB= -lf77blas
|
||||
.elif !defined(WITHOUT_BLAS)
|
||||
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
|
||||
LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
|
||||
BLAS_LIB= -lblas
|
||||
.endif
|
||||
|
||||
|
@ -107,16 +106,14 @@ pre-everything::
|
|||
@${ECHO_MSG} "WITHOUT_BLAS or WITHOUT_ATLAS if you prefer."
|
||||
@${ECHO_MSG}
|
||||
|
||||
pre-configure:
|
||||
${REINPLACE_CMD} -e 's|/bin/bash| ${LOCALBASE}/bin/bash|' ${WRKSRC}/bin/runcase.in
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${INSTALL_DATA} ${DOCS:C|^|${WRKSRC}/|} ${DOCSDIR}
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${DOCS:C|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
|
||||
.endif
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
10
science/ncs/files/patch-src_base_tremai.c
Normal file
10
science/ncs/files/patch-src_base_tremai.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/base/tremai.c.orig 2011-04-11 18:26:06.000000000 +0200
|
||||
+++ src/base/tremai.c 2014-03-26 23:51:58.000000000 +0100
|
||||
@@ -45,6 +45,7 @@
|
||||
#include <string.h>
|
||||
|
||||
#if defined(HAVE_SYS_RESOURCE_H)
|
||||
+#include <sys/types.h>
|
||||
#include <sys/resource.h>
|
||||
#endif
|
||||
|
|
@ -746,6 +746,8 @@ lib/libsyrcs.a
|
|||
lib/libsyrcs.la
|
||||
lib/libsyrcs.so
|
||||
lib/libsyrcs.so.0
|
||||
man/man1/code_saturne.1.gz
|
||||
man/man1/cs_solver.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COMPATIBILITY
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
|
|
Loading…
Reference in a new issue