- Update to 2.09

- This version adds multiple psk decode, watch more than one QSO
This commit is contained in:
Diane Bruce 2008-02-17 21:43:18 +00:00
parent 8dae7d08c8
commit 520bf74542
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=207490
4 changed files with 24 additions and 25 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= fldigi
PORTVERSION= 2.08
PORTVERSION= 2.09
CATEGORIES= comms hamradio
MASTER_SITES= http://www.w1hkj.com/fldigi-2.0.distro/ \
${MASTER_SITE_LOCAL}

View file

@ -1,3 +1,3 @@
MD5 (fldigi-2.08.tar.gz) = c4de82f422a5b3e3b29e168ac2f850b2
SHA256 (fldigi-2.08.tar.gz) = 024c2c090ca42bfea603c31198cb15e6be84cea1b298d73c26e991d0dcd470a8
SIZE (fldigi-2.08.tar.gz) = 540064
MD5 (fldigi-2.09.tar.gz) = 19b6e4b82ae15d58e158bebec81df466
SHA256 (fldigi-2.09.tar.gz) = cc1737aee1fc436834643a5eacbde8db22104933900ddcc9b91fe640b885f783
SIZE (fldigi-2.09.tar.gz) = 549546

View file

@ -1,21 +0,0 @@
--- src/Makefile.in.orig 2008-01-26 07:59:17.000000000 -0500
+++ src/Makefile.in 2008-01-31 11:42:23.000000000 -0500
@@ -280,15 +280,15 @@
target_alias = @target_alias@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-AM_CPPFLAGS = -I$(srcdir) -I$(srcdir)/include -I$(srcdir)/irrxml \
+AM_CPPFLAGS = @PORTAUDIO_CFLAGS@ -I$(srcdir) -I$(srcdir)/include -I$(srcdir)/irrxml \
@BOOST_CPPFLAGS@ $(am__append_1) $(am__append_3) \
$(am__append_4)
-AM_CXXFLAGS = @FLTK_CFLAGS@ @PORTAUDIO_CFLAGS@ @SNDFILE_CFLAGS@ \
+AM_CXXFLAGS = @PORTAUDIO_CFLAGS@ @FLTK_CFLAGS@ @SNDFILE_CFLAGS@ \
@SAMPLERATE_CFLAGS@ @HAMLIB_CFLAGS@ \
-pipe -Wall -O2 -ffast-math -fexceptions -finline-functions
AM_CFLAGS = $(AM_CXXFLAGS)
-LDADD = @BOOST_LDFLAGS@ @FLTK_LIBS@ @PORTAUDIO_LIBS@ @SNDFILE_LIBS@ \
+LDADD = @PORTAUDIO_LIBS@ @BOOST_LDFLAGS@ @FLTK_LIBS@ @SNDFILE_LIBS@ \
@SAMPLERATE_LIBS@ @HAMLIB_LIBS@ @RTLIB@ $(am__append_2)
SAMPLERATE_SRC = samplerate/common.h samplerate/fastest_coeffs.h \
samplerate/float_cast.h samplerate/samplerate.c samplerate/samplerate.h \

View file

@ -0,0 +1,20 @@
--- src/dialogs/Viewer.cxx.orig 2008-02-17 13:33:02.000000000 -0500
+++ src/dialogs/Viewer.cxx 2008-02-17 13:35:44.000000000 -0500
@@ -87,7 +87,7 @@
#ifdef REGEX
regex_t* seek_re = 0;
-void re_comp(const char* needle)
+void fl_re_comp(const char* needle)
{
if (seek_re)
regfree(seek_re);
@@ -292,7 +292,7 @@
for (size_t i = 0; i < tofind.length(); i++)
tofind[i] = toupper(tofind[i]);
#else
- re_comp(inpSeek->value());
+ fl_re_comp(inpSeek->value());
#endif
}