- Update to 1.3.2 and unbreak on 5.x
- Switch maintainer to ports@FreeBSD.org PR: ports/62390 Submitted by: hrs
This commit is contained in:
parent
d55e243de2
commit
52168317e2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100832
3 changed files with 23 additions and 7 deletions
|
@ -6,12 +6,12 @@
|
|||
#
|
||||
|
||||
PORTNAME= html2text
|
||||
PORTVERSION= 1.3.1
|
||||
PORTVERSION= 1.3.2
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://userpage.fu-berlin.de/~mbayer/tools/ \
|
||||
ftp://ftp.ibiblio.org/pub/linux/apps/www/converters/
|
||||
|
||||
MAINTAINER= corecode@corecode.ath.cx
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Converts HTML documents into plain text
|
||||
|
||||
USE_REINPLACE= yes
|
||||
|
@ -25,10 +25,6 @@ DOCS= CHANGES COPYING CREDITS KNOWN_BUGS README TODO
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 502000
|
||||
BROKEN= "Does not compile"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/echo=/s/ -e//' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; /^CXXFLAGS/s/=/+=/' \
|
||||
|
|
|
@ -1 +1,2 @@
|
|||
MD5 (html2text-1.3.1.tar.gz) = faa3eaeb062540e72d251d6c3fa6cc71
|
||||
MD5 (html2text-1.3.2.tar.gz) = 14b091c7c5cb5c3bc2ce19298a0c0e27
|
||||
SIZE (html2text-1.3.2.tar.gz) = 131336
|
||||
|
|
19
textproc/html2text/files/patch-format.C
Normal file
19
textproc/html2text/files/patch-format.C
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- format.C Mon Jul 29 20:12:13 2002
|
||||
+++ format.C Thu Feb 5 22:47:07 2004
|
||||
@@ -34,7 +34,7 @@
|
||||
/***************************************************************************/
|
||||
|
||||
|
||||
-#include <strstream.h>
|
||||
+#include <strstream>
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <ctype.h>
|
||||
@@ -50,6 +50,7 @@
|
||||
|
||||
using std::endl;
|
||||
using std::flush;
|
||||
+using std::ostrstream;
|
||||
|
||||
#ifndef nelems
|
||||
#define nelems(array) (sizeof(array) / sizeof((array)[0]))
|
Loading…
Reference in a new issue