- Update to 0.38.1

- Workaround internal compiller error on -STABLE [1]
- More build patches incl. fix for build with antiqe STL on -STABLE

Reported by:	Lee Harr <missive@hotmail.com> [1]
This commit is contained in:
Alexander Nedotsukov 2004-04-12 16:20:45 +00:00
parent 5c000ea5a2
commit 5249e13e8b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106818
8 changed files with 163 additions and 15 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= inkscape
PORTVERSION= 0.38
PORTVERSION= 0.38.1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -32,6 +32,10 @@ MAN1= inkscape.1 inkview.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old_gcc_bugs
.endif
post-patch:
@${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' \
${WRKSRC}/src/helper/action.cpp \

View file

@ -1,2 +1,2 @@
MD5 (inkscape-0.38.tar.gz) = eadbc6200d2d984328db8e77068196c1
SIZE (inkscape-0.38.tar.gz) = 3301867
MD5 (inkscape-0.38.1.tar.gz) = ea486c528649a34827b74077ffd2076c
SIZE (inkscape-0.38.1.tar.gz) = 3301980

View file

@ -0,0 +1,116 @@
--- src/dialogs/desktop-properties.cpp.orig Mon Apr 12 11:12:20 2004
+++ src/dialogs/desktop-properties.cpp Mon Apr 12 11:11:10 2004
@@ -11,7 +11,6 @@
* Released under GNU GPL, read the file 'COPYING' for more information
*/
-#include <locale>
#include <sstream>
#include <config.h>
@@ -266,7 +265,6 @@
gdouble vbWidth = (gdouble)atof(sp_repr_attr (repr, "width")) * 1.25;
gdouble vbHeight = (gdouble)atof(sp_repr_attr (repr, "height")) * 1.25;
std::ostringstream os;
- os.imbue(std::locale::classic());
os.setf(std::ios::showpoint);
os.precision(8);
os << "0 0 " << vbWidth << " " << vbHeight;
--- src/document.cpp.orig Mon Apr 12 10:42:05 2004
+++ src/document.cpp Mon Apr 12 10:42:12 2004
@@ -42,7 +42,6 @@
#define SP_DOCUMENT_UPDATE_PRIORITY (G_PRIORITY_HIGH_IDLE - 1)
-#include <locale>
#include <sstream>
enum {
--- src/libnr/nr-rect.h.orig Mon Apr 12 09:28:10 2004
+++ src/libnr/nr-rect.h Mon Apr 12 09:29:19 2004
@@ -107,6 +107,33 @@
/** returns the midpoint of this rect. */
Point midpoint() const;
+private:
+ template <NR::Dim2 axis>
+ double extent() const {
+ return _max[axis] - _min[axis];
+ }
+
+ template <Dim2 axis>
+ bool isEmpty() const {
+ return !( _min[axis] < _max[axis] );
+ }
+
+ template <Dim2 axis>
+ bool intersects(const Rect &r) const {
+ return _max[axis] >= r._min[axis] && _min[axis] <= r._max[axis];
+ }
+
+ template <Dim2 axis>
+ bool contains(const Rect &r) const {
+ return contains(r._min) && contains(r._max);
+ }
+
+ template <Dim2 axis>
+ bool contains(const Point &p) const {
+ return p[axis] >= _min[axis] && p[axis] <= _max[axis];
+ }
+
+public:
/** does this rectangle have zero area? */
bool isEmpty() const {
return isEmpty<X>() && isEmpty<Y>();
@@ -162,31 +189,6 @@
private:
Rect() {}
-
- template <NR::Dim2 axis>
- double extent() const {
- return _max[axis] - _min[axis];
- }
-
- template <Dim2 axis>
- bool isEmpty() const {
- return !( _min[axis] < _max[axis] );
- }
-
- template <Dim2 axis>
- bool intersects(const Rect &r) const {
- return _max[axis] >= r._min[axis] && _min[axis] <= r._max[axis];
- }
-
- template <Dim2 axis>
- bool contains(const Rect &r) const {
- return contains(r._min) && contains(r._max);
- }
-
- template <Dim2 axis>
- bool contains(const Point &p) const {
- return p[axis] >= _min[axis] && p[axis] <= _max[axis];
- }
Point _min, _max;
--- src/svg/stringstream.h.orig Sat Apr 10 04:39:51 2004
+++ src/svg/stringstream.h Sat Apr 10 04:44:36 2004
@@ -9,7 +9,6 @@
public:
SVGOStringStream() {
- this->imbue(std::locale::classic());
this->setf(std::ios::showpoint);
this->precision(8);
}
--- src/svg/svg-path.cpp.orig Mon Apr 12 11:16:05 2004
+++ src/svg/svg-path.cpp Mon Apr 12 11:15:56 2004
@@ -33,7 +33,6 @@
#include "svg.h"
#include "stringstream.h"
-#include <locale>
#include <sstream>
/* This module parses an SVG path element into an RsvgBpathDef.

View file

@ -1,4 +1,4 @@
--- configure.tmp Sat Apr 10 03:28:51 2004
--- configure.orig Sat Apr 10 03:28:51 2004
+++ configure Sat Apr 10 04:47:54 2004
@@ -16589,17 +16589,12 @@
cat >>conftest.$ac_ext <<_ACEOF

View file

@ -0,0 +1,10 @@
--- src/livarot/Path.cpp.orig Sat Apr 10 03:53:47 2004
+++ src/livarot/Path.cpp Sat Apr 10 03:53:52 2004
@@ -7,6 +7,7 @@
*/
#include <glib.h>
+#include <cstdio>
#include "Path.h"
#include <libnr/nr-point.h>
#include <libnr/nr-point-ops.h>

View file

@ -0,0 +1,10 @@
--- src/livarot/PathOutline.cpp.orig Sat Apr 10 04:09:41 2004
+++ src/livarot/PathOutline.cpp Sat Apr 10 04:34:35 2004
@@ -9,6 +9,7 @@
#include "Path.h"
//#include "MyMath.h"
#include <math.h>
+#include <algorithm>
#include <libnr/nr-point-fns.h>
/*

View file

@ -0,0 +1,19 @@
--- src/remove-last.h.orig Mon Apr 12 09:56:06 2004
+++ src/remove-last.h Mon Apr 12 09:56:47 2004
@@ -2,6 +2,7 @@
#define __REMOVE_LAST_H__
#include <vector>
+#include <algorithm>
#include <glib.h>
template<class T>
@@ -9,7 +10,7 @@
{
using std::vector;
- typename vector<T>::reverse_iterator i(find(seq.rbegin(), seq.rend(), elem));
+ typename vector<T>::reverse_iterator i(std::find(seq.rbegin(), seq.rend(), elem));
g_assert( i != seq.rend() );
typename vector<T>::iterator ii(&*i);
seq.erase(ii);

View file

@ -1,11 +0,0 @@
--- src/svg/ftos.cpp.orig Sat Apr 10 04:00:08 2004
+++ src/svg/ftos.cpp Sat Apr 10 03:59:33 2004
@@ -164,7 +164,7 @@
using namespace std;
#ifdef __FreeBSD__
-#include <stdio>
+#include <stdio.h>
#endif
#include "ftos.h"