- Unbreak
This commit is contained in:
parent
4b198e97b3
commit
52756d084a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=248723
2 changed files with 13 additions and 5 deletions
|
@ -26,8 +26,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois \
|
|||
RUN_DEPENDS= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois \
|
||||
xset:${PORTSDIR}/x11/xset
|
||||
|
||||
BROKEN= does not build
|
||||
|
||||
USE_ZIP= yes
|
||||
USE_OPENAL= al
|
||||
USE_XORG= x11 xt xaw sm ice xext
|
||||
|
|
|
@ -1,6 +1,16 @@
|
|||
--- configurator/CMakeLists.txt.orig 2009-06-25 22:30:12.000000000 +0400
|
||||
+++ configurator/CMakeLists.txt 2009-08-13 19:19:37.000000000 +0400
|
||||
@@ -27,9 +27,10 @@
|
||||
+++ configurator/CMakeLists.txt 2010-01-27 22:29:11.000000000 +0300
|
||||
@@ -12,6 +12,9 @@
|
||||
|
||||
FIND_PACKAGE(wxWidgets COMPONENTS base core html net)
|
||||
IF(wxWidgets_FOUND)
|
||||
+ STRING(REGEX REPLACE ";" ";-D" wxWidgets_DEFINITIONS "${wxWidgets_DEFINITIONS}")
|
||||
+ SET(wxWidgets_DEFINITIONS "-D${wxWidgets_DEFINITIONS}")
|
||||
+
|
||||
include_directories(${wxWidgets_INCLUDE_DIRS})
|
||||
add_definitions(${wxWidgets_DEFINITIONS} ${wxWidgets_CXX_FLAGS})
|
||||
|
||||
@@ -27,9 +30,10 @@
|
||||
link_directories (${wxWidgets_LIB_DIR})
|
||||
include_directories (${RoR_Dependencies_SOURCE_DIR}/rorserver-sf/source)
|
||||
include_directories (${RoR_Dependencies_SOURCE_DIR}/ogrenew/OgreMain/include)
|
||||
|
@ -13,7 +23,7 @@
|
|||
|
||||
SET(config_source ${config_source} ${RoR_SOURCE_DIR}/main/source/InputEngine.cpp)
|
||||
|
||||
@@ -48,7 +49,7 @@
|
||||
@@ -48,7 +52,7 @@
|
||||
|
||||
add_executable(rorconfig ${config_source} ${config_headers} ${config_res})
|
||||
TARGET_LINK_LIBRARIES(rorconfig ${wxWidgets_LIBRARIES} )
|
||||
|
|
Loading…
Reference in a new issue