- Add graphics/rubygem-exifr, a pure-ruby EXIF reader.
This commit is contained in:
parent
dd58ad9dec
commit
5282b73e06
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=221201
6 changed files with 75 additions and 0 deletions
|
@ -718,6 +718,7 @@
|
|||
SUBDIR += ruby-svg
|
||||
SUBDIR += ruby-tgif
|
||||
SUBDIR += rubygem-captcha
|
||||
SUBDIR += rubygem-exifr
|
||||
SUBDIR += rubygem-gd2
|
||||
SUBDIR += rubygem-gruff
|
||||
SUBDIR += rubygem-railroad
|
||||
|
|
27
graphics/rubygem-exifr/Makefile
Normal file
27
graphics/rubygem-exifr/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# Ports collection makefile for: rubygem-exifr
|
||||
# Date created: 4 October 2008
|
||||
# Whom: stas
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= exifr
|
||||
PORTVERSION= 0.10.6
|
||||
CATEGORIES= graphics rubygems
|
||||
MASTER_SITES= RF
|
||||
|
||||
MAINTAINER= stas@FreeBSD.org
|
||||
COMMENT= A pure-ruby EXIF reader
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RUBYGEMS= yes
|
||||
|
||||
post-install:
|
||||
cd ${PREFIX}/${GEM_LIB_DIR}/bin && \
|
||||
${PATCH} -p0 < ${FILESDIR}/exifr.patch && \
|
||||
${RM} -f ${PREFIX}/${GEM_LIB_DIR}/bin/exifr.orig
|
||||
@${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | \
|
||||
${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
|
||||
@${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | \
|
||||
${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.mk>
|
3
graphics/rubygem-exifr/distinfo
Normal file
3
graphics/rubygem-exifr/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (rubygem/exifr-0.10.6.gem) = 6256d24af55812c40dfc9a23329d9cb6
|
||||
SHA256 (rubygem/exifr-0.10.6.gem) = b17a708706bb2c40a201ed2bf23264c216fd49e10a745959c0af4c5afeca68a5
|
||||
SIZE (rubygem/exifr-0.10.6.gem) = 207872
|
7
graphics/rubygem-exifr/files/exifr.patch
Normal file
7
graphics/rubygem-exifr/files/exifr.patch
Normal file
|
@ -0,0 +1,7 @@
|
|||
--- exifr.orig 2008-10-05 03:17:11.000000000 +0400
|
||||
+++ exifr 2008-10-05 03:17:38.000000000 +0400
|
||||
@@ -1,3 +1,4 @@
|
||||
+require 'rubygems'
|
||||
require 'exifr'
|
||||
include EXIFR
|
||||
|
4
graphics/rubygem-exifr/pkg-descr
Normal file
4
graphics/rubygem-exifr/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
Exifr is a pure ruby library to extract EXIF info from
|
||||
image files. Both JPEG and TIFF formats are supported.
|
||||
|
||||
WWW: http://rubyforge.org/projects/exifr
|
33
graphics/rubygem-exifr/pkg-plist
Normal file
33
graphics/rubygem-exifr/pkg-plist
Normal file
|
@ -0,0 +1,33 @@
|
|||
%%GEM_CACHE%%
|
||||
%%GEM_LIB_DIR%%/CHANGELOG
|
||||
%%GEM_LIB_DIR%%/README
|
||||
%%GEM_LIB_DIR%%/Rakefile
|
||||
%%GEM_LIB_DIR%%/bin/exifr
|
||||
%%GEM_LIB_DIR%%/lib/exifr.rb
|
||||
%%GEM_LIB_DIR%%/lib/jpeg.rb
|
||||
%%GEM_LIB_DIR%%/lib/tiff.rb
|
||||
%%GEM_LIB_DIR%%/tests/data/1x1.jpg
|
||||
%%GEM_LIB_DIR%%/tests/data/Canon_PowerShot_A85.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/Casio-EX-S20.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/FUJIFILM-FinePix_S3000.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/Panasonic-DMC-LC33.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/Trust-DC3500_MINI.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/apple-aperture-1.5.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/canon-g3.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/endless-loop.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/exif.jpg
|
||||
%%GEM_LIB_DIR%%/tests/data/gps.exif
|
||||
%%GEM_LIB_DIR%%/tests/data/image.jpg
|
||||
%%GEM_LIB_DIR%%/tests/data/multiple-app1.jpg
|
||||
%%GEM_LIB_DIR%%/tests/data/nikon_d1x.tif
|
||||
%%GEM_LIB_DIR%%/tests/data/plain.tif
|
||||
%%GEM_LIB_DIR%%/tests/data/weird_date.exif
|
||||
%%GEM_LIB_DIR%%/tests/test_helper.rb
|
||||
%%GEM_LIB_DIR%%/tests/test_jpeg.rb
|
||||
%%GEM_LIB_DIR%%/tests/test_tiff.rb
|
||||
%%GEM_SPEC%%
|
||||
@dirrm %%GEM_LIB_DIR%%/bin
|
||||
@dirrm %%GEM_LIB_DIR%%/lib
|
||||
@dirrm %%GEM_LIB_DIR%%/tests/data
|
||||
@dirrm %%GEM_LIB_DIR%%/tests
|
||||
@dirrm %%GEM_LIB_DIR%%
|
Loading…
Reference in a new issue