- Fix build

- Add several libraries, utilities and documents

PR:		44349
Submitted by:	Ports Fury
This commit is contained in:
Ying-Chieh Liao 2002-10-22 06:12:06 +00:00
parent 5e457c68d7
commit 529e2d348b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68573
18 changed files with 711 additions and 47 deletions

View file

@ -8,37 +8,92 @@
PORTNAME= sather
PORTVERSION= 1.2.1
PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= sather
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libgc.a:${PORTSDIR}/devel/boehm-gc
LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc \
tk83.1:${PORTSDIR}/x11-toolkits/tk83
USE_REINPLACE= yes
USE_GMAKE= yes
ALL_TARGET= full
MAN1= sacomp.1
ALL_TARGET= full optional
MAN1= sabrowse.1 sacomp.1
pre-configure:
@${REINPLACE_CMD} \
-e "s:%%CC%%:${CC}:g ;" \
-e "s:%%CFLAGS%%:${CFLAGS}:g ;" \
-e "s:%%LOCALBASE%%:${LOCALBASE}:g ;" \
-e "s:%%GMAKE%%:${GMAKE}:g ;" \
${WRKSRC}/System/Common/CONFIG.proto
post-extract:
@${MKDIR} ${WRKSRC}/System/Platforms/freebsd
.for file in CONFIG Makefile Platform.module header.h
@${CP} -f ${FILESDIR}/freebsd-${file} \
${WRKSRC}/System/Platforms/freebsd/${file}
.endfor
post-patch:
.for file in Boot/sacomp.code/Makefile Browser/Web/convert-1.1 \
Browser/Web/gen_html_class_index Browser/Web/gen_html_sa_files \
Browser/Web/gen_html_shortflat Browser/Web/gen_html_top_level \
Browser/Web/gen_mml_sa_files Browser/Web/gen_mml_shortflat \
Browser/Web/graph2dot Library/System/unix.sa \
System/Common/CONFIG.proto System/Platforms/freebsd/CONFIG \
System/Platforms/X/Platform.module debian/bin-wrapper
@${REINPLACE_CMD} -e 's|%%VERSION%%|${PORTVERSION}|g ; \
s|%%CC%%|${CC}|g ; \
s|%%CFLAGS%%|${CFLAGS}|g ; \
s|%%GMAKE%%|${GMAKE}|g ; \
s|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g ; \
s|CONFIG_PLATFORMS|unix|g ; \
s|CONFIG_DEFAULT_PLATFORM|freebsd|g ; \
s|/usr/bin/tclsh|${LOCALBASE}/bin/tclsh8.3|g' ${WRKSRC}/${file}
.endfor
post-build:
.for file in sather-tutorial.texinfo sather-mode.texinfo sather.texinfo
cd ${WRKSRC}/Emacs && /usr/bin/makeinfo --no-split ${file}
.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/Bin/sacomp ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/Doc/man/man1/sacomp.1 ${PREFIX}/man/man1
@${MKDIR} ${PREFIX}/share/doc/sather
${INSTALL_DATA} ${WRKSRC}/Doc/License ${PREFIX}/share/doc/sather
.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sather
.for file in Bugs Changes Contributing FAQ programmer-manual.ps
${INSTALL_DATA} ${WRKSRC}/Doc/${file} ${PREFIX}/share/doc/sather
@${MKDIR} ${PREFIX}/lib/sather/Bin
.for file in sabrowse sacomp
${INSTALL_PROGRAM} ${WRKSRC}/Bin/${file} ${PREFIX}/lib/sather/Bin
.endfor
.for file in PP gen_html saprep
${INSTALL_SCRIPT} ${WRKSRC}/Bin/${file} ${PREFIX}/lib/sather/Bin
.endfor
${INSTALL_SCRIPT} ${WRKSRC}/debian/bin-wrapper ${PREFIX}/lib/sather/Bin
.for link in sabrowse sacomp
${LN} -sf ${PREFIX}/lib/sather/Bin/bin-wrapper ${PREFIX}/bin/${link}
.endfor
.for obj in Browser Library System/Common System/Debug System/FORBID \
System/Platforms/X System/Platforms/dualgui System/Platforms/f77 \
System/Platforms/freebsd System/Platforms/gui System/Platforms/tcltk
${TAR} -C ${WRKSRC} -cf - \
--exclude "ActiveThreads" --exclude "Brahma" \
--exclude "CONFIG.proto" --exclude "Siva" \
--exclude "dual_gui_server.code" --exclude "*.bak" \
--exclude "*.config" --exclude "*.orig" \
--exclude "*Makefile*" ${obj} | \
${TAR} -C ${PREFIX}/lib/sather --unlink -xf -
@${CHOWN} -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/sather/${obj}
.endfor
.for file in sabrowse.1 sacomp.1
${INSTALL_MAN} ${WRKSRC}/Doc/man/man1/${file} ${MANPREFIX}/man/man1
.endfor
.for file in sather-mode.info sather-tutorial.info sather.info
${INSTALL_DATA} ${WRKSRC}/Emacs/${file} ${PREFIX}/info
@install-info ${PREFIX}/info/${file} ${PREFIX}/info/dir
.endfor
.for file in hl319.el sather-lib.el sather-module.el sather.el
${INSTALL_DATA} ${WRKSRC}/Emacs/${file} ${PREFIX}/share/emacs/site-lisp
.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${TAR} -C ${WRKSRC}/Doc --exclude '*GPL' --exclude man -cf - . | \
${TAR} -C ${DOCSDIR} --unlink -xf -
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
CC_OPTIONS: "-I%%LOCALBASE%%/include -I%%X11BASE%%/include -I%%LOCALBASE%%/include/tcl8.3 -I%%LOCALBASE%%/include/tk8.3 ";

View file

@ -0,0 +1,7 @@
all:
clean:
test:
boot:
ln -s `pwd`/header.h ../BOOT
$(MAKE) -C $(SATHER_HOME)/Boot/sacomp.code CC=$(CC)
rm -f ../BOOT/header.h

View file

@ -0,0 +1,5 @@
$(SATHER_HOME)/Library/System/Socket/Socket.module
-external C_SOCKET "$(SATHER_HOME)/Library/System/Socket/socket_support.c " -end
-external BROWSER " " -end
-external C_TCL_TK " " -end

View file

@ -0,0 +1,14 @@
#ifndef _HEADER_H_
#define _HEADER_H_
#ifndef ZONES
# include <gc.h>
#endif
#include "../../Common/c_header.h"
#include "../../Common/runtime.h"
#undef GC_ENABLE_INCREMENTAL
#endif

View file

@ -4,9 +4,9 @@
SHOME =../..
-CFLAGS = -I. -O2 -I../System/Common
-CC =gcc
+CFLAGS += -I. -I../System/Common -I${LOCALBASE}/include
+CC ?=gcc
+CFLAGS = -I. %%CFLAGS%% -I../System/Common -I%%LOCALBASE%%/include
+CC =%%CC%%
HDR =sather.h tags.h
-LIBS = -lgc -lm
+LIBS = -lgc -lm -L${LOCALBASE}/lib
+LIBS = -lgc -lm -L%%LOCALBASE%%/lib
CS =sacomp

View file

@ -0,0 +1,19 @@
--- Emacs/sather-mode.texinfo.orig Wed Nov 3 22:09:35 1999
+++ Emacs/sather-mode.texinfo Thu May 2 22:00:14 2002
@@ -5,7 +5,16 @@
@setchapternewpage off
@c %**end of header
+
@ifinfo
+@format
+INFO-DIR-SECTION Sather
+START-INFO-DIR-ENTRY
+* sather-mode: (sather-mode).
+ The Sather Emacs Programming Environment.
+END-INFO-DIR-ENTRY
+@end format
+
This file describes the Emacs editing environment for the Sather
language.

View file

@ -0,0 +1,17 @@
--- Emacs/sather-tutorial.texinfo.orig Wed Nov 3 22:09:35 1999
+++ Emacs/sather-tutorial.texinfo Thu May 2 22:01:24 2002
@@ -7,6 +7,14 @@
@setchapternewpage odd
@ifinfo
+@format
+INFO-DIR-SECTION Sather
+START-INFO-DIR-ENTRY
+* sather-tutorial: (sather-tutorial).
+ The Sather Eclectic Tutorial.
+END-INFO-DIR-ENTRY
+@end format
+
Sather Eclectic Tutorial
Copyright (C) 1995 by International Computer Science Institute

View file

@ -0,0 +1,16 @@
--- Emacs/sather.texinfo.orig Sun Jul 25 17:23:34 1999
+++ Emacs/sather.texinfo Thu May 2 22:01:13 2002
@@ -9,6 +9,13 @@
@c %**end of header
@ifinfo
+@format
+INFO-DIR-SECTION Sather
+START-INFO-DIR-ENTRY
+* sather: (sather). The Sather Specification.
+END-INFO-DIR-ENTRY
+@end format
+
This file describes the Sather language.
Copyright (C) 1995 by International Computer Science Institute

View file

@ -0,0 +1,11 @@
--- Library/System/unix.sa.orig Wed Oct 13 13:34:47 1999
+++ Library/System/unix.sa
@@ -20,7 +20,7 @@
sather_home: STR is
r ::= get_env("SATHER_HOME");
if void(r) then
- r := "/usr/lib/sather";
+ r := "%%PREFIX%%/lib/sather";
end;
if r[r.size-1] = '/' then
raise "Environment variable SATHER_HOME should not end with /";

View file

@ -0,0 +1,22 @@
--- Makefile.orig Thu Nov 4 17:04:28 1999
+++ Makefile Fri Oct 11 10:13:26 2002
@@ -30,8 +30,8 @@
LN=ln -s
CP=cp
-CPP=/lib/cpp -C -P
-CC=gcc
+CPP=/usr/bin/cpp -C -P
+CC?=cc
EXEC_SUFFIX=
# CC is only used for bootstrapping, check System/Common/CONFIG.proto if
# you want to change it for all Sather compilations
@@ -90,7 +90,7 @@
# The platform to use if not overridden by a -<platform> option
# or the SATHER_PLATFORM environment variable
# Should be edited for a particular system
-DEFAULT_PLATFORM=unix
+DEFAULT_PLATFORM=freebsd
# The platform used to compile the boot compiler. Usually just default, but has to
# be one of: freebsd, hpux_at, iris-4, linux, osf_at, solaris, solaris_at, unix,

View file

@ -1,5 +1,5 @@
--- System/Common/CONFIG.proto.orig Thu Nov 4 03:48:17 1999
+++ System/Common/CONFIG.proto Wed Feb 2 20:25:35 2000
+++ System/Common/CONFIG.proto Fri Oct 11 10:15:05 2002
@@ -23,12 +23,12 @@
ZONES: false;
TRACE: false;
@ -8,7 +8,7 @@
-C_COMPILER: "gcc ";
-CC_OPTIONS: "";
-GC_LINK: "-lgc";
+VERSION: "1.2.1";
+VERSION: "%%VERSION%%";
+C_COMPILER: "%%CC%% ";
+CC_OPTIONS: "-I%%LOCALBASE%%/include";
+GC_LINK: "-lgc -L%%LOCALBASE%%/lib";
@ -18,7 +18,7 @@
OBJECT_EXT: ".o";
LIB_EXT: ".a";
C_EXT: ".c";
@@ -38,7 +38,7 @@
@@ -38,11 +38,11 @@
SEPARATE_POINTERS: false;
PSATHER_FLAG: "","";
CC_DEBUG_FLAG: "","-g";
@ -27,3 +27,8 @@
CC_PROLIX_FLAG: "",""; -- passed to the C compiler (prolix implies verbose)
MAKE_VERBOSE_FLAG: "-s","-s"; -- passed to make
-FORTRAN_APPEND_UNDERSCORE: "false";
+FORTRAN_APPEND_UNDERSCORE: "true";
FORTRAN_PREFIX_UNDERSCORE: "false";
FORTRAN_BIND_FUNC: "true";

View file

@ -0,0 +1,15 @@
--- System/Platforms/X/Platform.module.orig Thu May 2 17:18:27 2002
+++ System/Platforms/X/Platform.module Thu May 2 17:19:33 2002
@@ -16,10 +16,10 @@
-- Gui, DualGui and the Browser all rely on these paths
-not_a_real_platform
--C_flag -I/usr/X11R6/include/X11/ -- Expected to contain X11/ headers
+-C_flag -I%%X11BASE%%/include -- Expected to contain X11/ headers
-- -C_flag -lm
--C_flag -L/usr/X11R6/lib/ -- Expected to contain libX11.a
+-C_flag -L%%X11BASE%%/lib -- Expected to contain libX11.a
-C_flag -lX11

View file

@ -0,0 +1,7 @@
--- System/Platforms/tcltk/Make.target.inc.orig Thu May 2 17:21:52 2002
+++ System/Platforms/tcltk/Make.target.inc Thu May 2 17:21:35 2002
@@ -1,2 +1,2 @@
-TCL_LIB_NAME = $(shell if [ -e /usr/lib/libtcl8.0.so ] ; then echo "tcl8.0" ; else echo "tcl"; fi)
-TK_LIB_NAME = $(shell if [ -e /usr/lib/libtk8.0.so ] ; then echo "tk8.0" ; else echo "tk"; fi)
+TCL_LIB_NAME = tcl83
+TK_LIB_NAME = tk83

View file

@ -1,13 +0,0 @@
--- Makefile.orig Thu Nov 4 17:04:28 1999
+++ Makefile Wed Feb 2 19:46:11 2000
@@ -30,8 +30,8 @@
LN=ln -s
CP=cp
-CPP=/lib/cpp -C -P
-CC=gcc
+CPP=/usr/bin/cpp -C -P
+CC?=gcc
EXEC_SUFFIX=
# CC is only used for bootstrapping, check System/Common/CONFIG.proto if
# you want to change it for all Sather compilations

View file

@ -0,0 +1,10 @@
--- debian/bin-wrapper.orig Thu May 2 19:23:45 2002
+++ debian/bin-wrapper Thu May 2 19:24:10 2002
@@ -1,6 +1,6 @@
#!/bin/sh
-export SATHER_HOME=/usr/lib/sather
+export SATHER_HOME=%%PREFIX%%/lib/sather
BIN_NAME=`basename $0`

View file

@ -1,10 +1,483 @@
@comment $FreeBSD$
bin/sabrowse
bin/sacomp
share/doc/sather/Bugs
share/doc/sather/Changes
share/doc/sather/Contributing
share/doc/sather/FAQ
share/doc/sather/License
share/doc/sather/README
share/doc/sather/programmer-manual.ps
@dirrm share/doc/sather
@unexec install-info --delete %D/info/sather.info %D/info/dir
info/sather.info
@exec install-info %D/info/sather-mode.info %D/info/dir
@unexec install-info --delete %D/info/sather-mode.info %D/info/dir
info/sather-mode.info
@exec install-info %D/info/sather.info %D/info/dir
@unexec install-info --delete %D/info/sather-tutorial.info %D/info/dir
info/sather-tutorial.info
@exec install-info %D/info/sather-tutorial.info %D/info/dir
lib/sather/Bin/PP
lib/sather/Bin/bin-wrapper
lib/sather/Bin/gen_html
lib/sather/Bin/sabrowse
lib/sather/Bin/sacomp
lib/sather/Bin/saprep
lib/sather/Browser/Help/Files
lib/sather/Browser/Help/HTML
lib/sather/Browser/Help/NewStuff
lib/sather/Browser/Help/VersionHistory
lib/sather/Browser/Help/acknowledgements
lib/sather/Browser/Help/browser-tut.tex
lib/sather/Browser/Help/bugs
lib/sather/Browser/Help/buttons
lib/sather/Browser/Help/classListPane
lib/sather/Browser/Help/customization
lib/sather/Browser/Help/emacs
lib/sather/Browser/Help/featureListPane
lib/sather/Browser/Help/graphPane
lib/sather/Browser/Help/help
lib/sather/Browser/Help/historyPane
lib/sather/Browser/Help/implementation
lib/sather/Browser/Help/menuPane
lib/sather/Browser/Help/speed
lib/sather/Browser/Help/tcl-sather-interface
lib/sather/Browser/Help/textPane
lib/sather/Browser/README
lib/sather/Browser/Sather/abs_graph.sa
lib/sather/Browser/Sather/browser.sa
lib/sather/Browser/Sather/digraph.sa
lib/sather/Browser/Sather/digraph_aux.sa
lib/sather/Browser/Sather/dummy_compiler.sa
lib/sather/Browser/Tcl/browser.tcl
lib/sather/Browser/Tcl/browserClassList.tcl
lib/sather/Browser/Tcl/browserConfig.tcl
lib/sather/Browser/Tcl/browserDump.tcl
lib/sather/Browser/Tcl/browserFeatureList.tcl
lib/sather/Browser/Tcl/browserFontsNColors.tcl
lib/sather/Browser/Tcl/browserGraph.tcl
lib/sather/Browser/Tcl/browserHelp.tcl
lib/sather/Browser/Tcl/browserHistory.tcl
lib/sather/Browser/Tcl/browserMisc.tcl
lib/sather/Browser/Tcl/browserPrompters.tcl
lib/sather/Browser/Tcl/browserStartupWindow.tcl
lib/sather/Browser/Tcl/browserText.tcl
lib/sather/Browser/Tcl/campanile.gif
lib/sather/Browser/Tcl/campanile_smaller.gif
lib/sather/Browser/Tcl/dotty-header
lib/sather/Browser/Tcl/sather.xbm
lib/sather/Browser/Tcl/sathermask.xbm
lib/sather/Browser/TkKit/TkKit.html
lib/sather/Browser/TkKit/TkKit.module
lib/sather/Browser/TkKit/entry_arr.sa
lib/sather/Browser/TkKit/exceptions.sa
lib/sather/Browser/TkKit/simpleTkApp.sa
lib/sather/Browser/TkKit/temperature.sa
lib/sather/Browser/TkKit/tkApp.sa
lib/sather/Browser/TkKit/tkCallback.sa
lib/sather/Browser/TkKit/tkMiscWidgets.sa
lib/sather/Browser/TkKit/tkToplevel.sa
lib/sather/Browser/TkKit/tkWidget.sa
lib/sather/Browser/TkKit/tkWindow.sa
lib/sather/Browser/Web/Bugs
lib/sather/Browser/Web/README
lib/sather/Browser/Web/common_funcs
lib/sather/Browser/Web/convert-1.1
lib/sather/Browser/Web/dotty-header
lib/sather/Browser/Web/dump-pre-html-info
lib/sather/Browser/Web/gen_html_class_index
lib/sather/Browser/Web/gen_html_quick
lib/sather/Browser/Web/gen_html_sa_files
lib/sather/Browser/Web/gen_html_shortflat
lib/sather/Browser/Web/gen_html_top_level
lib/sather/Browser/Web/gen_mml_sa_files
lib/sather/Browser/Web/gen_mml_shortflat
lib/sather/Browser/Web/gif2jpg
lib/sather/Browser/Web/gr2gif
lib/sather/Browser/Web/gr2jpg
lib/sather/Browser/Web/graph2dot
lib/sather/Browser/Web/ps2gif
lib/sather/Browser/all-classes.sa
lib/sather/Browser/browser-debug.module
lib/sather/Browser/browser.module
lib/sather/Browser/gen_lib
lib/sather/Browser/test.sa
lib/sather/Library/Base/Base.module
lib/sather/Library/Base/abstract.sa
lib/sather/Library/Base/aref.sa
lib/sather/Library/Base/aref_test.sa
lib/sather/Library/Base/aval.sa
lib/sather/Library/Base/bool.sa
lib/sather/Library/Base/bool_test.sa
lib/sather/Library/Base/char.sa
lib/sather/Library/Base/char_test.sa
lib/sather/Library/Base/compare.sa
lib/sather/Library/Base/elt_alg.sa
lib/sather/Library/Base/flt.sa
lib/sather/Library/Base/flt_dummy.sa
lib/sather/Library/Base/flt_other.sa
lib/sather/Library/Base/fltd.sa
lib/sather/Library/Base/fltd_test.sa
lib/sather/Library/Base/int.sa
lib/sather/Library/Base/int_test.sa
lib/sather/Library/Base/math_test.sa
lib/sather/Library/Base/misc.sa
lib/sather/Library/Base/number.sa
lib/sather/Library/Base/succ_stream.sa
lib/sather/Library/Containers/Containers.module
lib/sather/Library/Containers/ContainersArrays.module
lib/sather/Library/Containers/ContainersBags.module
lib/sather/Library/Containers/ContainersDispensers.module
lib/sather/Library/Containers/ContainersF_classes.module
lib/sather/Library/Containers/ContainersLists.module
lib/sather/Library/Containers/ContainersMaps.module
lib/sather/Library/Containers/ContainersSets.module
lib/sather/Library/Containers/GeneratedContainers.module
lib/sather/Library/Containers/a_list.sa
lib/sather/Library/Containers/a_pq.sa
lib/sather/Library/Containers/a_queue.sa
lib/sather/Library/Containers/a_stack.sa
lib/sather/Library/Containers/arr.sa
lib/sather/Library/Containers/arr_alg.sa
lib/sather/Library/Containers/arr_permute_alg.sa
lib/sather/Library/Containers/arr_search_alg.sa
lib/sather/Library/Containers/arr_select_alg.sa
lib/sather/Library/Containers/arr_sort_alg.sa
lib/sather/Library/Containers/array.sa
lib/sather/Library/Containers/array2.sa
lib/sather/Library/Containers/array2_test.sa
lib/sather/Library/Containers/array3.sa
lib/sather/Library/Containers/array3_test.sa
lib/sather/Library/Containers/arrays_test.sa
lib/sather/Library/Containers/bag.sa
lib/sather/Library/Containers/bag_incl.sa
lib/sather/Library/Containers/bag_test.sa
lib/sather/Library/Containers/btree.sa
lib/sather/Library/Containers/btree_test.sa
lib/sather/Library/Containers/container.sa
lib/sather/Library/Containers/container_alg.sa
lib/sather/Library/Containers/dispenser.sa
lib/sather/Library/Containers/fgap_list.sa
lib/sather/Library/Containers/fgap_list_test.sa
lib/sather/Library/Containers/flist.sa
lib/sather/Library/Containers/flist_test.sa
lib/sather/Library/Containers/fmap.sa
lib/sather/Library/Containers/fmap_test.sa
lib/sather/Library/Containers/fmultimap.sa
lib/sather/Library/Containers/fmultimap_test.sa
lib/sather/Library/Containers/fqset.sa
lib/sather/Library/Containers/fset.sa
lib/sather/Library/Containers/fset_test.sa
lib/sather/Library/Containers/h_bag.sa
lib/sather/Library/Containers/h_map.sa
lib/sather/Library/Containers/h_multimap.sa
lib/sather/Library/Containers/h_set.sa
lib/sather/Library/Containers/hashtab.sa
lib/sather/Library/Containers/list.sa
lib/sather/Library/Containers/list_test.sa
lib/sather/Library/Containers/llist.sa
lib/sather/Library/Containers/llist_test.sa
lib/sather/Library/Containers/map.sa
lib/sather/Library/Containers/map_alg.sa
lib/sather/Library/Containers/map_incl.sa
lib/sather/Library/Containers/map_test.sa
lib/sather/Library/Containers/multimap.sa
lib/sather/Library/Containers/multimap_incl.sa
lib/sather/Library/Containers/multimap_test.sa
lib/sather/Library/Containers/next.sa
lib/sather/Library/Containers/nr_a_stack.sa
lib/sather/Library/Containers/nr_stack.sa
lib/sather/Library/Containers/orig_fset.sa
lib/sather/Library/Containers/pq.sa
lib/sather/Library/Containers/pq_test.sa
lib/sather/Library/Containers/queue.sa
lib/sather/Library/Containers/queue_test.sa
lib/sather/Library/Containers/set.sa
lib/sather/Library/Containers/set_incl.sa
lib/sather/Library/Containers/set_test.sa
lib/sather/Library/Containers/set_views.sa
lib/sather/Library/Containers/set_views_test.sa
lib/sather/Library/Containers/stack.sa
lib/sather/Library/Containers/stack_test.sa
lib/sather/Library/Containers/tup.sa
lib/sather/Library/Containers/tup_test.sa
lib/sather/Library/Ext/External.module
lib/sather/Library/Ext/bind_fortran.sa
lib/sather/Library/Ext/c.sa
lib/sather/Library/Ext/c_ptr.sa
lib/sather/Library/Ext/fortran.sa
lib/sather/Library/Ext/other_c_ptrs.sa
lib/sather/Library/Graphs/Graphs.module
lib/sather/Library/Graphs/abs_digraph.sa
lib/sather/Library/Graphs/abs_graph.sa
lib/sather/Library/Graphs/abs_ugraph.sa
lib/sather/Library/Graphs/digraph.sa
lib/sather/Library/Graphs/digraph_alg.sa
lib/sather/Library/Graphs/digraph_incl.sa
lib/sather/Library/Graphs/digraph_mat.sa
lib/sather/Library/Graphs/digraph_test.sa
lib/sather/Library/Graphs/digraph_views.sa
lib/sather/Library/Graphs/digraph_views_test.sa
lib/sather/Library/Graphs/edges.sa
lib/sather/Library/Graphs/graph_exc.sa
lib/sather/Library/Graphs/lbld_digraph.sa
lib/sather/Library/Graphs/ugraph.sa
lib/sather/Library/Graphs/ugraph_incl.sa
lib/sather/Library/Graphs/ugraph_test.sa
lib/sather/Library/Graphs/wtd_digraph.sa
lib/sather/Library/Graphs/wtd_digraph_alg.sa
lib/sather/Library/Graphs/wtd_digraph_test.sa
lib/sather/Library/IO/IO.module
lib/sather/Library/IO/err.sa
lib/sather/Library/IO/file.sa
lib/sather/Library/IO/in.sa
lib/sather/Library/IO/out.sa
lib/sather/Library/IO/str_stream.sa
lib/sather/Library/IO/stream.sa
lib/sather/Library/Library.module
lib/sather/Library/Math/Math.module
lib/sather/Library/Math/Matvec.module
lib/sather/Library/Math/abs_mat.sa
lib/sather/Library/Math/abs_vec.sa
lib/sather/Library/Math/cpx.sa
lib/sather/Library/Math/cpx_test.sa
lib/sather/Library/Math/cpxd.sa
lib/sather/Library/Math/fft.sa
lib/sather/Library/Math/i_interval.sa
lib/sather/Library/Math/inti.sa
lib/sather/Library/Math/jacobi.sa
lib/sather/Library/Math/mat.sa
lib/sather/Library/Math/matcpx.sa
lib/sather/Library/Math/matd.sa
lib/sather/Library/Math/perm_random_gen.sa
lib/sather/Library/Math/rat.sa
lib/sather/Library/Math/rnd.sa
lib/sather/Library/Math/rnd_test.sa
lib/sather/Library/Math/svd.sa
lib/sather/Library/Math/test_i_interval.sa
lib/sather/Library/Math/test_matvec.sa
lib/sather/Library/Math/vec.sa
lib/sather/Library/Math/veccpx.sa
lib/sather/Library/Math/vecd.sa
lib/sather/Library/Strings/Strings.module
lib/sather/Library/Strings/base_format.sa
lib/sather/Library/Strings/format.sa
lib/sather/Library/Strings/fstr.sa
lib/sather/Library/Strings/fstr_test.sa
lib/sather/Library/Strings/glob.sa
lib/sather/Library/Strings/regex.c
lib/sather/Library/Strings/regex.h
lib/sather/Library/Strings/regexp.c
lib/sather/Library/Strings/regexp.sa
lib/sather/Library/Strings/str.sa
lib/sather/Library/Strings/str_cursor.sa
lib/sather/Library/Strings/str_cursor_test.sa
lib/sather/Library/Strings/test_format.sa
lib/sather/Library/System/DualGui/DualGuiAppToServer.module
lib/sather/Library/System/DualGui/gui_app_end.sa
lib/sather/Library/System/DualGui/gui_server_end.sa
lib/sather/Library/System/DualGui/gui_util.sa
lib/sather/Library/System/Gui/Demos/demo1.sa
lib/sather/Library/System/Gui/Demos/demo2.sa
lib/sather/Library/System/Gui/Demos/demo_listbox.sa
lib/sather/Library/System/Gui/Demos/demo_menu.sa
lib/sather/Library/System/Gui/Demos/demo_raster.sa
lib/sather/Library/System/Gui/Demos/demo_text.sa
lib/sather/Library/System/Gui/Demos/pizza.sa
lib/sather/Library/System/Gui/GuiRaster.module
lib/sather/Library/System/Gui/GuiTclTkInterface.module
lib/sather/Library/System/Gui/GuiWidgets.module
lib/sather/Library/System/Gui/anchor.sa
lib/sather/Library/System/Gui/button.sa
lib/sather/Library/System/Gui/canvas.sa
lib/sather/Library/System/Gui/check.sa
lib/sather/Library/System/Gui/color.sa
lib/sather/Library/System/Gui/entry.sa
lib/sather/Library/System/Gui/events.sa
lib/sather/Library/System/Gui/frame.sa
lib/sather/Library/System/Gui/gui.sa
lib/sather/Library/System/Gui/gui_util.sa
lib/sather/Library/System/Gui/init_gui.sa
lib/sather/Library/System/Gui/label.sa
lib/sather/Library/System/Gui/listbox.sa
lib/sather/Library/System/Gui/menu.sa
lib/sather/Library/System/Gui/menubutton.sa
lib/sather/Library/System/Gui/misc.sa
lib/sather/Library/System/Gui/pack.sa
lib/sather/Library/System/Gui/radio.sa
lib/sather/Library/System/Gui/raster.sa
lib/sather/Library/System/Gui/root_window.sa
lib/sather/Library/System/Gui/text.sa
lib/sather/Library/System/Gui/tk.sa
lib/sather/Library/System/Gui/toplevel.sa
lib/sather/Library/System/Gui/widget.sa
lib/sather/Library/System/Gui/widget_config.sa
lib/sather/Library/System/Gui/wmgr.sa
lib/sather/Library/System/Socket/Socket.module
lib/sather/Library/System/Socket/experimental/README
lib/sather/Library/System/Socket/experimental/Socket.module
lib/sather/Library/System/Socket/experimental/socket.sa
lib/sather/Library/System/Socket/experimental/socket_support.c
lib/sather/Library/System/Socket/experimental/test/TODO
lib/sather/Library/System/Socket/experimental/test/socket.sa
lib/sather/Library/System/Socket/experimental/test/test.module
lib/sather/Library/System/Socket/socket.sa
lib/sather/Library/System/Socket/socket_support.c
lib/sather/Library/System/Socket/socket_support_unix.c
lib/sather/Library/System/Socket/socket_support_win32.c
lib/sather/Library/System/Socket/socket_test.sa
lib/sather/Library/System/System.module
lib/sather/Library/System/TclTk/TclTk.module
lib/sather/Library/System/TclTk/c_interface.c
lib/sather/Library/System/TclTk/c_interface.sa
lib/sather/Library/System/TclTk/c_raster.c
lib/sather/Library/System/TclTk/tkRaster.c
lib/sather/Library/System/TclTk/tkRaster.h
lib/sather/Library/System/TclTk/tkRasterBuiltIn.c
lib/sather/Library/System/TclTk/tkRasterBuiltIn.h
lib/sather/Library/System/Zones/Zones.module
lib/sather/Library/System/Zones/zone.sa
lib/sather/Library/System/runtime.sa
lib/sather/Library/System/sys.sa
lib/sather/Library/System/test.sa
lib/sather/Library/System/time.sa
lib/sather/Library/System/unix.sa
lib/sather/Library/pSather/pSather.module
lib/sather/Library/pSather/psather.sa
lib/sather/System/Common/CONFIG
lib/sather/System/Common/Common.module
lib/sather/System/Common/c.h
lib/sather/System/Common/c_header.h
lib/sather/System/Common/exception.h
lib/sather/System/Common/floatmath.h
lib/sather/System/Common/fortran.h
lib/sather/System/Common/header.h
lib/sather/System/Common/runtime.c
lib/sather/System/Common/runtime.h
lib/sather/System/Debug/PO.module
lib/sather/System/Debug/POG.module
lib/sather/System/Debug/debug.sa
lib/sather/System/Debug/po.sa
lib/sather/System/Debug/pog.sa
lib/sather/System/Debug/pohelp.sa
lib/sather/System/Debug/print.c
lib/sather/System/FORBID
lib/sather/System/Platforms/X/CONFIG
lib/sather/System/Platforms/X/Platform.module
lib/sather/System/Platforms/X/header.h
lib/sather/System/Platforms/dualgui/CONFIG
lib/sather/System/Platforms/dualgui/GuiServer.module
lib/sather/System/Platforms/dualgui/Platform.module
lib/sather/System/Platforms/dualgui/dual_gui_server
lib/sather/System/Platforms/dualgui/header.h
lib/sather/System/Platforms/f77/CONFIG
lib/sather/System/Platforms/f77/Platform.module
lib/sather/System/Platforms/f77/header.h
lib/sather/System/Platforms/gui/CONFIG
lib/sather/System/Platforms/gui/Platform.module
lib/sather/System/Platforms/gui/TclCode/README
lib/sather/System/Platforms/gui/TclCode/gui_post_socket_init.tcl
lib/sather/System/Platforms/gui/TclCode/gui_setup.tcl
lib/sather/System/Platforms/gui/TclCode/sather.xbm
lib/sather/System/Platforms/gui/TclCode/sathermask.xbm
lib/sather/System/Platforms/gui/TclCode/startup.tcl
lib/sather/System/Platforms/gui/TclCode/tcl-system-init.tcl
lib/sather/System/Platforms/gui/TclCode/tk-system-init.tcl
lib/sather/System/Platforms/gui/gui_post_socket_init.tcl
lib/sather/System/Platforms/gui/gui_setup.tcl
lib/sather/System/Platforms/gui/header.h
lib/sather/System/Platforms/freebsd/CONFIG
lib/sather/System/Platforms/freebsd/Platform.module
lib/sather/System/Platforms/freebsd/header.h
lib/sather/System/Platforms/tcltk/CONFIG
lib/sather/System/Platforms/tcltk/Make.target.inc
lib/sather/System/Platforms/tcltk/Platform.module
lib/sather/System/Platforms/tcltk/header.h
lib/sather/System/Platforms/tcltk/init/button.tcl
lib/sather/System/Platforms/tcltk/init/dialog.tcl
lib/sather/System/Platforms/tcltk/init/entry.tcl
lib/sather/System/Platforms/tcltk/init/focus.tcl
lib/sather/System/Platforms/tcltk/init/listbox.tcl
lib/sather/System/Platforms/tcltk/init/menu.tcl
lib/sather/System/Platforms/tcltk/init/obsolete.tcl
lib/sather/System/Platforms/tcltk/init/optionMenu.tcl
lib/sather/System/Platforms/tcltk/init/palette.tcl
lib/sather/System/Platforms/tcltk/init/scale.tcl
lib/sather/System/Platforms/tcltk/init/scrollbar.tcl
lib/sather/System/Platforms/tcltk/init/tcl-system-init.tcl
lib/sather/System/Platforms/tcltk/init/tearoff.tcl
lib/sather/System/Platforms/tcltk/init/text.tcl
lib/sather/System/Platforms/tcltk/init/tk-system-init.tcl
lib/sather/System/Platforms/tcltk/init/tk.tcl
lib/sather/System/Platforms/tcltk/init/tkerror.tcl
lib/sather/System/Platforms/tcltk/sather.xbm
lib/sather/System/Platforms/tcltk/sathermask.xbm
lib/sather/System/Platforms/tcltk/startup.tcl
%%PORTDOCS%%share/doc/sather/BugReport
%%PORTDOCS%%share/doc/sather/Bugs
%%PORTDOCS%%share/doc/sather/Changes
%%PORTDOCS%%share/doc/sather/Contributing
%%PORTDOCS%%share/doc/sather/Debugging.html
%%PORTDOCS%%share/doc/sather/FAQ
%%PORTDOCS%%share/doc/sather/GC-incremental
%%PORTDOCS%%share/doc/sather/Gui/Doc.fmk.ps
%%PORTDOCS%%share/doc/sather/Gui/index.html
%%PORTDOCS%%share/doc/sather/Gui/install
%%PORTDOCS%%share/doc/sather/Installation.html
%%PORTDOCS%%share/doc/sather/License
%%PORTDOCS%%share/doc/sather/PP.description
%%PORTDOCS%%share/doc/sather/Sather-1.1.ps
%%PORTDOCS%%share/doc/sather/ToDo
%%PORTDOCS%%share/doc/sather/WebBrowser.html
%%PORTDOCS%%share/doc/sather/compiler.ps
%%PORTDOCS%%share/doc/sather/header/README
%%PORTDOCS%%share/doc/sather/header/c
%%PORTDOCS%%share/doc/sather/header/c-lgpl
%%PORTDOCS%%share/doc/sather/header/h
%%PORTDOCS%%share/doc/sather/header/h-lgpl
%%PORTDOCS%%share/doc/sather/header/make
%%PORTDOCS%%share/doc/sather/header/module
%%PORTDOCS%%share/doc/sather/header/sa
%%PORTDOCS%%share/doc/sather/header/sa-lgpl
%%PORTDOCS%%share/doc/sather/index.html
%%PORTDOCS%%share/doc/sather/iterators.ps
%%PORTDOCS%%share/doc/sather/pSather-notes
%%PORTDOCS%%share/doc/sather/programmer-manual.ps
%%PORTDOCS%%share/doc/sather/runtime_spec
share/emacs/site-lisp/hl319.el
share/emacs/site-lisp/sather-lib.el
share/emacs/site-lisp/sather-module.el
share/emacs/site-lisp/sather.el
%%PORTDOCS%%@dirrm share/doc/sather/header
%%PORTDOCS%%@dirrm share/doc/sather/Gui
%%PORTDOCS%%@dirrm share/doc/sather
@dirrm lib/sather/System/Platforms/tcltk/init
@dirrm lib/sather/System/Platforms/tcltk
@dirrm lib/sather/System/Platforms/freebsd
@dirrm lib/sather/System/Platforms/gui/TclCode
@dirrm lib/sather/System/Platforms/gui
@dirrm lib/sather/System/Platforms/f77
@dirrm lib/sather/System/Platforms/dualgui
@dirrm lib/sather/System/Platforms/X
@dirrm lib/sather/System/Platforms
@dirrm lib/sather/System/Debug
@dirrm lib/sather/System/Common
@dirrm lib/sather/System
@dirrm lib/sather/Library/pSather
@dirrm lib/sather/Library/System/Zones
@dirrm lib/sather/Library/System/TclTk
@dirrm lib/sather/Library/System/Socket/experimental/test
@dirrm lib/sather/Library/System/Socket/experimental
@dirrm lib/sather/Library/System/Socket
@dirrm lib/sather/Library/System/Gui/Demos
@dirrm lib/sather/Library/System/Gui
@dirrm lib/sather/Library/System/DualGui
@dirrm lib/sather/Library/System
@dirrm lib/sather/Library/Strings
@dirrm lib/sather/Library/Math
@dirrm lib/sather/Library/IO
@dirrm lib/sather/Library/Graphs
@dirrm lib/sather/Library/Ext
@dirrm lib/sather/Library/Containers
@dirrm lib/sather/Library/Base
@dirrm lib/sather/Library
@dirrm lib/sather/Browser/Web
@dirrm lib/sather/Browser/TkKit
@dirrm lib/sather/Browser/Tcl
@dirrm lib/sather/Browser/Sather
@dirrm lib/sather/Browser/Help
@dirrm lib/sather/Browser
@dirrm lib/sather/Bin
@dirrm lib/sather