Add gnurobots 1.0D, a game/diversion where you construct a program for a
little robot, then set him loose and watch him explore a world on his own. It is written in Scheme and implemented using Guile. PR: 21482 Submitted by: Aaron VonderHaar <avh4@crosswinds.net>
This commit is contained in:
parent
594fa29da6
commit
5321816733
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34325
8 changed files with 92 additions and 0 deletions
|
@ -78,6 +78,7 @@
|
|||
SUBDIR += gnomememoryblocks
|
||||
SUBDIR += gnuchess
|
||||
SUBDIR += gnugo
|
||||
SUBDIR += gnurobots
|
||||
SUBDIR += gnushogi
|
||||
SUBDIR += golddig
|
||||
SUBDIR += gomoku.app
|
||||
|
|
38
games/gnurobots/Makefile
Normal file
38
games/gnurobots/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# New ports collection makefile for: gnurobots
|
||||
# Date created: 22 Sept 2000
|
||||
# Whom: Aaron VonderHaar <avh4@usa.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gnurobots
|
||||
PORTVERSION= 1.0D
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= gnurobots
|
||||
|
||||
MAINTAINER= avh4@usa.net
|
||||
|
||||
LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
pre-patch:
|
||||
${CP} ${WRKSRC}/getopt/getopt.h ${WRKSRC}/include
|
||||
${CP} ${WRKSRC}/getopt/getopt.c ${WRKSRC}/src
|
||||
${CP} ${WRKSRC}/getopt/getopt1.c ${WRKSRC}/src
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/share/gnurobots/maps ${PREFIX}/share/gnurobots/scheme \
|
||||
${PREFIX}/share/doc/gnurobots
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/robots ${PREFIX}/bin/gnurobots
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/robots_logfile ${PREFIX}/bin/gnurobots_logfile
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/xrobots ${PREFIX}/bin/xgnurobots
|
||||
${INSTALL_DATA} ${WRKSRC}/maps/* ${PREFIX}/share/gnurobots/maps/
|
||||
${INSTALL_DATA} ${WRKSRC}/scheme/* ${PREFIX}/share/gnurobots/scheme/
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/* ${PREFIX}/share/doc/gnurobots/
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/gnurobots/distinfo
Normal file
1
games/gnurobots/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (gnurobots-1.0D.tar.gz) = 0ced682367b0dc9b2fcfdb40230a5fb5
|
11
games/gnurobots/files/patch-aa
Normal file
11
games/gnurobots/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/Makefile.in Sun Jun 18 11:26:24 2000
|
||||
+++ src/Makefile.in Fri Sep 22 01:12:42 2000
|
||||
@@ -17,7 +17,7 @@
|
||||
|
||||
# Macros:
|
||||
|
||||
-SOURCES=api.c sign.c loadmap.c drawmap.c
|
||||
+SOURCES=api.c sign.c loadmap.c drawmap.c getopt.c getopt1.c
|
||||
OBJECTS=$(SOURCES:.c=.o)
|
||||
|
||||
CFLAGS_X=@X_CFLAGS@
|
1
games/gnurobots/pkg-comment
Normal file
1
games/gnurobots/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
GNU diversion wherein Scheme-coded robots explore a world
|
9
games/gnurobots/pkg-descr
Normal file
9
games/gnurobots/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
GNU Robots is a game/diversion where you construct a program for a
|
||||
little robot, then set him loose and watch him explore a world on his
|
||||
own. The robot program is written in Scheme, and is implemented using
|
||||
GNU Guile. --from GNU robots README
|
||||
|
||||
WWW: http://www.gnu.org/software/robots/
|
||||
|
||||
-Aaron VonderHaar
|
||||
avh4@usa.net
|
7
games/gnurobots/pkg-message
Normal file
7
games/gnurobots/pkg-message
Normal file
|
@ -0,0 +1,7 @@
|
|||
Where to find things
|
||||
- A place to start: $PREFIX/share/doc/gnurobots/Robots-HOWTO
|
||||
- Example maps: $PREFIX/share/gnurobots/maps/
|
||||
- Example robots: $PREFIX/share/gnurobots/scheme/
|
||||
- Binaries: gnurobots, gnurobots_logfile, xgnurobots
|
||||
(this port adds the 'gnu' prefix to
|
||||
distinguish from /usr/games/robots)
|
24
games/gnurobots/pkg-plist
Normal file
24
games/gnurobots/pkg-plist
Normal file
|
@ -0,0 +1,24 @@
|
|||
bin/gnurobots
|
||||
bin/gnurobots_logfile
|
||||
bin/xgnurobots
|
||||
share/gnurobots/maps/maze.map
|
||||
share/gnurobots/maps/pattern.map
|
||||
share/gnurobots/maps/small.map
|
||||
share/gnurobots/scheme/beep.scm
|
||||
share/gnurobots/scheme/greedy.scm
|
||||
share/gnurobots/scheme/mapper.scm
|
||||
share/gnurobots/scheme/simple.scm
|
||||
share/gnurobots/scheme/stop.scm
|
||||
share/gnurobots/scheme/zap.scm
|
||||
share/doc/gnurobots/BUGS
|
||||
share/doc/gnurobots/COPYING
|
||||
share/doc/gnurobots/INSTALL
|
||||
share/doc/gnurobots/NEWS
|
||||
share/doc/gnurobots/README
|
||||
share/doc/gnurobots/Robots-HOWTO
|
||||
share/doc/gnurobots/contrib
|
||||
share/doc/gnurobots/guile-proj.scm
|
||||
@dirrm share/gnurobots/scheme
|
||||
@dirrm share/gnurobots/maps
|
||||
@dirrm share/gnurobots
|
||||
@dirrm share/doc/gnurobots
|
Loading…
Reference in a new issue