audio/aacgain: Remove expired port

2023-09-30 audio/aacgain: Obsolete way of handling volume adjustment, consider using audio/rsgain
This commit is contained in:
Muhammad Moinur Rahman 2023-09-30 01:28:40 +02:00
parent c79462cc57
commit 53cd65fc55
6 changed files with 1 additions and 52 deletions

1
MOVED
View file

@ -7864,3 +7864,4 @@ x11-fonts/sourcecodepro-ttf|x11-fonts/source-code-pro-ttf|2023-09-30|Move x11-fo
x11-fonts/sourceserifpro-ttf|x11-fonts/source-serif-ttf|2023-09-30|Move x11-fonts/sourceserifpro-ttf to x11-fonts/source-serif-ttf
www/pserv||2023-09-30|Has expired: Abandonware, last release in 2005. Consider migrating to www/apache24 , www/lighttpd or www/nginx
www/polipo||2023-09-30|Has expired: No longer maintained upstream
audio/aacgain||2023-09-30|Has expired: Obsolete way of handling volume adjustment, consider using audio/rsgain

View file

@ -4,7 +4,6 @@
SUBDIR += HVSC-Update
SUBDIR += Maaate
SUBDIR += a2jmidid
SUBDIR += aacgain
SUBDIR += abcde
SUBDIR += abcselect
SUBDIR += abgate-lv2

View file

@ -1,23 +0,0 @@
PORTNAME= aacgain
PORTVERSION= 1.8
PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://aacgain.altosdesign.com/alvarez/
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Normalizes the volume of MP3 and AAC (MP4/M4A/QuickTime) media files
WWW= http://aacgain.altosdesign.com/
LICENSE= GPLv2
BROKEN= Unfetchable
DEPRECATED= Obsolete way of handling volume adjustment, consider using audio/rsgain
EXPIRATION_DATE=2023-09-30
GNU_CONFIGURE= yes
USES= gmake libtool tar:bzip2
PLIST_FILES= bin/aacgain
CXXFLAGS+= --std=c++98
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (aacgain-1.8.tar.bz2) = 2bb8e27aa8f8434a4861fdbc70adb9cb4b47e1dfe472910d62d6042cb80a2ee1
SIZE (aacgain-1.8.tar.bz2) = 1188680

View file

@ -1,19 +0,0 @@
--- faad2/libfaad/common.h.orig 2004-09-08 09:43:12 UTC
+++ faad2/libfaad/common.h
@@ -302,6 +302,7 @@ char *strchr(), *strrchr();
return i;
}
#elif (defined(__i386__) && defined(__GNUC__))
+#if 0
#define HAS_LRINTF
// from http://www.stereopsis.com/FPU.html
static INLINE int lrintf(float f)
@@ -315,7 +316,7 @@ char *strchr(), *strrchr();
return i;
}
#endif
-
+#endif
#ifdef __ICL /* only Intel C compiler has fmath ??? */

View file

@ -1,7 +0,0 @@
aacgain is a modification to Glen Sawyer's excellent mp3gain program, and
supports AAC (MP4/M4A/QuickTime) audio files in addition to MP3 files.
aacgain normalizes the volume of digital music files using the Replay Gain
algorithm, by modifying the global_gain fields in the AAC samples. Free-
form metadata tags are added to the file to save undo information, making
the normalization process reversible.