Update to 2.9.7 pre 0

PR:		28933
Submitted by:	maintainer
This commit is contained in:
David W. Chapman Jr. 2001-07-22 03:21:13 +00:00
parent 0c0e2ab02c
commit 53e7c69432
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45341
5 changed files with 75 additions and 60 deletions

View file

@ -6,12 +6,11 @@
#
PORTNAME= joe-devel
PORTVERSION= 2.9.6
PORTREVISION= 1
PORTVERSION= 2.9.7p0
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= joe-editor
DISTNAME= joe-${PORTVERSION}
DISTNAME= joe-${PORTVERSION:S/p/-pre/}
EXTRACT_SUFX= .tgz
MAINTAINER= petef@databits.net
@ -21,11 +20,23 @@ MAN1= joe.1
GNU_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= joe
post-patch:
@${PERL} -pi -e 's!CFLAGS = -O2!CFLAGS +=!' ${WRKSRC}/Makefile.in
@${PERL} -pi -e 's!fprintf.*long time.*!!' ${WRKSRC}/conf.c
@${PERL} -pi -e 's!2.9.6-pre1!2.9.7-pre0!' ${WRKSRC}/main.c
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/joe
${INSTALL_DATA} ${WRKSRC}/INFO ${WRKSRC}/README ${PREFIX}/share/doc/joe
${INSTALL_DATA} ${WRKSRC}/LIST ${PREFIX}/share/doc/joe/CommandList
.endif
.for file in jmacsrc jpicorc jstarrc rjoerc joerc
.if !exists(${PREFIX}/etc/${file})
@${CP} ${PREFIX}/etc/${file}.dist ${PREFIX}/etc/${file}
.endif
.endfor
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (joe-2.9.6.tgz) = 304084bd8e32ec3a4ac2d90bbfef19b3
MD5 (joe-2.9.7-pre0.tgz) = 40851a16c847db0e3a75040dad201f3c

View file

@ -1,5 +1,5 @@
--- b.c.orig Wed Apr 11 17:10:49 2001
+++ b.c Sat Apr 21 23:11:38 2001
--- b.c.orig Mon Jul 9 13:22:47 2001
+++ b.c Mon Jul 9 13:22:49 2001
@@ -16,6 +16,9 @@
#include <pwd.h>
#endif
@ -10,27 +10,26 @@
#include <stdlib.h>
#include <ctype.h>
#include <string.h>
@@ -178,6 +181,7 @@
@@ -184,6 +187,7 @@
else
b->o = pdefault;
mset (b->marks, 0, sizeof (b->marks));
+ b->filehandle = -1; /* initialize filehandle &&& ob */
mset(b->marks, 0, sizeof(b->marks));
+ b->filehandle = -1; /* initialize filehande &&& ob */
b->rdonly = 0;
b->orphan = 0;
b->oldcur = 0;
@@ -229,6 +233,11 @@
void brm (B *b) {
if (b && !--b->count)
{
+ if (b->filehandle != -1) {
+ /* close filehandle, free lock &&& ob */
+ close (b->filehandle);
+ }
+
if (b->changed)
abrerr (b->name);
if (b == errbuf)
@@ -1867,7 +1876,8 @@
@@ -236,6 +240,10 @@
void brm(B * b)
{
if (b && !--b->count) {
+ if (b->filehandle != -1) {
+ /* close filehandle, free lock &&& ob */
+ close (b->filehandle);
+ }
if (b->changed)
abrerr(b->name);
if (b == errbuf)
@@ -1809,7 +1817,8 @@
B *b;
long skip, amnt;
char *n;
@ -38,29 +37,27 @@
+ struct stat sb;
+ int nowrite = 0, fh = -1;
if (!s || !s[0])
{
@@ -1920,6 +1930,14 @@
goto opnerr;
}
if (!s || !s[0]) {
error = -1;
@@ -1857,6 +1866,12 @@
goto opnerr;
}
+ /* Lock the file &&& ob,petef */
+ if (fi)
+ {
+ fh = dup( fileno(fi) );
+ nowrite = (flock (fh, LOCK_EX | LOCK_NB));
+ }
+
+ if (fi) {
+ fh = dup( fileno(fi) );
+ nowrite = (flock (fh, LOCK_EX | LOCK_NB));
+ }
+
/* Skip data if we need to */
if (skip && lseek (fileno (fi), skip, 0) < 0)
{
@@ -1978,6 +1996,8 @@
vsrm (n);
if (skip && lseek(fileno(fi), skip, 0) < 0) {
int r;
@@ -1912,6 +1927,8 @@
vsrm(n);
b->er = error;
+ if (fh != -1)
+ b->filehandle = fh;
+ b->filehandle = fh;
return b;
}

View file

@ -1,17 +1,14 @@
--- conf.c.orig Wed Apr 11 16:11:00 2001
+++ conf.c Mon Jun 25 22:19:07 2001
@@ -179,14 +179,6 @@
fprintf (f, "\n");
--- conf.c.orig Mon Jul 2 17:23:01 2001
+++ conf.c Mon Jul 9 13:27:15 2001
@@ -180,11 +180,6 @@
fprintf(f, "\n");
fprintf (f, "char *getenv();\n");
-#if !defined(__linux__) || !defined(__alpha)
- if (sizeof (long) == 8) {
- fprintf (f, "int time();\n");
- } else
fprintf(f, "char *getenv();\n");
-#if !defined(__linux__) || !defined(__alpha__)
- if (sizeof(long) == 8) {
- fprintf(f, "int time();\n");
- } else
-#endif
- {
- fprintf (f, "long time();\n");
- }
fprintf (f, "void *malloc();\n");
fprintf (f, "void free();\n");
fprintf (f, "void *calloc();\n");
{
fprintf(f, "long time();\n");
}

View file

@ -1,14 +1,24 @@
bin/joe
bin/jmacs
bin/joe
bin/jpico
bin/jstar
bin/rjoe
bin/jpico
bin/termidx
etc/joerc
etc/jmacsrc
etc/jstarrc
etc/rjoerc
etc/jpicorc
@unexec if cmp -s %D/etc/jmacsrc.dist %D/etc/jmacsrc; then rm -f %D/etc/jmacsrc; fi
etc/jmacsrc.dist
@exec if [ ! -f %D/etc/jmacsrc ]; then cp %D/etc/%f %D/etc/jmacsrc; fi
@unexec if cmp -s %D/etc/joerc.dist %D/etc/joerc; then rm -f %D/etc/joerc; fi
etc/joerc.dist
@exec if [ ! -f %D/etc/joerc ]; then cp %D/etc/%f %D/etc/joerc; fi
@unexec if cmp -s %D/etc/jpicorc.dist %D/etc/jpicorc; then rm -f %D/etc/jpicorc; fi
etc/jpicorc.dist
@exec if [ ! -f %D/etc/jpicorc ]; then cp %D/etc/%f %D/etc/jpicorc; fi
@unexec if cmp -s %D/etc/jstarrc.dist %D/etc/jstarrc; then rm -f %D/etc/jstarrc; fi
etc/jstarrc.dist
@exec if [ ! -f %D/etc/jstarrc ]; then cp %D/etc/%f %D/etc/jstarrc; fi
@unexec if cmp -s %D/etc/rjoerc.dist %D/etc/rjoerc; then rm -f %D/etc/rjoerc; fi
etc/rjoerc.dist
@exec if [ ! -f %D/etc/rjoerc ]; then cp %D/etc/%f %D/etc/rjoerc; fi
%%PORTDOCS%%share/doc/joe/INFO
%%PORTDOCS%%share/doc/joe/README
%%PORTDOCS%%share/doc/joe/CommandList