Repo-copy textproc/redisearch to textproc/redisearch16 and

update to the recent stable version v2.0.
This commit is contained in:
Sergey A. Osokin 2021-03-10 22:11:41 +00:00
parent f38fff2015
commit 5416d86007
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=568050
10 changed files with 113 additions and 4 deletions

View file

@ -5,6 +5,24 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20210310:
AFFECTS: users of textproc/redisearch
AUTHOR: osa@FreeBSD.org
The textproc/redisearch port has been updated to the recent stable
release - v2.0. Users wanting to stay on v1.6 can replace
textproc/redisearch with textproc/redisearch16 with one of the
following commands:
# pkg install textproc/redisearch16
or
# portmaster -o textproc/redisearch16 textproc/redisearch
or
# portupgrade -o textproc/redisearch16 textproc/redisearch
NOTE: The textproc/redisearch16 brings a new name for the module,
i.e. redisearch16.so, so be careful.
20210309:
AFFECTS: users of emulators/virtualbox-ose
AUTHOR: madpilot@FreeBSD.org

View file

@ -1493,6 +1493,7 @@
SUBDIR += re_graph
SUBDIR += redet
SUBDIR += redisearch
SUBDIR += redisearch16
SUBDIR += redland
SUBDIR += redland-bindings
SUBDIR += refdb

View file

@ -3,7 +3,7 @@
PORTNAME= redisearch
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.15
DISTVERSION= 2.0.6
CATEGORIES= textproc
MAINTAINER= osa@FreeBSD.org

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1614205727
SHA256 (RediSearch-RediSearch-v1.6.15_GH0.tar.gz) = 8e81b895ceb3309644c199225df25332a2bb0023311275af934ad19c59c0adbc
SIZE (RediSearch-RediSearch-v1.6.15_GH0.tar.gz) = 3671869
TIMESTAMP = 1615413552
SHA256 (RediSearch-RediSearch-v2.0.6_GH0.tar.gz) = 6b74c2bb47569c0a4508a99025ee0c6942edb2c1f76b76366f5062c9b9b37601
SIZE (RediSearch-RediSearch-v2.0.6_GH0.tar.gz) = 3974128

View file

@ -0,0 +1,32 @@
# Created by: Sergey A. Osokin <osa@FreeBSD.org>
# $FreeBSD$
PORTNAME= redisearch16
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.15
DISTNAME= RediSearch-${DISTVERSION}
CATEGORIES= textproc
MAINTAINER= osa@FreeBSD.org
COMMENT= Full-text search over Redis
LICENSE= UNKNOWN
LICENSE_NAME= Redis Source Available License Agreement
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
USES= cmake compiler
USE_GITHUB= yes
GH_ACCOUNT= RediSearch
GH_PROJECT= RediSearch
CMAKE_ARGS= -DGIT_DESCRIBE_VERSION:STRING=${PKGVERSION}
PLIST_FILES= lib/redisearch16.so
do-install:
${INSTALL_LIB} ${INSTALL_WRKSRC}/redisearch.so \
${STAGEDIR}${PREFIX}/lib/redisearch16.so
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1614205727
SHA256 (RediSearch-RediSearch-v1.6.15_GH0.tar.gz) = 8e81b895ceb3309644c199225df25332a2bb0023311275af934ad19c59c0adbc
SIZE (RediSearch-RediSearch-v1.6.15_GH0.tar.gz) = 3671869

View file

@ -0,0 +1,21 @@
--- src/fork_gc.c.orig 2020-04-12 11:18:47 UTC
+++ src/fork_gc.c
@@ -282,6 +282,7 @@ done:
}
static void sendHeaderString(ForkGC *gc, void *arg) {
+ struct iovec { void *iov_base; size_t iov_len; };
struct iovec *iov = arg;
FGC_sendBuffer(gc, iov->iov_base, iov->iov_len);
}
@@ -298,7 +299,9 @@ static void FGC_childCollectTerms(ForkGC *gc, RedisSea
RedisModuleKey *idxKey = NULL;
InvertedIndex *idx = Redis_OpenInvertedIndexEx(sctx, term, strlen(term), 1, &idxKey);
if (idx) {
- struct iovec iov = {.iov_base = (void *)term, termLen};
+ struct iovec { void *iov_base; size_t iov_len; } iov;
+ iov.iov_base = term;
+ iov.iov_len = termLen;
FGC_childRepairInvidx(gc, sctx, idx, sendHeaderString, &iov, NULL);
}
if (idxKey) {

View file

@ -0,0 +1,11 @@
--- src/numeric_index.c.orig 2020-02-29 20:43:50 UTC
+++ src/numeric_index.c
@@ -474,7 +474,7 @@ int NumericIndexType_Register(RedisModuleCtx *ctx) {
.rdb_save = NumericIndexType_RdbSave,
.aof_rewrite = GenericAofRewrite_DisabledHandler,
.free = NumericIndexType_Free,
- .mem_usage = NumericIndexType_MemUsage};
+ .mem_usage = (const void *)NumericIndexType_MemUsage};
NumericIndexType = RedisModule_CreateDataType(ctx, "numericdx", NUMERIC_INDEX_ENCVER, &tm);
if (NumericIndexType == NULL) {

View file

@ -0,0 +1,11 @@
--- src/redis_index.c.orig 2020-02-29 20:35:56 UTC
+++ src/redis_index.c
@@ -108,7 +108,7 @@ int InvertedIndex_RegisterType(RedisModuleCtx *ctx) {
.rdb_load = InvertedIndex_RdbLoad,
.rdb_save = InvertedIndex_RdbSave,
.aof_rewrite = GenericAofRewrite_DisabledHandler,
- .mem_usage = InvertedIndex_MemUsage,
+ .mem_usage = (const void *)InvertedIndex_MemUsage,
.free = InvertedIndex_Free};
InvertedIndexType = RedisModule_CreateDataType(ctx, "ft_invidx", INVERTED_INDEX_ENCVER, &tm);

View file

@ -0,0 +1,12 @@
RediSearch is a source available Full-Text and Secondary Index
engine over Redis, developed by Redis Labs.
Redisearch implements a search engine on top of Redis, but
unlike other Redis search libraries, it does not use internal
data structures like sorted sets.
This also enables more advanced features, like exact phrase
matching and numeric filtering for text queries, that are not
possible or efficient with traditional Redis search approaches.
WWW: https://oss.redislabs.com/redisearch/