Add cramfs 1.1, the compressed ROM filesystem.

PR:		ports/105993
Submitted by:	Gea-Suan Lin <gslin at gslin.org>
This commit is contained in:
Cheng-Lung Sung 2006-12-07 09:36:45 +00:00
parent 35b0d2b0da
commit 541a339c46
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179097
7 changed files with 76 additions and 0 deletions

View file

@ -100,6 +100,7 @@
SUBDIR += cpdup
SUBDIR += cpu
SUBDIR += cpuburn
SUBDIR += cramfs
SUBDIR += crashme
SUBDIR += cromwell
SUBDIR += cronolog

26
sysutils/cramfs/Makefile Normal file
View file

@ -0,0 +1,26 @@
# New ports collection makefile for: cramfs
# Date created: 2006-11-29
# Whom: Gea-Suan Lin <gslin@gslin.org>
#
# $FreeBSD$
#
PORTNAME= cramfs
PORTVERSION= 1.1
CATEGORIES= sysutils
MASTER_SITES= SOURCEFORGE
MASTER_SITE_SUBDIR= cramfs
MAINTAINER= gslin@gslin.org
COMMENT= The compressed ROM filesystem
MAKEFILE= GNUmakefile
USE_GMAKE= yes
PLIST_FILES= sbin/cramfsck sbin/mkcramfs
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cramfsck ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/mkcramfs ${PREFIX}/sbin
.include <bsd.port.mk>

3
sysutils/cramfs/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (cramfs-1.1.tar.gz) = d3912b9f7bf745fbfea68f6a9b9de30f
SHA256 (cramfs-1.1.tar.gz) = 133caca2c4e7c64106555154ee0ff693f5cf5beb9421ce2eb86baee997d22368
SIZE (cramfs-1.1.tar.gz) = 24179

View file

@ -0,0 +1,10 @@
--- GNUmakefile.orig Wed Nov 29 12:51:59 2006
+++ GNUmakefile Wed Nov 29 12:52:06 2006
@@ -1,5 +1,5 @@
-CC = gcc
-CFLAGS = -W -Wall -O2 -g
+CC ?= gcc
+CFLAGS ?= -W -Wall -O2 -g
CPPFLAGS = -I.
LDLIBS = -lz
PROGS = mkcramfs cramfsck

View file

@ -0,0 +1,19 @@
--- cramfsck.c.orig Wed Nov 29 12:49:40 2006
+++ cramfsck.c Wed Nov 29 12:51:12 2006
@@ -47,13 +47,14 @@
#include <stdlib.h>
#include <errno.h>
#include <string.h>
-#include <sys/sysmacros.h>
#include <utime.h>
#include <sys/ioctl.h>
#define _LINUX_STRING_H_
-#include <linux/fs.h>
#include <linux/cramfs_fs.h>
#include <zlib.h>
+
+#define BLKGETSIZE _IO(0x12,96)
+#define MAP_ANONYMOUS 0x20
/* Exit codes used by fsck-type programs */
#define FSCK_OK 0 /* No errors */

View file

@ -0,0 +1,12 @@
--- mkcramfs.c.orig Wed Nov 29 12:47:30 2006
+++ mkcramfs.c Wed Nov 29 12:49:25 2006
@@ -36,6 +36,9 @@
#include <linux/cramfs_fs.h>
#include <zlib.h>
+#define MAP_ANONYMOUS 0x20
+typedef long long loff_t;
+
/* Exit codes used by mkfs-type programs */
#define MKFS_OK 0 /* No errors */
#define MKFS_ERROR 8 /* Operational error */

View file

@ -0,0 +1,5 @@
Cramfs is a Linux filesystem designed to be simple, small, and to
compress things well. It is used on a number of embedded systems and
small devices.
WWW: http://sourceforge.net/projects/cramfs/