Update from 2.4.1 to 2.8.0. Add support for Atari and for
the uIP TCP stack.
This commit is contained in:
parent
af93bed2da
commit
5443c74e41
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=65498
6 changed files with 201 additions and 78 deletions
|
@ -6,62 +6,123 @@
|
|||
#
|
||||
|
||||
PORTNAME= cc65
|
||||
PORTVERSION= 2.4.1
|
||||
PORTVERSION= 2.8.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL} \
|
||||
ftp://ftp.musoftware.de/pub/uz/cc65/
|
||||
# ftp://ftp.us.musoftware.de/pub/uz/cc65/
|
||||
# US musoftware mirror down; main site doesn't like fetch(1)
|
||||
# Mirror sites that were not useful at the time I updated this port:
|
||||
# http://www.acc.umu.se/~arvid/cc65_mirror/ \
|
||||
# ftp://ftp.elysium.pl/tools/crossplatform/programming/c/cc65/ \
|
||||
# http://www.funet.fi/pub/cbm/programming/cc65/
|
||||
MASTER_SITE_SUBDIR= hoek
|
||||
WRKSRC= ${WRKDIR}/cc65-2.4.1
|
||||
DISTNAME= cc65-sources-2.4.1
|
||||
WRKSRC= ${WRKDIR}/cc65-2.8.0
|
||||
DISTNAME= cc65-sources-2.8.0
|
||||
|
||||
MAINTAINER= hoek@FreeBSD.org
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
CFLAGS+= -DCC65_INC=\\\"${PREFIX}/lib/cc65/include\\\" \
|
||||
-DCC65_LIB=\\\"${PREFIX}/lib/cc65/lib\\\"
|
||||
-DCC65_LIB=\\\"${PREFIX}/lib/cc65/lib\\\" \
|
||||
-I${WRKSRC}/src/common
|
||||
|
||||
DOCFILES= doc/ar65.txt doc/ca65.txt doc/cc65.txt doc/cl65.txt doc/coding.txt \
|
||||
doc/compile.txt doc/debugging.txt doc/internal.doc doc/intro.txt \
|
||||
doc/ld65.txt doc/library.txt doc/newvers.txt doc/readme.txt BUGS \
|
||||
CREDITS announce.txt
|
||||
# These doc files can be compiled using the textproc/sgmltools port
|
||||
DOCFILES= \
|
||||
doc/BUGS doc/CREDITS doc/Makefile doc/Makefile.orig \
|
||||
doc/ar65.sgml doc/ca65.sgml doc/cc65.sgml doc/cl65.sgml \
|
||||
doc/coding.sgml doc/compile.txt doc/debugging.sgml \
|
||||
doc/dio.sgml doc/geos.sgml doc/grc.txt doc/index.sgml \
|
||||
doc/internal.txt doc/intro.sgml doc/ld65.sgml \
|
||||
doc/library.sgml doc/newvers.txt doc/readme.1st announce.txt
|
||||
|
||||
BINFILES= binutils/ar65/ar65 binutils/ca65/ca65 binutils/ld65/ld65 \
|
||||
cc65/cc65 cl65/cl65
|
||||
|
||||
CC65INCFILES= 6502.h _6525.h _6526.h _6545.h _6551.h _sid.h _vdc.h _vic.h \
|
||||
ace.h apple2.h assert.h c128.h c64.h cbm.h cbm610.h conio.h ctype.h \
|
||||
dbg.h errno.h fcntl.h iso646.h joystick.h limits.h locale.h mouse.h \
|
||||
nes.h pet.h plus4.h rs232.h setjmp.h stdarg.h stddef.h stdio.h \
|
||||
stdlib.h string.h time.h
|
||||
BINFILES= \
|
||||
src/ar65/ar65 src/ca65/ca65 src/cc65/cc65 \
|
||||
src/cl65/cl65 src/da65/da65 src/grc/grc src/ld65/ld65 src/od65/od65
|
||||
|
||||
CC65LIBFILES= apple2.lib apple2.o c128.lib c128.o c64.lib c64.o cbm610.lib \
|
||||
cbm610.o pet.lib pet.o plus4.lib plus4.o
|
||||
BINSCRIPTS= src/ca65html/ca65html
|
||||
|
||||
SAMPLES= Makefile c1541.rsp hello.c nachtm.c sieve.c
|
||||
CC65INCFILES= \
|
||||
6502.h _6525.h _6526.h _6545.h _6551.h _antic.h _gtia.h _pbi.h _pia.h \
|
||||
_pokey.h _sid.h _vdc.h _vic.h ace.h apple2.h assert.h atari.h c128.h \
|
||||
c64.h cbm.h cbm510.h cbm610.h conio.h ctype.h dbg.h dio.h errno.h \
|
||||
fcntl.h geos.h graphics.h iso646.h joystick.h limits.h locale.h \
|
||||
mouse.h pet.h plus4.h rs232.h setjmp.h stdarg.h stddef.h stdio.h \
|
||||
stdlib.h string.h time.h zlib.h
|
||||
|
||||
CC65GEOSINCFILES= \
|
||||
gconst.h gdisk.h gdlgbox.h gfile.h ggraph.h gmemory.h gmenu.h \
|
||||
gprocess.h gsprite.h gstruct.h gsym.h gsys.h
|
||||
|
||||
CC65LIBFILES= \
|
||||
apple2.o atari.o c128.o c64.o cbm510.o cbm610.o geos.o pet.o \
|
||||
plus4.o apple2.lib atari.lib c128.lib c64.lib cbm510.lib cbm610.lib \
|
||||
geos.lib pet.lib plus4.lib
|
||||
|
||||
SAMPLES= Makefile README hello.c mousedemo.c nachtm.c plasma.c sieve.c
|
||||
|
||||
GEOSSAMPLES= \
|
||||
appfile.grc apphello1.grc apphello2.grc apprmvprot.grc \
|
||||
appyesno.grc dialog.c filesel.c geosconio.c geosconiores.res \
|
||||
grphstr.c hello1.c hello2.c inittab.c menu.c rmvprot.c yesno.c
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC}/cc65 && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
|
||||
cd ${WRKSRC}/cc65 && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
|
||||
cd ${WRKSRC}/binutils && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
|
||||
cd ${WRKSRC}/binutils && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
|
||||
cd ${WRKSRC}/cl65 && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
|
||||
cd ${WRKSRC}/cl65 && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
|
||||
cd ${WRKSRC}/lib && ${GMAKE} all
|
||||
cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
|
||||
cd ${WRKSRC}/libsrc && ${GMAKE} all
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/share/doc/cc65
|
||||
${MKDIR} ${PREFIX}/lib/cc65/include
|
||||
${MKDIR} ${PREFIX}/lib/cc65/include/geos
|
||||
${MKDIR} ${PREFIX}/lib/cc65/lib
|
||||
${MKDIR} ${PREFIX}/share/doc/cc65/samples
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/cc65/samples/geos
|
||||
${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/,} ${PREFIX}/share/doc/cc65
|
||||
${INSTALL_DATA} ${SAMPLES:S,^,${WRKSRC}/samples/,} \
|
||||
${PREFIX}/share/doc/cc65/samples
|
||||
${INSTALL_DATA} ${GEOSSAMPLES:S,^,${WRKSRC}/samples/geos/,} \
|
||||
${PREFIX}/share/doc/cc65/samples/geos
|
||||
.endif
|
||||
${INSTALL_PROGRAM} ${BINFILES:S,^,${WRKSRC}/,} ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${BINSCRIPTS:S,^,${WRKSRC}/,} ${PREFIX}/bin
|
||||
${INSTALL_DATA} ${CC65INCFILES:S,^,${WRKSRC}/include/,} \
|
||||
${PREFIX}/lib/cc65/include
|
||||
${INSTALL_DATA} ${CC65LIBFILES:S,^,${WRKSRC}/lib/,} \
|
||||
${INSTALL_DATA} ${CC65GEOSINCFILES:S,^,${WRKSRC}/include/geos/,} \
|
||||
${PREFIX}/lib/cc65/include/geos
|
||||
${INSTALL_DATA} ${CC65LIBFILES:S,^,${WRKSRC}/libsrc/,} \
|
||||
${PREFIX}/lib/cc65/lib
|
||||
|
||||
plist:
|
||||
.for file in ${DOCFILES}
|
||||
@${ECHO_CMD} %%PORTDOCS%%share/doc/cc65/`${BASENAME} ${file}`
|
||||
.endfor
|
||||
.for file in ${BINFILES}
|
||||
@${ECHO_CMD} bin/`${BASENAME} ${file}`
|
||||
.endfor
|
||||
.for file in ${BINSCRIPTS}
|
||||
@${ECHO_CMD} bin/`${BASENAME} ${file}`
|
||||
.endfor
|
||||
.for file in ${CC65GEOSINCFILES}
|
||||
@${ECHO_CMD} lib/cc65/include/geos/`${BASENAME} ${file}`
|
||||
.endfor
|
||||
.for file in ${CC65INCFILES}
|
||||
@${ECHO_CMD} lib/cc65/include/`${BASENAME} ${file}`
|
||||
.endfor
|
||||
.for file in ${CC65LIBFILES}
|
||||
@${ECHO_CMD} lib/cc65/lib/`${BASENAME} ${file}`
|
||||
.endfor
|
||||
.for file in ${SAMPLES}
|
||||
@${ECHO_CMD} %%PORTDOCS%%share/doc/cc65/samples/`${BASENAME} ${file}`
|
||||
.endfor
|
||||
.for file in ${GEOSSAMPLES}
|
||||
@${ECHO_CMD} \
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/`${BASENAME} ${file}`
|
||||
.endfor
|
||||
@${ECHO_CMD} @dirrm lib/cc65/lib
|
||||
@${ECHO_CMD} @dirrm lib/cc65/include/geos
|
||||
@${ECHO_CMD} @dirrm lib/cc65/include
|
||||
@${ECHO_CMD} @dirrm lib/cc65
|
||||
@${ECHO_CMD} %%PORTDOCS%%@dirrm share/doc/cc65/samples/geos
|
||||
@${ECHO_CMD} %%PORTDOCS%%@dirrm share/doc/cc65/samples
|
||||
@${ECHO_CMD} %%PORTDOCS%%@dirrm share/doc/cc65
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (cc65-sources-2.4.1.tar.gz) = 5bcc8bcbf367bc94d004da142fae110b
|
||||
MD5 (cc65-sources-2.8.0.tar.bz2) = 4940798834d64dacac722f3b573fb811
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -ur3 samples/Makefile samples/Makefile
|
||||
--- samples/Makefile Mon May 8 18:07:09 2000
|
||||
+++ samples/Makefile Mon May 8 18:08:49 2000
|
||||
@@ -1,6 +1,8 @@
|
||||
#
|
||||
# Makefile for cc65 samples
|
||||
#
|
||||
+# This Makefile requires GNU make
|
||||
+#
|
||||
|
||||
# Enter the target system here
|
||||
SYS = c64
|
14
devel/cc65/files/patch-doc_Makefile
Normal file
14
devel/cc65/files/patch-doc_Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/Makefile.orig Mon Sep 2 12:12:59 2002
|
||||
+++ doc/Makefile Mon Sep 2 12:13:01 2002
|
||||
@@ -1,6 +1,8 @@
|
||||
#
|
||||
# Makefile for the cc65 documentation
|
||||
#
|
||||
+# These can be built using the textproc/sgmltools port.
|
||||
+#
|
||||
|
||||
|
||||
# Default for the compiler lib search path as compiler define
|
|
@ -2,17 +2,19 @@ CC65 is a C cross-compiler for 6502 systems. CC65 includes a
|
|||
powerful macro assembler, a debugger, an archiver, and a highly
|
||||
configurable linker. The linker supports overlays, ROMable code,
|
||||
split output, among other features. The compiler supports a large
|
||||
subset of ISO C (as per the ISO 9899 specification).
|
||||
subset of ISO C (as per the ISO 9899 specification) and can compile
|
||||
the uIP TCP stack.
|
||||
|
||||
It is easy to write code for standalone 6502 boards (target none). In
|
||||
addition, particular support for the following targets is included:
|
||||
|
||||
- C64
|
||||
- C128
|
||||
- C16, C116, Plus/4
|
||||
- C64 and C128
|
||||
- the GEOS operating system for the C64 and C128
|
||||
- Commodore C16, C116, Plus/4
|
||||
- CBM 600/700 family (programs run in bank 1)
|
||||
- Newer PET machines (not 2001)
|
||||
- The Apple ][
|
||||
- Atari 8bit machines
|
||||
|
||||
The assembler and linker also support 65816 as a target.
|
||||
|
||||
|
|
|
@ -1,50 +1,81 @@
|
|||
share/doc/cc65/ar65.txt
|
||||
share/doc/cc65/ca65.txt
|
||||
share/doc/cc65/cc65.txt
|
||||
share/doc/cc65/cl65.txt
|
||||
share/doc/cc65/coding.txt
|
||||
share/doc/cc65/compile.txt
|
||||
share/doc/cc65/debugging.txt
|
||||
share/doc/cc65/internal.doc
|
||||
share/doc/cc65/intro.txt
|
||||
share/doc/cc65/ld65.txt
|
||||
share/doc/cc65/library.txt
|
||||
share/doc/cc65/newvers.txt
|
||||
share/doc/cc65/readme.txt
|
||||
share/doc/cc65/BUGS
|
||||
share/doc/cc65/CREDITS
|
||||
share/doc/cc65/announce.txt
|
||||
%%PORTDOCS%%share/doc/cc65/BUGS
|
||||
%%PORTDOCS%%share/doc/cc65/CREDITS
|
||||
%%PORTDOCS%%share/doc/cc65/Makefile
|
||||
%%PORTDOCS%%share/doc/cc65/Makefile.orig
|
||||
%%PORTDOCS%%share/doc/cc65/ar65.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/ca65.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/cc65.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/cl65.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/coding.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/compile.txt
|
||||
%%PORTDOCS%%share/doc/cc65/debugging.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/dio.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/geos.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/grc.txt
|
||||
%%PORTDOCS%%share/doc/cc65/index.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/internal.txt
|
||||
%%PORTDOCS%%share/doc/cc65/intro.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/ld65.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/library.sgml
|
||||
%%PORTDOCS%%share/doc/cc65/newvers.txt
|
||||
%%PORTDOCS%%share/doc/cc65/readme.1st
|
||||
%%PORTDOCS%%share/doc/cc65/announce.txt
|
||||
bin/ar65
|
||||
bin/ca65
|
||||
bin/ld65
|
||||
bin/cc65
|
||||
bin/cl65
|
||||
bin/da65
|
||||
bin/grc
|
||||
bin/ld65
|
||||
bin/od65
|
||||
bin/ca65html
|
||||
lib/cc65/include/geos/gconst.h
|
||||
lib/cc65/include/geos/gdisk.h
|
||||
lib/cc65/include/geos/gdlgbox.h
|
||||
lib/cc65/include/geos/gfile.h
|
||||
lib/cc65/include/geos/ggraph.h
|
||||
lib/cc65/include/geos/gmemory.h
|
||||
lib/cc65/include/geos/gmenu.h
|
||||
lib/cc65/include/geos/gprocess.h
|
||||
lib/cc65/include/geos/gsprite.h
|
||||
lib/cc65/include/geos/gstruct.h
|
||||
lib/cc65/include/geos/gsym.h
|
||||
lib/cc65/include/geos/gsys.h
|
||||
lib/cc65/include/6502.h
|
||||
lib/cc65/include/_6525.h
|
||||
lib/cc65/include/_6526.h
|
||||
lib/cc65/include/_6545.h
|
||||
lib/cc65/include/_6551.h
|
||||
lib/cc65/include/_antic.h
|
||||
lib/cc65/include/_gtia.h
|
||||
lib/cc65/include/_pbi.h
|
||||
lib/cc65/include/_pia.h
|
||||
lib/cc65/include/_pokey.h
|
||||
lib/cc65/include/_sid.h
|
||||
lib/cc65/include/_vdc.h
|
||||
lib/cc65/include/_vic.h
|
||||
lib/cc65/include/ace.h
|
||||
lib/cc65/include/apple2.h
|
||||
lib/cc65/include/assert.h
|
||||
lib/cc65/include/atari.h
|
||||
lib/cc65/include/c128.h
|
||||
lib/cc65/include/c64.h
|
||||
lib/cc65/include/cbm.h
|
||||
lib/cc65/include/cbm510.h
|
||||
lib/cc65/include/cbm610.h
|
||||
lib/cc65/include/conio.h
|
||||
lib/cc65/include/ctype.h
|
||||
lib/cc65/include/dbg.h
|
||||
lib/cc65/include/dio.h
|
||||
lib/cc65/include/errno.h
|
||||
lib/cc65/include/fcntl.h
|
||||
lib/cc65/include/geos.h
|
||||
lib/cc65/include/graphics.h
|
||||
lib/cc65/include/iso646.h
|
||||
lib/cc65/include/joystick.h
|
||||
lib/cc65/include/limits.h
|
||||
lib/cc65/include/locale.h
|
||||
lib/cc65/include/mouse.h
|
||||
lib/cc65/include/nes.h
|
||||
lib/cc65/include/pet.h
|
||||
lib/cc65/include/plus4.h
|
||||
lib/cc65/include/rs232.h
|
||||
|
@ -55,25 +86,52 @@ lib/cc65/include/stdio.h
|
|||
lib/cc65/include/stdlib.h
|
||||
lib/cc65/include/string.h
|
||||
lib/cc65/include/time.h
|
||||
lib/cc65/lib/apple2.lib
|
||||
lib/cc65/include/zlib.h
|
||||
lib/cc65/lib/apple2.o
|
||||
lib/cc65/lib/c128.lib
|
||||
lib/cc65/lib/atari.o
|
||||
lib/cc65/lib/c128.o
|
||||
lib/cc65/lib/c64.lib
|
||||
lib/cc65/lib/c64.o
|
||||
lib/cc65/lib/cbm610.lib
|
||||
lib/cc65/lib/cbm510.o
|
||||
lib/cc65/lib/cbm610.o
|
||||
lib/cc65/lib/pet.lib
|
||||
lib/cc65/lib/geos.o
|
||||
lib/cc65/lib/pet.o
|
||||
lib/cc65/lib/plus4.lib
|
||||
lib/cc65/lib/plus4.o
|
||||
share/doc/cc65/samples/Makefile
|
||||
share/doc/cc65/samples/c1541.rsp
|
||||
share/doc/cc65/samples/hello.c
|
||||
share/doc/cc65/samples/nachtm.c
|
||||
share/doc/cc65/samples/sieve.c
|
||||
@dirrm share/doc/cc65/samples
|
||||
@dirrm share/doc/cc65
|
||||
lib/cc65/lib/apple2.lib
|
||||
lib/cc65/lib/atari.lib
|
||||
lib/cc65/lib/c128.lib
|
||||
lib/cc65/lib/c64.lib
|
||||
lib/cc65/lib/cbm510.lib
|
||||
lib/cc65/lib/cbm610.lib
|
||||
lib/cc65/lib/geos.lib
|
||||
lib/cc65/lib/pet.lib
|
||||
lib/cc65/lib/plus4.lib
|
||||
%%PORTDOCS%%share/doc/cc65/samples/Makefile
|
||||
%%PORTDOCS%%share/doc/cc65/samples/README
|
||||
%%PORTDOCS%%share/doc/cc65/samples/hello.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/mousedemo.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/nachtm.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/plasma.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/sieve.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/appfile.grc
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/apphello1.grc
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/apphello2.grc
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/apprmvprot.grc
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/appyesno.grc
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/dialog.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/filesel.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/geosconio.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/geosconiores.res
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/grphstr.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/hello1.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/hello2.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/inittab.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/menu.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/rmvprot.c
|
||||
%%PORTDOCS%%share/doc/cc65/samples/geos/yesno.c
|
||||
@dirrm lib/cc65/lib
|
||||
@dirrm lib/cc65/include/geos
|
||||
@dirrm lib/cc65/include
|
||||
@dirrm lib/cc65
|
||||
%%PORTDOCS%%@dirrm share/doc/cc65/samples/geos
|
||||
%%PORTDOCS%%@dirrm share/doc/cc65/samples
|
||||
%%PORTDOCS%%@dirrm share/doc/cc65
|
||||
|
|
Loading…
Reference in a new issue