Unbreak, including switching the Motif dependency to lesstif.

PR:		ports/44768
Submitted by:	Paul Everlund <tdv94ped@cs.umu.se>,
		Mark Linimon <linimon@lonesome.com>
This commit is contained in:
Eric Anholt 2003-05-13 18:57:24 +00:00
parent f2b39cb68f
commit 54587965be
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80930
6 changed files with 66 additions and 62 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= xblackjack
PORTVERSION= 2.2
PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
@ -15,10 +16,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= An X11/Motif blackjack game
BROKEN= "Broken by open-motif upgrade"
USE_MOTIF= yes
USE_IMAKE= yes
LIB_DEPENDS+= Xm.1:${PORTSDIR}/x11-toolkits/lesstif
MAN1= xblackjack.1
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- Draw.c.orig Wed Oct 30 22:16:05 2002
+++ Draw.c Wed Oct 30 22:34:05 2002
@@ -84,7 +84,7 @@
#include <Xol/OpenLook.h>
#else
#include <X11/Xutil.h>
-#include <X11/Xm/Xm.h>
+#include <Xm/Xm.h>
#endif
#include "Assert.h"
#include "Bitmaps.h"

View file

@ -0,0 +1,11 @@
--- Imakefile.orig Wed Oct 30 22:39:10 2002
+++ Imakefile Wed Oct 30 22:39:40 2002
@@ -54,7 +54,7 @@
/*
* You may need to remove -lbsd.
*/
- EXTRA_LIBRARIES = -lXm $(DEPLIBS) -lbsd
+ EXTRA_LIBRARIES = ${MOTIFLIB} -lXt -lXmu -lXext -lX11
#endif
/*

View file

@ -0,0 +1,13 @@
--- Strategy.c.orig Wed Oct 30 22:23:48 2002
+++ Strategy.c Wed Oct 30 22:24:07 2002
@@ -95,8 +95,8 @@
#include <Xol/OpenLook.h>
#include <Xol/StaticText.h>
#else
-#include <X11/Xm/Xm.h>
-#include <X11/Xm/Label.h>
+#include <Xm/Xm.h>
+#include <Xm/Label.h>
#include "Table.h"
#endif
#include "Assert.h"

View file

@ -0,0 +1,29 @@
--- Table.c.orig Wed Oct 30 22:35:52 2002
+++ Table.c Wed Oct 30 23:11:30 2002
@@ -229,7 +229,7 @@
/* always_install_accelerators */ False,
#if XmVersion > 1000
/* geo_matrix_create */ NULL,
- /* focus_moved_proc */ XtInheritFocusMovedProc,
+ /* focus_moved_proc */ /*XtInheritFocusMovedProc,*/
#endif
/* extension */ NULL,
},
@@ -967,7 +967,7 @@
/* XtMoveWidget(w, rx, ry);*/
#if 1
- _XmMoveObject((RectObj) w, rx, ry);
+ _XmMoveObject( w, rx, ry);
#else
_XmMoveObject( w, rx, ry);
#endif
@@ -1020,7 +1020,7 @@
w, nw, nh,
w->core.border_width);
#endif
- _XmResizeObject((RectObj) managed->locs[i].w, nw, nh,
+ _XmResizeObject( managed->locs[i].w, nw, nh,
managed->locs[i].w->core.border_width);
}

View file

@ -1,59 +0,0 @@
--- Imakefile~ Thu Aug 1 21:41:28 1996
+++ Imakefile Thu Aug 1 21:41:43 1996
@@ -54,7 +54,7 @@
/*
* You may need to remove -lbsd.
*/
- EXTRA_LIBRARIES = -lXm $(DEPLIBS) -lbsd
+ EXTRA_LIBRARIES = ${MOTIFLIB} -lXt -lXmu -lXext -lX11
#endif
/*
--- Table.c~ Thu Aug 1 21:39:10 1996
+++ Table.c Thu Aug 1 21:40:50 1996
@@ -229,7 +229,8 @@
/* always_install_accelerators */ False,
#if XmVersion > 1000
/* geo_matrix_create */ NULL,
- /* focus_moved_proc */ XtInheritFocusMovedProc,
+ /* focus_moved_proc */ /*XtInheritFocusMovedProc,*/
+ XtCallAcceptFocus,
#endif
/* extension */ NULL,
},
--- TableP.h~ Thu Aug 1 21:36:01 1996
+++ TableP.h Thu Aug 1 21:38:03 1996
@@ -15,6 +15,9 @@
#include "Table.h"
#include <Xm/XmP.h>
+#include <Xm/TravActI.h>
+#include <Xm/ManagerI.h>
+#include <Xm/BulletinBI.h>
#include <Xm/BulletinBP.h>
/*
--- ./Draw.c.org Fri Jun 18 10:17:44 1993
+++ ./Draw.c Mon Aug 19 03:45:59 1996
@@ -84,7 +84,7 @@
#include <Xol/OpenLook.h>
#else
#include <X11/Xutil.h>
-#include <X11/Xm/Xm.h>
+#include <Xm/Xm.h>
#endif
#include "Assert.h"
#include "Bitmaps.h"
--- ./Strategy.c.org Fri Jun 18 10:17:44 1993
+++ ./Strategy.c Mon Aug 19 03:48:21 1996
@@ -95,8 +95,8 @@
#include <Xol/OpenLook.h>
#include <Xol/StaticText.h>
#else
-#include <X11/Xm/Xm.h>
-#include <X11/Xm/Label.h>
+#include <Xm/Xm.h>
+#include <Xm/Label.h>
#include "Table.h"
#endif
#include "Assert.h"