- Fix build clang

PR:		180516
Submitted by:	maintainer
This commit is contained in:
Martin Wilke 2013-07-16 05:48:14 +00:00
parent 8d5f3c22d7
commit 54659968ea
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323095
3 changed files with 28 additions and 9 deletions

View file

@ -1,9 +1,5 @@
# New ports collection makefile for: epos-devel
# Date created: 3 September 2005
# Whom: Martin Matuska <mm@FreeBSD.org>
#
# Created by: Martin Matuska <mm@FreeBSD.org>
# $FreeBSD$
#
PORTNAME= epos
PORTVERSION= 2.5.37
@ -15,14 +11,15 @@ COMMENT= Text-to-Speech system
LICENSE= GPLv2 LGPL20
LICENSE_COMB= multi
LICENSE_FILE_GPLv2= ${WRKSRC}/doc/COPYING
LICENSE_FILE_LGPL20= ${WRKSRC}/libs/regex/COPYING.LIB
USES= bison gmake
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ENV= ac_cv_lib_stdcpp_main=no
MAKE_JOBS_SAFE= yes
post-patch:
${REINPLACE_CMD} -e 's/^\(SUBDIRS =.*\)doc/\1/' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's/^\(SUBDIRS =.*\)doc/\1/' ${WRKSRC}/Makefile.in
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-ggdb||'
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- src/nnet/map.h.orig
+++ src/nnet/map.h
@@ -25,7 +25,7 @@
else {
TData x;
x.first() = key;
- return insert (x)->second();
+ return this->insert (x)->second();
}
}

View file

@ -0,0 +1,11 @@
--- src/nnet/neural_parse.yy.orig
+++ src/nnet/neural_parse.yy
@@ -255,7 +255,7 @@
int yyerror (char *s)
{
- shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf, s));
+ shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf.c_str(), s));
return -1;
}