- Remove audio/audacity-devel, because it's now redundant after

updating audio/audacity to the latest version.

PR:		ports/63674
Submitted by:	maintainer
This commit is contained in:
Kirill Ponomarev 2004-03-03 13:16:54 +00:00
parent 4be40100eb
commit 54674e87a9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=102819
14 changed files with 0 additions and 263 deletions

View file

@ -19,7 +19,6 @@
SUBDIR += asmixer
SUBDIR += aube
SUBDIR += audacity
SUBDIR += audacity-devel
SUBDIR += aumix
SUBDIR += aureal-kmod
SUBDIR += autocd

View file

@ -1,66 +0,0 @@
# New ports collection makefile for: audacity-devel
# Date created: 2 Dec 2003
# Whom: Craig Boston <craig@yekse.gank.org>
#
# $FreeBSD$
PORTNAME= audacity
PORTVERSION= 1.2.0.p3
PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-src-1.2.0-pre3
MAINTAINER= craig@yekse.gank.org
COMMENT= Audacity is a GUI editor for digital audio waveforms
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
CONFLICTS= audacity-1.0*
LATEST_LINK= audacity-devel
WRKSRC= ${WRKDIR}/${PORTNAME}-src-1.2.0-pre3
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
WX_CONFIG=${X11BASE}/bin/wxgtk2-2.4-config
CONFIGURE_ARGS+= --with-id3=no
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
MAKE_ENV= DOC=yes
.endif
.if !defined(WITHOUT_MAD)
CONFIGURE_ARGS+= --with-libmad=system
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
.else
CONFIGURE_ARGS+= --without-libmad
.endif
.if !defined(WITHOUT_VORBIS)
CONFIGURE_ARGS+= --with-vorbis=system
LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+= --without-vorbis
.endif
pre-everything::
.if !defined(WITHOUT_MAD)
@${ECHO_MSG} "You can disable support for libmad (MP3) by defining WITHOUT_MAD."
.endif
.if !defined(WITHOUT_VORBIS)
@${ECHO_MSG} "You can disable support for vorbis by defining WITHOUT_VORBIS."
.endif
MAN1= audacity.1
MANCOMPRESSED= yes
.include <bsd.port.post.mk>

View file

@ -1 +0,0 @@
MD5 (audacity-src-1.2.0-pre3.tar.bz2) = a7efddd64e2ce3e380614796d689e11f

View file

@ -1,17 +0,0 @@
--- Makefile.in.orig Tue Dec 2 22:43:47 2003
+++ Makefile.in Tue Dec 2 22:46:38 2003
@@ -27,12 +27,14 @@
$(INSTALL) -d $(DESTDIR)$(BINDIR)
$(INSTALL) -m 755 audacity $(DESTDIR)$(BINDIR)/$(AUDACITY_NAME)
+ifeq ($(DOC),yes)
# install docs
$(INSTALL) -d $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)
-test -f audacity-1.2-help.htb && $(INSTALL) -m 644 audacity-1.2-help.htb \
$(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/audacity-1.2-help.htb
$(INSTALL) -m 644 README.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/README.txt
$(INSTALL) -m 644 LICENSE.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/LICENSE.txt
+endif
# install manpage
$(INSTALL) -d $(DESTDIR)$(MANDIR)/man1

View file

@ -1,36 +0,0 @@
--- lib-src/libnyquist/Makefile.in.orig Tue Dec 2 19:32:18 2003
+++ lib-src/libnyquist/Makefile.in Tue Dec 2 19:32:42 2003
@@ -465,13 +465,13 @@
cc -c cmt/userio.c -o cmt/userio.o $(CFLAGS)
misc/intgen: misc/intgen.c
- cd misc; make intgen
+ cd misc; $(MAKE) intgen
misc/unpacker: misc/unpacker.c misc/convert.c
- cd misc; make unpacker
+ cd misc; $(MAKE) unpacker
misc/packer: misc/packer.c misc/convert.c
- cd misc; make packer
+ cd misc; $(MAKE) packer
nyqsrc/sndfnintptrs.h: $(NYQHDRS) snd/snd.h misc/intgen
$(INTGEN) nyqsrc/sndfnint $(NYQHDRS)
@@ -481,14 +481,14 @@
clean:
rm -f libnyquist.a
- cd misc; make clean
+ cd misc; $(MAKE) clean
rm -f $(OBJECTS)
# Note that these files are machine-generated:
rm -f nyqsrc/sndfnintptrs.h nyqsrc/sndfnint.c nyqsrc/sndfnintdefs.h
rm -f nyqsrc/seqfnintptrs.h nyqsrc/seqfnint.c nyqsrc/seqfnintdefs.h
cleaner: clean
- cd misc; make cleaner
+ cd misc; $(MAKE) cleaner
rm -f *.backup */*.backup
rm -f *~ */*.*~
rm -f *.save */*.save

View file

@ -1,11 +0,0 @@
--- lib-src/libnyquist/sys/switches.h.orig Tue Dec 2 19:14:40 2003
+++ lib-src/libnyquist/sys/switches.h Tue Dec 2 19:16:20 2003
@@ -39,7 +39,7 @@
*/
#define nyquist_printf printf
-#if __APPLE__ && __GNUC__ /* Mac OS X */
+#if (__FreeBSD__ || __APPLE__) && __GNUC__ /* Mac OS X */
#define NEED_ULONG 1
#else
#include <sys/types.h>

View file

@ -1,11 +0,0 @@
--- lib-src/libnyquist/sys/term.c.orig Tue Dec 2 19:17:30 2003
+++ lib-src/libnyquist/sys/term.c Tue Dec 2 19:17:51 2003
@@ -40,7 +40,7 @@
#else
#include <termios.h>
-#ifndef __APPLE__
+#if !defined(__APPLE__) && !defined(__FreeBSD__)
#include <asm/ioctls.h>
#endif
#include <signal.h>

View file

@ -1,11 +0,0 @@
--- lib-src/libresample/Makefile.in.orig Tue Dec 2 19:46:02 2003
+++ lib-src/libresample/Makefile.in Tue Dec 2 19:46:25 2003
@@ -6,7 +6,7 @@
CC = @CC@
CFLAGS = @CFLAGS@ -Wall
-LIBS = @LIBS@ -lm
+LIBS = @LDFLAGS@ @LIBS@ -lm
AR = @AR@
RANLIB = @RANLIB@

View file

@ -1,11 +0,0 @@
--- lib-src/portaudio/pa_unix_oss/pa_unix.h.orig Tue Dec 2 19:56:56 2003
+++ lib-src/portaudio/pa_unix_oss/pa_unix.h Tue Dec 2 19:58:33 2003
@@ -82,7 +82,7 @@
#define MAX_TIMEOUT_MSEC (1000)
/************************************************* Definitions ********/
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
#define DEVICE_NAME_BASE "/dev/dsp"
#else
#define DEVICE_NAME_BASE "/dev/audio"

View file

@ -1,11 +0,0 @@
--- lib-src/portaudio/pa_unix_oss/pa_unix_oss.c.orig Tue Dec 2 19:57:13 2003
+++ lib-src/portaudio/pa_unix_oss/pa_unix_oss.c Tue Dec 2 19:57:47 2003
@@ -42,6 +42,8 @@
#ifdef __linux__
#include <linux/soundcard.h>
+#elif defined(__FreeBSD__)
+#include <sys/soundcard.h>
#else
#include <machine/soundcard.h> /* JH20010905 */
#endif

View file

@ -1,11 +0,0 @@
--- lib-src/portmixer/px_unix_oss/px_unix_oss.c.orig Tue Dec 2 20:06:55 2003
+++ lib-src/portmixer/px_unix_oss/px_unix_oss.c Tue Dec 2 20:07:09 2003
@@ -37,6 +37,8 @@
#ifdef __linux__
#include <linux/soundcard.h>
+#elif defined(__FreeBSD__)
+#include <sys/soundcard.h>
#else
#include <machine/soundcard.h> /* JH20010905 */
#endif

View file

@ -1,16 +0,0 @@
--- lib-src/soundtouch/Makefile.in.orig Tue Dec 2 19:01:28 2003
+++ lib-src/soundtouch/Makefile.in Tue Dec 2 19:03:17 2003
@@ -1,10 +1,10 @@
all:
- cd src && make
+ cd src && $(MAKE)
clean:
rm -f *~ *.a config.cache config.log config.status core*
- cd src && make clean
+ cd src && $(MAKE) clean
distclean: clean
rm -f Makefile
- cd src && make dist
+ cd src && $(MAKE) dist

View file

@ -1,16 +0,0 @@
Audacity is a program that lets you manipulate digital audio
waveforms. In addition to letting you record sounds directly from
within the program, it imports many sound file formats, including
WAV, AIFF, AU, IRCAM, MP3, and Ogg Vorbis. It supports all
common editing operations such as Cut, Copy, and Paste, plus it will
mix tracks and let you apply plug-in effects to any part of a sound. It
also has a built-in amplitude envelope editor, a customizable
spectrogram mode and a frequency analysis window for audio
analysis applications.
This is the development release of Audacity. It has significant
feature improvements over the stable release (audio/audacity), but has
not received as much real-world testing.
Author: Dominic Mazzoni dominic@minorninth.com
WWW: http://audacity.sourceforge.net

View file

@ -1,44 +0,0 @@
bin/audacity
share/audacity/nyquist/bug.lsp
share/audacity/nyquist/dspprims.lsp
share/audacity/nyquist/evalenv.lsp
share/audacity/nyquist/follow.lsp
share/audacity/nyquist/init.lsp
share/audacity/nyquist/misc.lsp
share/audacity/nyquist/nyinit.lsp
share/audacity/nyquist/nyqmisc.lsp
share/audacity/nyquist/nyquist.lsp
share/audacity/nyquist/printrec.lsp
share/audacity/nyquist/profile.lsp
share/audacity/nyquist/seq.lsp
share/audacity/nyquist/seqfnint.lsp
share/audacity/nyquist/seqmidi.lsp
share/audacity/nyquist/sndfnint.lsp
share/audacity/nyquist/system.lsp
share/audacity/nyquist/test.lsp
share/audacity/nyquist/xlinit.lsp
share/audacity/plug-ins/clicktrack.ny
share/audacity/plug-ins/delay.ny
share/audacity/plug-ins/highpass.ny
share/audacity/plug-ins/lowpass.ny
share/audacity/plug-ins/pluck.ny
share/audacity/plug-ins/tremolo.ny
share/locale/bg/LC_MESSAGES/audacity.mo
share/locale/ca/LC_MESSAGES/audacity.mo
share/locale/cs/LC_MESSAGES/audacity.mo
share/locale/da/LC_MESSAGES/audacity.mo
share/locale/de/LC_MESSAGES/audacity.mo
share/locale/es/LC_MESSAGES/audacity.mo
share/locale/it/LC_MESSAGES/audacity.mo
share/locale/mk/LC_MESSAGES/audacity.mo
share/locale/nl/LC_MESSAGES/audacity.mo
share/locale/pt/LC_MESSAGES/audacity.mo
share/locale/ru/LC_MESSAGES/audacity.mo
share/locale/sv/LC_MESSAGES/audacity.mo
@dirrm share/audacity/plug-ins
@dirrm share/audacity/nyquist
@dirrm share/audacity
%%PORTDOCS%%%%DOCSDIR%%/audacity-1.2-help.htb
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%