devel/py-poetry-types: Add py-poetry-types 0.3.5
poetry-types is a plugin to poetry for the poetry plugin feature. It installs/removes/updates typing stubs via following commands: - poetry types add <package names> - poetry types remove <package names> - poetry types update <package names>
This commit is contained in:
parent
6aed6e9048
commit
54cb2983d5
5 changed files with 45 additions and 0 deletions
|
@ -5106,6 +5106,7 @@
|
|||
SUBDIR += py-poetry-dynamic-versioning
|
||||
SUBDIR += py-poetry-plugin-export
|
||||
SUBDIR += py-poetry-semver
|
||||
SUBDIR += py-poetry-types
|
||||
SUBDIR += py-poetry2setup
|
||||
SUBDIR += py-polib
|
||||
SUBDIR += py-pooch
|
||||
|
|
25
devel/py-poetry-types/Makefile
Normal file
25
devel/py-poetry-types/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
PORTNAME= poetry-types
|
||||
PORTVERSION= 0.3.5
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= poetry_types-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Poetry plugin that adds/removes type stubs as dependencies
|
||||
WWW= https://github.com/jvllmr/poetry-types
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=21.3:devel/py-packaging@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}poetry>=1.2<2:devel/py-poetry@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}tomlkit>=0.11.4<0.12:textproc/py-tomlkit@${PY_FLAVOR}
|
||||
|
||||
USES= python:3.7+
|
||||
USE_PYTHON= autoplist concurrent pep517
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/py-poetry-types/distinfo
Normal file
3
devel/py-poetry-types/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1681052888
|
||||
SHA256 (poetry_types-0.3.5.tar.gz) = 8178e5ceb8d4ec01cf5eeba128736442c27faec9171ae525372b3812a82d85ec
|
||||
SIZE (poetry_types-0.3.5.tar.gz) = 6443
|
11
devel/py-poetry-types/files/patch-pyproject.toml
Normal file
11
devel/py-poetry-types/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- pyproject.toml.orig 2022-12-29 14:10:46 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -16,7 +16,7 @@ classifiers = [
|
||||
python = "^3.7"
|
||||
poetry = "^1.2"
|
||||
tomlkit = "^0.11.4"
|
||||
-packaging = "^21.3"
|
||||
+packaging = ">=21.3"
|
||||
|
||||
[tool.poetry.group.dev.dependencies]
|
||||
pytest = "^7.0"
|
5
devel/py-poetry-types/pkg-descr
Normal file
5
devel/py-poetry-types/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
poetry-types is a plugin to poetry for the poetry plugin feature. It
|
||||
installs/removes/updates typing stubs via following commands:
|
||||
- poetry types add <package names>
|
||||
- poetry types remove <package names>
|
||||
- poetry types update <package names>
|
Loading…
Reference in a new issue