Add bomberinstinct - a nice Bomberman-like multiplayer game.

This commit is contained in:
Maxim Sobolev 2000-09-28 09:32:23 +00:00
parent b22766fe59
commit 54edf3ba8d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33201
8 changed files with 212 additions and 0 deletions

View file

@ -25,6 +25,7 @@
SUBDIR += blue
SUBDIR += bnetd
SUBDIR += bogged
SUBDIR += bomberinstinct
SUBDIR += bombermaze
SUBDIR += bs
SUBDIR += bugsx

View file

@ -0,0 +1,37 @@
# New ports collection makefile for: bomberinstinct
# Date created: 28 September 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= bomberinstinct
PORTVERSION= 0.8.21
CATEGORIES= games
MASTER_SITES= http://harpe.dptmaths.ens-cachan.fr/U/gesbert/dl/
DISTNAME= BomberInstinct-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
WRKSRC= ${WRKDIR}/BomberInstinct
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
pre-patch:
@find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e 's|<SDL/|<|g'
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/bi ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/Nived/nived ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/Spred/spred ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/BomberInstinct
@${INSTALL_DATA} ${WRKSRC}/bi.cfg ${PREFIX}/share/BomberInstinct
@cd ${WRKSRC}; tar cf - Décors Sprites Niveaux Bruitages | \
(cd ${PREFIX}/share/BomberInstinct; ${TAR} --unlink -xf - )
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (BomberInstinct-0.8.21.tar.gz) = d5a2f5be3a56ac72673d3394d3639328

View file

@ -0,0 +1,37 @@
# This file contains the template for Makeflags
SYSTEM = FreeBSD
FEATURES = -DASYNCHRONOUS_IO -DUSE_POSIX_SIGNALS -DUNSIGNED_AUDIO_DATA -DFORCE_XSHM -DNETPLAY
LOGIC = netlogic
XPMINCLUDE =
XPMLINKDIR =
BINDIR = ${PREFIX}/bin
LIBDIR = ${PREFIX}/share/Maelstrom
DATAFILES = Images/*.icon Images/*.cicn "Maelstrom Fonts" \
"Maelstrom Sounds" "Maelstrom Sprites"
OBJS = main.o framebuf.o v_framebuf.o x11_framebuf.o vga_framebuf.o \
dga_framebuf.o fontserv.o sound.o Mac_Resource.o imagedump.o \
init.o $(LOGIC)/$(LOGIC).o \
controls.o scores.o dialog.o fastrand.o netscore.o checksum.o \
Utils.o shared.o myerror.o
SOUNDOBJS = Maelstrom_sound.o Mac_Resource.o soundres.o mixer.o shared.o myerror.o
X11INCLUDE = -I${X11BASE}/include
INCLUDES = -I$(LOGIC) $(X11INCLUDE) $(XPMINCLUDE)
CFLAGS += $(INCLUDES) $(FEATURES) \
-pedantic -DSYSTEM=\"$(SYSTEM)\" -DLIBDIR=\"$(LIBDIR)\"
EXTRALIBS =
X11LINKDIR = -L${X11BASE}/lib
X11LIBS = -lXpm $(XPMLINKDIR) -lX11 -lXext $(X11LINKDIR)
CSUMLIB =
LIBS = $(EXTRALIBS) $(X11LIBS) $(CSUMLIB)
SOUNDLIBS =
INSTALL = install
all: $(MAELSTROM)

View file

@ -0,0 +1,32 @@
--- Makefile.orig Sun Sep 24 23:50:45 2000
+++ Makefile Thu Sep 28 11:58:34 2000
@@ -1,7 +1,7 @@
VERSION=0.8.21
#Langue : francais ou english
-LANGUE=francais
+LANGUE=english
#langue=english
#Cible : Linux ou Windows (ou probablement d'autres mais je n'ai que ceux-là).
@@ -28,14 +28,15 @@
ifeq ($(LOCAL),1)
DATADIR = $(HOME)/BomberInstinct
else
- DATADIR = /usr/local/share/BomberInstinct
+ DATADIR = $(PREFIX)/share/BomberInstinct
endif
- BINDIR = /usr/local/bin
- CC = gcc
- CFLAGS := $(shell sdl-config --cflags) -Wall -O3\
+ BINDIR = $(PREFIX)/bin
+ CC? = gcc
+ CFLAGS_ := $(shell $(SDL_CONFIG) --cflags) -Wall \
-D$(CIBLE) -DDIR=\"$(DATADIR)\" -DVERSION=\"$(VERSION)\"
- LIBS := $(shell sdl-config --libs) -lSDL_mixer -lm #-lSDL_image --static
+ CFLAGS += $(CFLAGS_)
+ LIBS := $(shell $(SDL_CONFIG) --libs) -lSDL_mixer -lsmpeg -lgcc_r -lm #-lSDL_image --static
endif
OBJS = sprites.o niveaux.o pouvoirs.o evenements.o options.o son.o intro.o SFont/font.o
ifeq ($(DEBUG),1)

View file

@ -0,0 +1 @@
A nice Bomberman-like multiplayer game

View file

@ -0,0 +1,8 @@
BomberInstinct is a multiplayer-only Bomberman-like game. It plays only on a
single computer at the moment, with keyboard or joystick. It's part like
Bomberman, because you must kill the other players with bombs that throw flames
vertically and horizontally, but it's much more strategical because you have to
do with the elements of a maze (arrows, tunnels, teleportations, and many
more...), and with the special powers of each character.
WWW: http://harpe.dptmaths.ens-cachan.fr/U/gesbert/download.html

View file

@ -0,0 +1,95 @@
bin/bi
bin/nived
bin/spred
share/BomberInstinct/Bruitages/bouton.wav
share/BomberInstinct/Bruitages/choix.s3m
share/BomberInstinct/Bruitages/debut.wav
share/BomberInstinct/Bruitages/expl.wav
share/BomberInstinct/Bruitages/fin.wav
share/BomberInstinct/Bruitages/fontaine.wav
share/BomberInstinct/Bruitages/intro.s3m
share/BomberInstinct/Bruitages/mort.wav
share/BomberInstinct/Bruitages/teleport.wav
share/BomberInstinct/Décors/Bande.bmp
share/BomberInstinct/Décors/Choix.bmp
share/BomberInstinct/Décors/Menu.bmp
share/BomberInstinct/Décors/Menu_en.bmp
share/BomberInstinct/Décors/Menu_fr.bmp
share/BomberInstinct/Décors/Options.bmp
share/BomberInstinct/Décors/Options_en.bmp
share/BomberInstinct/Décors/Options_fr.bmp
share/BomberInstinct/Décors/font.bmp
share/BomberInstinct/Décors/icone.bmp
share/BomberInstinct/Décors/mode.bmp
share/BomberInstinct/Décors/mode_0.bmp
share/BomberInstinct/Décors/mode_1.bmp
share/BomberInstinct/Décors/mode_2.bmp
share/BomberInstinct/Niveaux/choix.niv
share/BomberInstinct/Niveaux/dedale.niv
share/BomberInstinct/Niveaux/electr.g
share/BomberInstinct/Niveaux/enfer.niv
share/BomberInstinct/Niveaux/fatum.niv
share/BomberInstinct/Niveaux/grotte.g
share/BomberInstinct/Niveaux/haha.niv
share/BomberInstinct/Niveaux/laby.niv
share/BomberInstinct/Niveaux/manon.niv
share/BomberInstinct/Niveaux/menu.niv
share/BomberInstinct/Niveaux/mysteredesruinesanciennes.niv
share/BomberInstinct/Niveaux/nils.niv
share/BomberInstinct/Niveaux/nol.niv
share/BomberInstinct/Niveaux/nouv.niv
share/BomberInstinct/Niveaux/options.niv
share/BomberInstinct/Niveaux/shadow.niv
share/BomberInstinct/Niveaux/tdm.niv
share/BomberInstinct/Niveaux/vide.niv
share/BomberInstinct/Sprites/1.spr
share/BomberInstinct/Sprites/2.spr
share/BomberInstinct/Sprites/3.spr
share/BomberInstinct/Sprites/4.spr
share/BomberInstinct/Sprites/5.spr
share/BomberInstinct/Sprites/6.spr
share/BomberInstinct/Sprites/7.spr
share/BomberInstinct/Sprites/8.spr
share/BomberInstinct/Sprites/TeraSoft1.spr
share/BomberInstinct/Sprites/TeraSoft2.spr
share/BomberInstinct/Sprites/barbare.spr
share/BomberInstinct/Sprites/bombe.spr
share/BomberInstinct/Sprites/bonus.spr
share/BomberInstinct/Sprites/bouton.spr
share/BomberInstinct/Sprites/caillou.spr
share/BomberInstinct/Sprites/circuit.spr
share/BomberInstinct/Sprites/citrouille.spr
share/BomberInstinct/Sprites/condens.spr
share/BomberInstinct/Sprites/court-circuit.spr
share/BomberInstinct/Sprites/etoiles.spr
share/BomberInstinct/Sprites/faille.spr
share/BomberInstinct/Sprites/flammes.spr
share/BomberInstinct/Sprites/fleche.spr
share/BomberInstinct/Sprites/flechrouge.spr
share/BomberInstinct/Sprites/fontaine.spr
share/BomberInstinct/Sprites/grotte.spr
share/BomberInstinct/Sprites/infos.spr
share/BomberInstinct/Sprites/intro.spr
share/BomberInstinct/Sprites/louis.spr
share/BomberInstinct/Sprites/maagus.spr
share/BomberInstinct/Sprites/magus.spr
share/BomberInstinct/Sprites/menu.spr
share/BomberInstinct/Sprites/miroirs.spr
share/BomberInstinct/Sprites/murlave.spr
share/BomberInstinct/Sprites/murnul.spr
share/BomberInstinct/Sprites/neruis.spr
share/BomberInstinct/Sprites/nived.spr
share/BomberInstinct/Sprites/pschit.spr
share/BomberInstinct/Sprites/puce.spr
share/BomberInstinct/Sprites/rien.spr
share/BomberInstinct/Sprites/ruines.spr
share/BomberInstinct/Sprites/telgris.spr
share/BomberInstinct/Sprites/telrouge.spr
share/BomberInstinct/Sprites/troll.spr
share/BomberInstinct/Sprites/tunnel.spr
share/BomberInstinct/bi.cfg
@dirrm share/BomberInstinct/Sprites
@dirrm share/BomberInstinct/Niveaux
@dirrm share/BomberInstinct/Décors
@dirrm share/BomberInstinct/Bruitages
@dirrm share/BomberInstinct