Add iconv support for translating file names across multiple charsets.
PR: 68102
This commit is contained in:
parent
ef70919e2c
commit
5521e8d9ff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111834
2 changed files with 24 additions and 1 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= netatalk
|
||||
PORTVERSION= 2.0.b1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net print
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= netatalk
|
||||
|
@ -22,8 +23,10 @@ LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
|
|||
|
||||
NO_LATEST_LINK= yes
|
||||
USE_BZIP2= yes
|
||||
USE_ICONV= yes
|
||||
CONFIGURE_ARGS+= --with-tcp-wrappers \
|
||||
--with-pkgconfdir=${PREFIX}/etc
|
||||
--with-pkgconfdir=${PREFIX}/etc \
|
||||
--with-libiconv=${LOCALBASE}
|
||||
.if defined(WITH_PAM)
|
||||
CONFIGURE_ARGS+= --with-pam=/etc/pam.d
|
||||
PLIST_SUB+= NETATALKPAM=""
|
||||
|
|
20
net/netatalk-devel/files/patch-etc_afpd_Makefile.in
Normal file
20
net/netatalk-devel/files/patch-etc_afpd_Makefile.in
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- etc/afpd/Makefile.in.orig Sat Jun 19 18:36:07 2004
|
||||
+++ etc/afpd/Makefile.in Sat Jun 19 18:37:03 2004
|
||||
@@ -62,7 +62,7 @@
|
||||
CCDEPMODE = @CCDEPMODE@
|
||||
|
||||
CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/sys \
|
||||
- @CFLAGS@ @SLP_CFLAGS@ \
|
||||
+ @CFLAGS@ @SLP_CFLAGS@ @ICONV_CFLAGS@ \
|
||||
-D_PATH_AFPDDEFVOL=\"$(pkgconfdir)/AppleVolumes.default\" \
|
||||
-D_PATH_AFPDSYSVOL=\"$(pkgconfdir)/AppleVolumes.system\" \
|
||||
-D_PATH_AFPDPWFILE=\"$(pkgconfdir)/afppasswd\" \
|
||||
@@ -105,7 +105,7 @@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
|
||||
-LIBS = @LIBS@ @PAM_LIBS@ @QUOTA_LIBS@ @SLP_LIBS@
|
||||
+LIBS = @LIBS@ @PAM_LIBS@ @QUOTA_LIBS@ @SLP_LIBS@ @ICONV_LIBS@
|
||||
LIBTOOL = @LIBTOOL@
|
||||
LN_S = @LN_S@
|
||||
LTLIBOBJS = @LTLIBOBJS@
|
Loading…
Reference in a new issue