Remove gtksourceview for re-import under x11-toolkits. Since this is a
new port, no history is lost.
This commit is contained in:
parent
c23c7d4ba7
commit
55274a373f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80406
8 changed files with 0 additions and 115 deletions
|
@ -1,32 +0,0 @@
|
|||
# New ports collection makefile for: gtksourceview
|
||||
# Date created: 07 May 2003
|
||||
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gtksourceview
|
||||
PORTVERSION= 0.2.0
|
||||
CATEGORIES= editors devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.2
|
||||
DIST_SUBDIR= gnome2
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= A text widget that adds syntax highlighting to the GtkTextView widget
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_GNOME= gnomeprefix gnomehack libgnome
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib -lgnuregex"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
|
||||
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1 +0,0 @@
|
|||
MD5 (gnome2/gtksourceview-0.2.0.tar.bz2) = 3b3cae93b4f00f920cdae3a1cb096e75
|
|
@ -1,10 +0,0 @@
|
|||
--- configure.orig Tue Dec 17 05:27:57 2002
|
||||
+++ configure Sun Dec 22 17:31:25 2002
|
||||
@@ -7270,6 +7270,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
|
@ -1,14 +0,0 @@
|
|||
--- gtksourceview/gtksourcebuffer.c.orig Wed May 7 20:05:58 2003
|
||||
+++ gtksourceview/gtksourcebuffer.c Wed May 7 20:06:18 2003
|
||||
@@ -687,9 +687,10 @@
|
||||
static void
|
||||
get_tags_func (GtkTextTag *tag, gpointer data)
|
||||
{
|
||||
+ GSList **list;
|
||||
g_return_if_fail (data != NULL);
|
||||
|
||||
- GSList **list = (GSList **) data;
|
||||
+ list = (GSList **) data;
|
||||
|
||||
if (GTK_IS_SOURCE_TAG (tag))
|
||||
{
|
|
@ -1,11 +0,0 @@
|
|||
--- gtksourceview/gtksourceregex.h.orig Wed May 7 20:04:08 2003
|
||||
+++ gtksourceview/gtksourceregex.h Wed May 7 20:05:43 2003
|
||||
@@ -20,7 +20,7 @@
|
||||
#ifndef __GTK_SOURCE_REGEX_H__
|
||||
#define __GTK_SOURCE_REGEX_H__
|
||||
|
||||
-#include <regex.h>
|
||||
+#include <gnuregex.h>
|
||||
#include <glib/gtypes.h>
|
||||
|
||||
G_BEGIN_DECLS
|
|
@ -1,13 +0,0 @@
|
|||
--- gtksourceview/gtksourceview.c.orig Wed May 7 20:10:15 2003
|
||||
+++ gtksourceview/gtksourceview.c Wed May 7 20:10:28 2003
|
||||
@@ -762,8 +762,9 @@
|
||||
gtk_text_iter_forward_to_line_end (&cur);
|
||||
while (!gtk_text_iter_starts_line (&cur))
|
||||
{
|
||||
+ gunichar c;
|
||||
gtk_text_iter_backward_char (&cur);
|
||||
- gunichar c = gtk_text_iter_get_char (&cur);
|
||||
+ c = gtk_text_iter_get_char (&cur);
|
||||
if (!g_unichar_isspace (c))
|
||||
{
|
||||
/* We've gone one character too far. */
|
|
@ -1,3 +0,0 @@
|
|||
Gtksourceview is a text widget that extends the standard Gtk+ 2.x GtkTextView.
|
||||
It improves it by implementing syntax highlighting and other features typical
|
||||
of a source editor.
|
|
@ -1,31 +0,0 @@
|
|||
include/gtksourceview-1.0/gtksourceview/gtksourcebuffer.h
|
||||
include/gtksourceview-1.0/gtksourceview/gtksourcelanguage.h
|
||||
include/gtksourceview-1.0/gtksourceview/gtksourcelanguagesmanager.h
|
||||
include/gtksourceview-1.0/gtksourceview/gtksourcemarker.h
|
||||
include/gtksourceview-1.0/gtksourceview/gtksourcestylescheme.h
|
||||
include/gtksourceview-1.0/gtksourceview/gtksourcetag.h
|
||||
include/gtksourceview-1.0/gtksourceview/gtksourcetagstyle.h
|
||||
include/gtksourceview-1.0/gtksourceview/gtksourcetagtable.h
|
||||
include/gtksourceview-1.0/gtksourceview/gtksourceview.h
|
||||
lib/libgtksourceview-1.0.a
|
||||
lib/libgtksourceview-1.0.so
|
||||
lib/libgtksourceview-1.0.so.0
|
||||
libdata/pkgconfig/gtksourceview-1.0.pc
|
||||
share/gnome/gtksourceview-1.0/language-specs/ada.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/c.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/cpp.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/desktop.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/diff.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/html.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/idl.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/java.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/latex.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/perl.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/po.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/python.lang
|
||||
share/gnome/gtksourceview-1.0/language-specs/xml.lang
|
||||
share/locale/es/LC_MESSAGES/gtksourceview-1.0.mo
|
||||
@dirrm share/gnome/gtksourceview-1.0/language-specs
|
||||
@dirrm share/gnome/gtksourceview-1.0
|
||||
@dirrm include/gtksourceview-1.0/gtksourceview
|
||||
@dirrm include/gtksourceview-1.0
|
Loading…
Reference in a new issue