- Do not expose list_length. This prevents the library to be used in
games/freetennis, which links sdl_image library that exposes the same symbol.
This commit is contained in:
parent
7d2b5e3b02
commit
5530c271c6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=252475
2 changed files with 13 additions and 2 deletions
|
@ -8,7 +8,7 @@
|
|||
|
||||
PORTNAME= images
|
||||
PORTVERSION= 3.0.2
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
PORTEPOCH= 2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/cristal/caml-light/bazar-ocaml/ \
|
||||
|
@ -46,7 +46,7 @@ OPTIONS= PNG "Enable PNG support" on \
|
|||
.include <bsd.port.options.mk>
|
||||
|
||||
.if !defined(WITHOUT_PNG)
|
||||
LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
|
||||
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
|
||||
CONFIGURE_ARGS+= --with-png
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-png
|
||||
|
|
11
graphics/ocaml-images/files/patch-src_gifwrite.c
Normal file
11
graphics/ocaml-images/files/patch-src_gifwrite.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./src/gifwrite.c.orig 2010-04-09 03:01:01.000000000 -0700
|
||||
+++ ./src/gifwrite.c 2010-04-09 03:01:08.000000000 -0700
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
#include <gif_lib.h>
|
||||
|
||||
-int list_length( value list )
|
||||
+static int list_length( value list )
|
||||
{
|
||||
CAMLparam1(list);
|
||||
CAMLlocal1(l);
|
Loading…
Reference in a new issue