Update to 3.36.3

This is the last version not depending on tracker3, tracker3 will follow
after the quarterly is branched
This commit is contained in:
Baptiste Daroussin 2020-09-29 15:39:34 +00:00
parent 801e0a391c
commit 555ea1f164
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=550523
5 changed files with 11 additions and 90 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nautilus
PORTVERSION= 3.28.1
PORTREVISION= 5
PORTVERSION= 3.36.3
CATEGORIES= x11-fm gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
@ -16,13 +15,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgnome-autoar-0.so:archivers/gnome-autoar \
libgexiv2.so:graphics/gexiv2 \
libtracker-sparql-2.0.so:sysutils/tracker
libtracker-sparql-2.0.so:sysutils/tracker \
libtotem.so:multimedia/totem
PORTSCOUT= limitw:1,even
USES= compiler:c11 desktop-file-utils gettext gnome \
localbase meson pkgconfig python:3.4+,build tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gnomedesktop3
USE_GSTREAMER1= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
USE_XORG= x11

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1525501674
SHA256 (gnome/nautilus-3.28.1.tar.xz) = 9ce878fc9d9f950475c504066ce5f8e98a8cfbf15051724469e865ea85bab0a5
SIZE (gnome/nautilus-3.28.1.tar.xz) = 3262520
TIMESTAMP = 1601393155
SHA256 (gnome/nautilus-3.36.3.tar.xz) = b6cafc7ab1e70a64383de391b6097fcccbf36b208f8502d8c46423224fd30ef8
SIZE (gnome/nautilus-3.36.3.tar.xz) = 3201908

View file

@ -1,28 +0,0 @@
From git master. Fixes the same 512x512 icon being installed as all sizes.
--- data/meson.build.orig 2018-06-24 22:58:44 UTC
+++ data/meson.build
@@ -8,17 +8,15 @@
# https://gitlab.gnome.org/GNOME/nautilus/merge_requests/144
##########
foreach icon_size: ['16x16', '22x22', '24x24', '32x32', '48x48', '512x512']
- configure_file(
- command: [
- 'cp', '@INPUT@', '@OUTPUT@'
- ],
- input: files(
- join_paths('icons', 'hicolor', icon_size, 'apps', 'org.gnome.Nautilus.png')
- ),
- install_dir: join_paths(datadir, 'icons', 'hicolor', icon_size, 'apps'),
- output: '@0@.png'.format(application_id)
+ icondir = join_paths('icons', 'hicolor', icon_size, 'apps')
+
+ install_data(
+ join_paths(icondir, 'org.gnome.Nautilus.png'),
+ install_dir: join_paths(datadir, icondir),
+ rename: '@0@.png'.format(application_id)
)
endforeach
+
configure_file(
command: [

View file

@ -1,50 +0,0 @@
diff --git a/src/meson.build b/src/meson.build
index 0979128c8ed4ab828f6d546ab86c301ab0c3f98c..c6fbd8808c3ecc0a30af14d621e24f921be2eb55 100644
--- src/meson.build
+++ src/meson.build
@@ -1,3 +1,13 @@
+resources = gnome.compile_resources(
+ 'nautilus-resources',
+ join_paths(
+ 'resources', 'nautilus.gresource.xml'
+ ),
+ source_dir: 'resources',
+ c_name: 'nautilus',
+ extra_args: '--manual-register'
+)
+
libnautilus_sources = [
gnome.mkenums(
'nautilus-enum-types',
@@ -10,15 +20,8 @@ libnautilus_sources = [
'nautilus-search-provider.h'
]
),
- gnome.compile_resources(
- 'nautilus-resources',
- join_paths(
- 'resources', 'nautilus.gresource.xml'
- ),
- source_dir: 'resources',
- c_name: 'nautilus',
- extra_args: '--manual-register'
- ),
+ # The header is only used by the main executable, no need to add it here.
+ resources[0],
gnome.gdbus_codegen(
'nautilus-freedesktop-generated',
join_paths(
@@ -294,7 +297,12 @@ libnautilus_dep = declare_dependency(
nautilus_include_dirs,
libnautilus_include_dirs
],
- dependencies: nautilus_deps
+ dependencies: nautilus_deps,
+ # nautilus-main.c, which is part of the main Nautilus executable, uses
+ # the header, generated by glib-compile-resources. Passing it on from here
+ # will ensure that an internal compile-time dependency is placed on this file,
+ # thus avoiding failures that are difficult to reproduce.
+ sources: resources[1]
)
nautilus = executable(

View file

@ -19,6 +19,7 @@ lib/libnautilus-extension.so.1
lib/libnautilus-extension.so.1.5.0
lib/nautilus/extensions-3.0/libnautilus-image-properties.so
lib/nautilus/extensions-3.0/libnautilus-sendto.so
lib/nautilus/extensions-3.0/libtotem-properties-page.so
libdata/pkgconfig/libnautilus-extension.pc
share/applications/nautilus-autorun-software.desktop
share/applications/org.gnome.Nautilus.desktop
@ -26,12 +27,7 @@ share/dbus-1/services/org.freedesktop.FileManager1.service
share/dbus-1/services/org.gnome.Nautilus.service
share/gir-1.0/Nautilus-3.0.gir
share/gnome-shell/search-providers/org.gnome.Nautilus.search-provider.ini
share/icons/hicolor/16x16/apps/org.gnome.Nautilus.png
share/icons/hicolor/22x22/apps/org.gnome.Nautilus.png
share/icons/hicolor/24x24/apps/org.gnome.Nautilus.png
share/icons/hicolor/32x32/apps/org.gnome.Nautilus.png
share/icons/hicolor/48x48/apps/org.gnome.Nautilus.png
share/icons/hicolor/512x512/apps/org.gnome.Nautilus.png
share/icons/hicolor/scalable/apps/org.gnome.Nautilus.svg
share/icons/hicolor/symbolic/apps/org.gnome.Nautilus-symbolic.svg
share/locale/af/LC_MESSAGES/nautilus.mo
share/locale/am/LC_MESSAGES/nautilus.mo
@ -50,6 +46,7 @@ share/locale/br/LC_MESSAGES/nautilus.mo
share/locale/bs/LC_MESSAGES/nautilus.mo
share/locale/ca/LC_MESSAGES/nautilus.mo
share/locale/ca@valencia/LC_MESSAGES/nautilus.mo
share/locale/ckb/LC_MESSAGES/nautilus.mo
share/locale/crh/LC_MESSAGES/nautilus.mo
share/locale/cs/LC_MESSAGES/nautilus.mo
share/locale/cy/LC_MESSAGES/nautilus.mo
@ -100,6 +97,7 @@ share/locale/lv/LC_MESSAGES/nautilus.mo
share/locale/mai/LC_MESSAGES/nautilus.mo
share/locale/mg/LC_MESSAGES/nautilus.mo
share/locale/mi/LC_MESSAGES/nautilus.mo
share/locale/mjw/LC_MESSAGES/nautilus.mo
share/locale/mk/LC_MESSAGES/nautilus.mo
share/locale/ml/LC_MESSAGES/nautilus.mo
share/locale/mn/LC_MESSAGES/nautilus.mo