Try a little harder to sanitize the builds: now ensure it builds not only in

parallel mode (-jX), but with disabled make jobs as well.  While here, evict
the trailing spaces at EOL in port description, and reindent it a bit.

Reported by:	bdrewery
This commit is contained in:
Alexey Dokuchaev 2013-08-30 15:15:51 +00:00
parent b728cc2245
commit 55b08b05b3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=325705
2 changed files with 24 additions and 15 deletions

View file

@ -1,16 +1,15 @@
--- nawk/Makefile.mk.orig 2005-02-09 23:58:39.000000000 +0800
+++ nawk/Makefile.mk 2013-07-26 18:01:39.000000000 +0800
@@ -12,14 +12,14 @@
@@ -12,23 +12,22 @@
$(LD) $(LDFLAGS) awk.g.2001.o $(OBJ) version_su3.o $(LUXRE) -lm $(LCOMMON) $(LWCHAR) $(LIBS) -o awk_su3
awk.g.c: awk.g.y
- $(YACC) -d awk.g.y
- mv -f y.tab.c awk.g.c
+ $(YACC) -d awk.g.y && mv -f y.tab.c awk.g.c
+
+y.tab.h: awk.g.y | awk.g.c
(echo '1i'; echo '#include <inttypes.h>'; echo '.'; echo 'w';) | \
ed -s y.tab.h
+y.tab.h: awk.g.y | awk.g.c
awk.g.2001.c: awk.g.2001.y awk.g.c
- $(YACC) awk.g.2001.y
@ -19,3 +18,13 @@
awk.g.2001.y: awk.g.y
sed -f rerule.sed <awk.g.y >awk.g.2001.y
maketab: maketab.o
$(HOSTCC) maketab.o -o maketab
- ./maketab > proctab.c
proctab.c: maketab
+ ./maketab > proctab.c
awk.g.o: awk.g.c
$(CC) $(CFLAGSS) $(CPPFLAGS) $(XO5FL) $(LARGEF) $(IWCHAR) $(ICOMMON) $(IUXRE) -c awk.g.c

View file

@ -1,17 +1,17 @@
The Heirloom Toolchest is a collection of standard Unix utilities.
Highlights are:
* Derived from original Unix material released as open source by Caldera.
* Derived from original Unix material released as open source by Caldera
* Up to four versions of each utility corresponding to SVID3/SVR4,
SVID4/SVR4.2MP, POSIX.2/SUSV2, and 4BSD (SVR4 /usr/ucb).
* Support for lines of arbitrary length and in many cases binary input data.
* Support for multibyte character sets, especially UTF-8.
SVID4/SVR4.2MP, POSIX.2/SUSV2, and 4BSD (SVR4 /usr/ucb)
* Support for lines of arbitrary length and in many cases binary input data
* Support for multibyte character sets, especially UTF-8
* More than 100 individual utilities including bc, cpio, diff, ed, file,
find, grep, man, nawk, oawk, pax, ps, sed, sort, spell, and tar.
find, grep, man, nawk, oawk, pax, ps, sed, sort, spell, and tar
* The cpio utility can read and write zip files, GNU tar files, and
the cpio formats of Cray UNICOS, SGI IRIX (-K), SCO UnixWare (-c)
and Tru64 UNIX (-e). It is also available with the pax interface.
* Extensive documentation including a manual page for any utility.
* Runs on Linux, Solaris, Open UNIX, and FreeBSD.
and Tru64 UNIX (-e). It is also available with the pax interface
* Extensive documentation including a manual page for any utility
* Runs on Linux, Solaris, Open UNIX, and FreeBSD
WWW: http://heirloom.sourceforge.net/