Unbreak by making fetchable again, using GH.
jmg@ has agreed to maintain this port for now as he uses it. He's willing to give maintainership to anyone else who actively uses it. Reported by: jmg
This commit is contained in:
parent
8d6db0f0fd
commit
55d1f50e35
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=549631
5 changed files with 33 additions and 17 deletions
|
@ -1,23 +1,23 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libpru
|
||||
PORTVERSION= 0.4
|
||||
DISTVERSION= 0.4
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://bitbucket.org/rpaulo/libpru/get/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= jmg@FreeBSD.org
|
||||
# The maintainer says, if you're actively using this you are free to
|
||||
# take this port.
|
||||
COMMENT= Library to interface with PRUs
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= rpaulo
|
||||
GH_TAGNAME= v0.4
|
||||
|
||||
IGNORE_DragonFly= only supported on FreeBSD
|
||||
USES= cmake compiler
|
||||
|
||||
EXPIRATION_DATE= 2020-09-30
|
||||
DEPRECATED= Unfetchable
|
||||
|
||||
WRKSRC= ${WRKDIR}/rpaulo-libpru-5a74157b82b8
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (libpru-0.4.tar.gz) = 6911732617b59d09b272216eb8ae4a496892783f2d05638f5538f5a0fcca198c
|
||||
SIZE (libpru-0.4.tar.gz) = 8287
|
||||
TIMESTAMP = 1600804285
|
||||
SHA256 (rpaulo-libpru-0.4-v0.4_GH0.tar.gz) = 2b011c9f54902012ac4f8e01deae529080838cdb705195e9829a5dd5b00f51c3
|
||||
SIZE (rpaulo-libpru-0.4-v0.4_GH0.tar.gz) = 8208
|
||||
|
|
11
devel/libpru/files/patch-ti-pru.c
Normal file
11
devel/libpru/files/patch-ti-pru.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ti-pru.c.orig 2015-08-19 15:27:54.000000000 -0700
|
||||
+++ ti-pru.c 2020-09-22 12:58:50.636444000 -0700
|
||||
@@ -502,7 +502,7 @@
|
||||
case TI_OP_MVI:
|
||||
ti_reg_str(op3, c_op3, sizeof(c_op3));
|
||||
ti_reg_str(op2, c_op2, sizeof(c_op2));
|
||||
- memmove(c_op2 + 1, c_op2, sizeof(c_op2));
|
||||
+ memmove(c_op2 + 1, c_op2, sizeof(c_op2)-1);
|
||||
c_op2[0] = '*';
|
||||
break;
|
||||
case TI_OP_JMP:
|
|
@ -1,21 +1,24 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pructl
|
||||
PORTVERSION= 0.2
|
||||
DISTVERSION= 0.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://bitbucket.org/rpaulo/pructl/get/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= jmg@FreeBSD.org
|
||||
# The maintainer says, if you're actively using this you are free to
|
||||
# take this port.
|
||||
COMMENT= Utilities to interface with PRUs
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= rpaulo
|
||||
GH_TAGNAME= v0.2
|
||||
|
||||
LIB_DEPENDS= libpru.so:devel/libpru
|
||||
|
||||
USES= cmake libedit
|
||||
USE_CSTD= c99
|
||||
|
||||
WRKSRC= ${WRKDIR}/rpaulo-pructl-ef9fa544e6a3
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (pructl-0.2.tar.gz) = 14642560e3a61ff5bd8fd863140cefdad4db35d5681885191a787a93e482bf3a
|
||||
SIZE (pructl-0.2.tar.gz) = 5160
|
||||
TIMESTAMP = 1600805117
|
||||
SHA256 (rpaulo-pructl-0.2-v0.2_GH0.tar.gz) = 544bdf6fe5c23f311a4a7969fd1a67c8dab860a73beebb972d501d393c400712
|
||||
SIZE (rpaulo-pructl-0.2-v0.2_GH0.tar.gz) = 5395
|
||||
|
|
Loading…
Reference in a new issue