- Update to 0.5.12

- Convert to new option framework
- Pass maintainership to submitter

PR:		ports/176598
Submitted by:	Kai Wang <kaiwang27@gmail.com>
This commit is contained in:
Max Brazhnikov 2013-03-19 14:01:20 +00:00
parent 50eede6bee
commit 56022db615
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=314647
8 changed files with 128 additions and 150 deletions

View file

@ -1,47 +1,70 @@
# New ports collection makefile for: qterm
# Date created: 10 Mar 2001
# Whom: Shen Chuan-Hsing
#
# Created by: Shen Chuan-Hsing
# $FreeBSD$
#
PORTNAME= qterm
PORTVERSION= 0.4.1
PORTREVISION= 8
PORTVERSION= 0.5.12
CATEGORIES= chinese
MASTER_SITES= SF/qterm/qterm/${PORTVERSION}
MASTER_SITES= SF/qterm/qterm/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= QTerm is a BBS client for BSD/Linux
MAINTAINER= kaiwang27@gmail.com
COMMENT= BBS client for BSD/Linux
DEPRECATED= Depends on QT3; unmaintained
EXPIRATION_DATE= 2013-07-01
USE_XORG= x11 ice xext xt xaw xpm xi xproto xextproto
USE_BZIP2= yes
USE_PERL5_BUILD=yes
USE_QT_VER= 3
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mt --prefix=${PREFIX}
LDFLAGS+= -L${LOCALBASE}/lib
USE_CMAKE= yes
USE_PERL5_BUILD= yes
USE_QT4= codecs-cn_run codecs-tw_run gui help-tools_build \
linguist_build moc_build network qt3support_build \
qmake_build rcc_build uic_build xml
USE_XORG= x11 ice
MAKE_JOBS_SAFE= yes
INSTALLS_ICONS= yes
.if !defined(WITHOUT_PYTHON)
USE_PYTHON= 2.5+
CONFIGURE_ARGS+= --with-pythondir=${LOCALBASE}
OPTIONS_DEFINE= DBUS OPENSSL PHONON QTSCRIPT KDE
OPTIONS_DEFAULT= DBUS OPENSSL PHONON QTSCRIPT
PHONON_DESC= Multimedia support via Phonon
QTSCRIPT_DESC= Scripting support via QtScript Bindings
KDE_DESC= Password management via KWallet
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CMAKE_ARGS+= -DQTERM_ENABLE_SSH:BOOL=TRUE
.else
CMAKE_ARGS+= -DQTERM_ENABLE_SSH:BOOL=FALSE
.endif
pre-everything::
.if !defined(WITHOUT_PYTHON)
@${ECHO_MSG} "Define WITHOUT_PYTHON to disable Python scripts support."
.if ${PORT_OPTIONS:MDBUS}
USE_QT4+= dbus
CMAKE_ARGS+= -DQTERM_ENABLE_DBUS:BOOL=TRUE
.else
CMAKE_ARGS+= -DQTERM_ENABLE_DBUS:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MPHONON}
USE_QT4+= phonon
CMAKE_ARGS+= -DQTERM_ENABLE_PHONON:BOOL=TRUE
.else
CMAKE_ARGS+= -DQTERM_ENABLE_PHONON:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MQTSCRIPT}
USE_QT4+= script
RUN_DEPENDS+= ${QT_PLUGINDIR}/script/libqtscript_core.so:${PORTSDIR}/devel/qtscriptgenerator
CMAKE_ARGS+= -DQTERM_ENABLE_SCRIPT:BOOL=TRUE
.else
CMAKE_ARGS+= -DQTERM_ENABLE_SCRIPT:BOOL=FALSE
.endif
.if ${PORT_OPTIONS:MKDE}
USE_KDE4= kdelibs automoc4
.endif
post-patch:
@${REINPLACE_CMD} -e 's,-lssl,-lssl -lcrypto,' \
${WRKSRC}/configure
post-install:
@${CHMOD} +w ${DATADIR}/qterm.cfg
@${CHMOD} +w ${DATADIR}/address.cfg
@${CAT} ${PKGMESSAGE}
.if !${PORT_OPTIONS:MKDE}
${REINPLACE_CMD} -e "/^find_package(KDE4)/d" ${WRKSRC}/CMakeLists.txt
.endif
${REINPLACE_CMD} -e "/^set(QT_MIN_VERSION/d" ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (qterm-0.4.1.tar.bz2) = 60c19303bc2eba11273607ae8711f0eecbd0d94b7dd2773cde128338aa5149a1
SIZE (qterm-0.4.1.tar.bz2) = 744822
SHA256 (qterm-0.5.12.tar.bz2) = bd31051a6c117b05fef3ea163480143837c57632a84eab43e8e142860bcab22a
SIZE (qterm-0.5.12.tar.bz2) = 749254

View file

@ -1,18 +0,0 @@
--- qterm/main.cpp.orig Mon Jul 10 15:36:13 2006
+++ qterm/main.cpp Thu Jul 27 17:55:53 2006
@@ -16,6 +16,15 @@
#ifdef HAVE_PYTHON
#include <Python.h>
#endif
+
+#undef isalnum
+#undef isalpha
+#undef islower
+#undef isspace
+#undef isupper
+#undef tolower
+#undef toupper
+
#include <qpixmap.h>
#include <qstringlist.h>
#include <qapplication.h>

View file

@ -1,17 +0,0 @@
--- qterm/qtermwindow.h.orig Mon Jul 10 15:36:12 2006
+++ qterm/qtermwindow.h Thu Jul 27 17:39:46 2006
@@ -10,6 +10,14 @@
#include <Python.h>
#endif
+#undef isalnum
+#undef isalpha
+#undef islower
+#undef isspace
+#undef isupper
+#undef tolower
+#undef toupper
+
#include <qmainwindow.h>
#include <qcursor.h>

View file

@ -0,0 +1,10 @@
--- ./src/CMakeLists.txt.orig 2011-03-05 19:10:11.000000000 +0000
+++ ./src/CMakeLists.txt 2013-03-17 00:48:41.239852359 +0000
@@ -14,6 +14,7 @@
if(UNIX)
find_package(X11)
set(optionalLibs ${optionalLibs} ${X11_X11_LIB})
+ include_directories(${X11_INCLUDE_DIR})
endif(UNIX)

View file

@ -1,12 +1,14 @@
QTerm is a BBS client for X Window System. The goal is
to make a client similar to Fterm and CTerm in MS Windows.
QTerm is a BBS client for X Window System.
Features:
1.mouse support
2.copy and paste
3.article download
4.address book
5.anti-idle
6.converting between GB and BIG5
* support mouse in Firebird BBS
* copy and paste
* article download
* address book
* proxy support
* anti-ilde
* auto-reply
* display and input cross language GB and BIG5
* QtScript support
WWW: http://qterm.sourceforge.net/wiki/

View file

@ -1,13 +0,0 @@
*************************************************************************
To display IP location when using QTerm
you must get file "QQWry.dat" and put it into your ~/.qterm directory
*************************************************************************
*************************************************************************
Unfortunately there is an anonying bug in the release of QTerm 0.4.0. If
your language setting is NOT English, you might experience some hang up
when connecting to a site.
A simple workaround is to use the English interface. This bug will be fixed
in the next minor release.
*************************************************************************

View file

@ -1,64 +1,55 @@
bin/qterm
share/applications/qterm.desktop
share/icons/qterm.png
%%DATADIR%%/address.cfg
%%DATADIR%%/credits
%%DATADIR%%/cursor/end.xpm
%%DATADIR%%/cursor/enter.xpm
%%DATADIR%%/cursor/exit.xpm
%%DATADIR%%/cursor/hand.xpm
%%DATADIR%%/cursor/home.xpm
%%DATADIR%%/cursor/next.xpm
%%DATADIR%%/cursor/pagedown.xpm
%%DATADIR%%/cursor/pageup.xpm
%%DATADIR%%/cursor/prev.xpm
%%DATADIR%%/pic/addr.png
%%DATADIR%%/pic/anti-idle.png
%%DATADIR%%/pic/article.png
%%DATADIR%%/pic/auto-reply.png
%%DATADIR%%/pic/color-copy.png
%%DATADIR%%/pic/color.png
%%DATADIR%%/pic/connect.png
%%DATADIR%%/pic/copy.png
%%DATADIR%%/pic/disconnect.png
%%DATADIR%%/pic/fonts.png
%%DATADIR%%/pic/keys.png
%%DATADIR%%/pic/message.png
%%DATADIR%%/pic/messagebox_critical.png
%%DATADIR%%/pic/messagebox_info.png
%%DATADIR%%/pic/messagebox_warning.png
%%DATADIR%%/pic/mouse.png
%%DATADIR%%/pic/paste.png
%%DATADIR%%/pic/popwidget.png
%%DATADIR%%/pic/pref.png
%%DATADIR%%/pic/qterm_32x32.png
%%DATADIR%%/pic/qterm_48x48.png
%%DATADIR%%/pic/qterm_tray.png
%%DATADIR%%/pic/quick.png
%%DATADIR%%/pic/reconnect.png
%%DATADIR%%/pic/rect.png
%%DATADIR%%/pic/refresh.png
%%DATADIR%%/pic/shadow.png
%%DATADIR%%/pic/sound.png
%%DATADIR%%/pic/tabpad.png
%%DATADIR%%/po/qterm_chs.qm
%%DATADIR%%/po/qterm_cht.qm
%%DATADIR%%/qterm.cfg
%%DATADIR%%/schema/Linux.schema
%%DATADIR%%/schema/Softness.schema
%%DATADIR%%/schema/VIM.schema
%%DATADIR%%/schema/XTerm.schema
%%DATADIR%%/schema/default.schema
%%DATADIR%%/script/continuous.py
%%DATADIR%%/script/download.py
%%DATADIR%%/script/sendmsg.py
%%DATADIR%%/script/system.py
%%DATADIR%%/script/tools.py
@dirrm %%DATADIR%%/script
@dirrm %%DATADIR%%/schema
@dirrm %%DATADIR%%/po
@dirrm %%DATADIR%%/pic
@dirrm %%DATADIR%%/cursor
@dirrm %%DATADIR%%
share/icons/hicolor/128x128/apps/qterm.png
share/icons/hicolor/16x16/apps/qterm.png
share/icons/hicolor/22x22/apps/qterm.png
share/icons/hicolor/32x32/apps/qterm.png
share/icons/hicolor/48x48/apps/qterm.png
share/icons/hicolor/64x64/apps/qterm.png
share/qterm/address.xml
share/qterm/credits
share/qterm/doc/qterm.qhc
share/qterm/keyboard_profiles/default.keytab
share/qterm/keyboard_profiles/linux.keytab
share/qterm/keyboard_profiles/solaris.keytab
share/qterm/keyboard_profiles/vt420pc.keytab
share/qterm/po/qterm_chs.qm
share/qterm/po/qterm_cht.qm
share/qterm/qterm.cfg
share/qterm/scheme/Linux.scheme
share/qterm/scheme/Softness.scheme
share/qterm/scheme/VIM.scheme
share/qterm/scheme/XTerm.scheme
share/qterm/scheme/default.scheme
share/qterm/scripts/article.js
share/qterm/scripts/console.js
share/qterm/scripts/google.js
share/qterm/scripts/highlight.js
share/qterm/scripts/ptt.js
share/qterm/scripts/senddelay.js
share/qterm/scripts/smth.js
share/qterm/scripts/ui/senddelay.ui
share/qterm/scripts/utils.js
share/qterm/scripts/websnap.js
@dirrm share/qterm/scripts/ui
@dirrm share/qterm/scripts
@dirrm share/qterm/scheme
@dirrm share/qterm/po
@dirrm share/qterm/keyboard_profiles
@dirrm share/qterm/doc
@dirrm share/qterm
@dirrmtry share/icons/hicolor/64x64/apps
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor/22x22/apps
@dirrmtry share/icons/hicolor/22x22
@dirrmtry share/icons/hicolor/16x16/apps
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor/128x128/apps
@dirrmtry share/icons/hicolor/128x128
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/applications