audio/deadbeef: link using ffmpeg0

- Link using ffmpeg0

Approved by:	portmgr (bapt, implicit)
This commit is contained in:
William Grzybowski 2013-10-08 23:01:38 +00:00
parent b2c1d1aabc
commit 56146681cc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=329848
3 changed files with 58 additions and 4 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= deadbeef
PORTVERSION= 0.5.5
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}
@ -166,9 +166,10 @@ PLIST_SUB+= OGG="@comment "
.if ${PORT_OPTIONS:MFFMPEG}
PLIST_SUB+= FFMPEG=""
LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg \
avformat:${PORTSDIR}/multimedia/ffmpeg \
avutil:${PORTSDIR}/multimedia/ffmpeg
LIB_DEPENDS+= libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0 \
libavformat0.so:${PORTSDIR}/multimedia/ffmpeg0 \
libavutil0.so:${PORTSDIR}/multimedia/ffmpeg0
CONFIGURE_ARGS+= --enable-ffmpeg
.else
CONFIGURE_ARGS+= --disable-ffmpeg
PLIST_SUB+= FFMPEG="@comment "
@ -359,6 +360,11 @@ post-patch:
${WRKSRC}/plugins/supereq/Makefile.in
@${REINPLACE_CMD} -e 's,/etc/timidity++/timidity-freepats.cfg:/etc/timidity/freepats.cfg:/etc/timidity/,${LOCALBASE}/share/,' \
${WRKSRC}/plugins/wildmidi/wildmidiplug.c
@${REINPLACE_CMD} \
-e 's,libavcodec ,libavcodec0 ,g' \
-e 's,libavutil ,libavutil0 ,g' \
-e 's,libavformat ,libavformat0 ,g' \
${WRKSRC}/configure
.include <bsd.port.pre.mk>

View file

@ -0,0 +1,16 @@
--- plugins/ffmpeg/Makefile.in.orig 2013-10-08 19:57:17.298159051 -0300
+++ plugins/ffmpeg/Makefile.in 2013-10-08 19:57:32.774264065 -0300
@@ -108,11 +108,11 @@
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
am__mv = mv -f
-COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+COMPILE = $(CC) $(DEFS) $(AM_CFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) \
- $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
+ $(AM_CFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(CFLAGS)
AM_V_CC = $(am__v_CC_@AM_V@)
am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)

View file

@ -0,0 +1,32 @@
--- plugins/ffmpeg/ffmpeg.c.orig 2013-10-08 19:54:33.943158658 -0300
+++ plugins/ffmpeg/ffmpeg.c 2013-10-08 19:54:44.352159132 -0300
@@ -25,20 +25,11 @@
#include "../../deadbeef.h"
-#if !FFMPEG_OLD
-
#include <libavformat/avformat.h>
#include <libavcodec/avcodec.h>
#include <libavutil/avutil.h>
#include <libavutil/avstring.h>
-#else
-
-#include <ffmpeg/avformat.h>
-#include <ffmpeg/avcodec.h>
-#include <ffmpeg/avutil.h>
-#include <ffmpeg/avstring.h>
-
#define AVERROR_EOF AVERROR(EPIPE)
#if LIBAVFORMAT_VERSION_MAJOR < 53
@@ -49,8 +40,6 @@
#define AV_VERSION_INT(a, b, c) (a<<16 | b<<8 | c)
#endif
-#endif
-
//#define trace(...) { fprintf(stderr, __VA_ARGS__); }
#define trace(fmt,...)