Update Perl 5.22 to 5.22.3-RC5 and 5.24 to 2.24.1-RC5.

Sponsored by:	Absolight
This commit is contained in:
Mathieu Arnold 2017-01-03 12:05:44 +00:00
parent bd28d2765b
commit 561cf337df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=430459
5 changed files with 34 additions and 35 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= perl
DISTVERSION= ${PERL_VERSION}-RC4
DISTVERSION= ${PERL_VERSION}-RC5
PORTREVISION= 0
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN/../../src/5.0 CPAN/../by-authors/id/S/SH/SHAY

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1476431177
SHA256 (perl/perl-5.22.3-RC4.tar.xz) = cd35050f1a45c48389133285870cf310d1fe5d342c52de10fd47b296e102e4ae
SIZE (perl/perl-5.22.3-RC4.tar.xz) = 11233496
TIMESTAMP = 1483444546
SHA256 (perl/perl-5.22.3-RC5.tar.xz) = 71857d6666d24b25394a3fb129f1b32d29767a8b318492c684b6950c9f55ebdb
SIZE (perl/perl-5.22.3-RC5.tar.xz) = 11244608

View file

@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= perl
DISTVERSION= ${PERL_VERSION}-RC4
PORTREVISION= 1
DISTVERSION= ${PERL_VERSION}-RC5
PORTREVISION= 0
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN/../../src/5.0 CPAN/../by-authors/id/S/SH/SHAY
DIST_SUBDIR= perl
@ -30,7 +30,6 @@ OPTIONS_DEFAULT= PERL_64BITINT THREADS PTHREAD MULTIPLICITY DTRACE
.if !exists(/usr/sbin/dtrace)
OPTIONS_EXCLUDE+= DTRACE
.endif
OPTIONS_EXCLUDE_FreeBSD_9= DTRACE
.for a in aarch64 arm armeb armv6 mips mips64 mips64el mipsel mipsn32 powerpc \
powerpc64 sparc64
OPTIONS_EXCLUDE_${a}= DTRACE

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1476431232
SHA256 (perl/perl-5.24.1-RC4.tar.xz) = 6da6333809eb2b35b17ee3c25b7f0327da32fad7214b296b662ccd9883b8bc59
SIZE (perl/perl-5.24.1-RC4.tar.xz) = 11553836
TIMESTAMP = 1483444229
SHA256 (perl/perl-5.24.1-RC5.tar.xz) = 6e6c545801fd84208e7e8451acb5aab0dedf938a8671aeed84e0339b042b9d86
SIZE (perl/perl-5.24.1-RC5.tar.xz) = 11562092

View file

@ -1,6 +1,6 @@
--- Configure.orig 2016-07-14 15:08:07.000000000 -0400
+++ Configure 2016-11-24 08:13:04.507723000 -0500
@@ -940,6 +940,7 @@
--- Configure.orig 2016-07-14 19:08:07 UTC
+++ Configure
@@ -940,6 +940,7 @@ lddlflags=''
usedl=''
doublesize=''
dtraceobject=''
@ -8,7 +8,7 @@
ebcdic=''
fflushNULL=''
fflushall=''
@@ -8140,10 +8141,19 @@
@@ -8140,10 +8141,19 @@ while $test 1 ; do
if $test -f $dtrace
then
@ -29,7 +29,7 @@
echo " "
echo "Good: your $dtrace knows about the -h flag."
else
@@ -8157,6 +8167,17 @@
@@ -8157,6 +8167,17 @@ while $test 1 ; do
EOM
exit 1
fi
@ -47,7 +47,7 @@
break;
fi
@@ -20756,7 +20777,11 @@
@@ -20756,7 +20777,11 @@ $define)
dtraceobject=$define
;;
' '|'')
@ -60,7 +60,7 @@
$cat >try.c <<EOM
#include "perldtrace.h"
int main(void) {
@@ -20766,14 +20791,14 @@
@@ -20766,14 +20791,14 @@ int main(void) {
EOM
dtraceobject=$undef
if $cc -c -o try.o $optimize $ccflags try.c \
@ -77,7 +77,7 @@
esac
: Determine if this is an EBCDIC system
@@ -24722,6 +24747,7 @@
@@ -24722,6 +24747,7 @@ drand01='$drand01'
drand48_r_proto='$drand48_r_proto'
dtrace='$dtrace'
dtraceobject='$dtraceobject'
@ -85,9 +85,9 @@
dynamic_ext='$dynamic_ext'
eagain='$eagain'
ebcdic='$ebcdic'
--- Makefile.SH.orig 2016-07-16 06:52:42.000000000 -0400
+++ Makefile.SH 2016-11-24 08:13:04.508901000 -0500
@@ -390,8 +390,13 @@
--- Makefile.SH.orig 2016-07-16 10:52:42 UTC
+++ Makefile.SH
@@ -390,8 +390,13 @@ VG_TEST ?= ./perl -e 1 2>/dev/null
;;
esac
@ -102,7 +102,7 @@
DTRACE_H = $dtrace_h
DTRACE_PERLLIB_O = $dtrace_perllib_o # "dtrace -G" output for perllib_objs
@@ -518,10 +523,53 @@
@@ -518,10 +523,53 @@ main_only_objs = op$(OBJ_EXT) perl$(
miniperl_objs_nodt = $(mini_only_objs) $(common_objs) miniperlmain$(OBJ_EXT)
perllib_objs_nodt = $(main_only_objs) $(common_objs)
@ -156,7 +156,7 @@
perltoc_pod_prereqs = extra.pods pod/perl5241delta.pod pod/perlapi.pod pod/perlintern.pod pod/perlmodlib.pod pod/perluniprops.pod
generated_pods = pod/perltoc.pod $(perltoc_pod_prereqs)
generated_headers = uudmap.h bitcount.h mg_data.h
@@ -860,19 +908,32 @@
@@ -860,19 +908,32 @@ mydtrace.h: $(DTRACE_H)
define)
$spitshell >>$Makefile <<'!NO!SUBS!'
$(DTRACE_MINI_O): perldtrace.d $(miniperl_objs_nodt)
@ -193,7 +193,7 @@
!NO!SUBS!
case "$useshrplib" in
true)
@@ -973,7 +1034,7 @@
@@ -973,7 +1034,7 @@ lib/buildcustomize.pl: $& $(miniperl_obj
*)
if test "X$hostperl" != X; then
$spitshell >>$Makefile <<!GROK!THIS!
@ -202,7 +202,7 @@
-@rm -f miniperl.xok
-@rm \$(MINIPERL_EXE)
\$(LNS) \$(HOST_PERL) \$(MINIPERL_EXE)
@@ -982,7 +1043,7 @@
@@ -982,7 +1043,7 @@ lib/buildcustomize.pl: \$& \$(miniperl_o
!GROK!THIS!
else
$spitshell >>$Makefile <<'!NO!SUBS!'
@ -211,7 +211,7 @@
-@rm -f miniperl.xok
$(CC) $(CLDFLAGS) -o $(MINIPERL_EXE) \
$(miniperl_objs) $(libs)
@@ -995,7 +1056,7 @@
@@ -995,7 +1056,7 @@ lib/buildcustomize.pl: $& $(miniperl_obj
$spitshell >>$Makefile <<'!NO!SUBS!'
@ -220,9 +220,9 @@
-@rm -f miniperl.xok
!NO!SUBS!
--- Porting/Glossary.orig 2016-07-14 15:06:55.000000000 -0400
+++ Porting/Glossary 2016-11-24 08:13:04.511723000 -0500
@@ -2949,6 +2949,11 @@
--- Porting/Glossary.orig 2016-07-14 19:06:55 UTC
+++ Porting/Glossary
@@ -2949,6 +2949,11 @@ dtrace (usedtrace.U):
dtraceobject (dtraceobject.U):
Whether we need to build an object file with the dtrace tool.
@ -234,9 +234,9 @@
dynamic_ext (Extensions.U):
This variable holds a list of XS extension files we want to
link dynamically into the package. It is used by Makefile.
--- ext/XS-APItest/Makefile.PL.orig 2016-07-14 15:08:07.000000000 -0400
+++ ext/XS-APItest/Makefile.PL 2016-11-24 08:13:04.512100000 -0500
@@ -58,7 +58,8 @@
--- ext/XS-APItest/Makefile.PL.orig 2016-07-14 19:08:07 UTC
+++ ext/XS-APItest/Makefile.PL
@@ -58,7 +58,8 @@ sub MY::postamble
DTRACE_D = ../../perldtrace.d
dtrace\$(OBJ_EXT): \$(DTRACE_D) core\$(OBJ_EXT)
@ -246,9 +246,9 @@
POSTAMBLE
return $post;
--- hints/freebsd.sh.orig 2016-07-14 15:07:39.000000000 -0400
+++ hints/freebsd.sh 2016-11-24 08:13:04.512583000 -0500
@@ -105,6 +105,15 @@
--- hints/freebsd.sh.orig 2016-07-14 19:07:39 UTC
+++ hints/freebsd.sh
@@ -105,6 +105,15 @@ case "$osvers" in
;;
esac