Update devel/pecl-ev to 1.0.4

PR:		216919
Submitted by:	johnpupu@gmail.com
Approved by:	mat (mentor)
Differential Revision:	https://reviews.freebsd.org/D9495
This commit is contained in:
Kirill Ponomarev 2017-02-09 18:06:14 +00:00
parent 19a4f0ddb2
commit 563515fbb5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433757
3 changed files with 4 additions and 23 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ev
PORTVERSION= 0.2.15
PORTREVISION= 3
PORTVERSION= 1.0.4
CATEGORIES= devel
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@ -16,6 +15,5 @@ LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (PECL/ev-0.2.15.tgz) = 801b2c39e081263f91d5a1d74e668e6c8ad199a34867c8e13e8fad3e83786fd5
SIZE (PECL/ev-0.2.15.tgz) = 96963
TIMESTAMP = 1486566619
SHA256 (PECL/ev-1.0.4.tgz) = 13804cb70e39a0abc014b45230a990ff046d748a9d806feca9ac511516be4f61
SIZE (PECL/ev-1.0.4.tgz) = 124735

View file

@ -1,18 +0,0 @@
--- libev/ev.c.orig 2014-12-08 18:18:51.000000000 +0100
+++ libev/ev.c 2015-03-01 22:43:14.480908000 +0100
@@ -1006,12 +1006,12 @@
}
#endif
-#if ECB_GCC_VERSION(4,5)
+#if ECB_GCC_VERSION(4,5) || defined __clang__
#define ecb_unreachable() __builtin_unreachable ()
#else
/* this seems to work fine, but gcc always emits a warning for it :/ */
- ecb_inline void ecb_unreachable (void) ecb_noreturn;
- ecb_inline void ecb_unreachable (void) { }
+ ecb_inline ecb_noreturn void ecb_unreachable (void);
+ ecb_inline ecb_noreturn void ecb_unreachable (void) { }
#endif
/* try to tell the compiler that some condition is definitely true */