- Add PROFILING_DESC (should be part of r323888)
- Unbreak the build on amd64 (and make it generally type safe) - Remove gtkmm-2.4 from LIB_DEPENDS, glademm-2.4 implies it
This commit is contained in:
parent
5d27780bc1
commit
5658568409
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323894
3 changed files with 54 additions and 3 deletions
|
@ -33,6 +33,7 @@ PORTDOCS= AUTHORS NEWS README ChangeLog
|
|||
|
||||
OPTIONS_DEFINE= GTK2 PROFILING DOCS
|
||||
OPTIONS_SUB= yes
|
||||
PROFILING_DESC= Enable profiling
|
||||
|
||||
GTK2_CONFIGURE_ON= --enable-gtk=2.4
|
||||
PROFILING_CONFIGURE_ENABLE= profiling
|
||||
|
@ -40,8 +41,7 @@ PROFILING_CONFIGURE_ENABLE= profiling
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MGTK2}
|
||||
LIB_DEPENDS+= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
|
||||
glademm-2.4:${PORTSDIR}/devel/libglademm24
|
||||
LIB_DEPENDS+= glademm-2.4:${PORTSDIR}/devel/libglademm24
|
||||
PROG_FILES+= ${WRKSRC}/src/gtk/gvba
|
||||
GTK2_DATA_FILES= ${WRKSRC}/src/gtk/vba.glade
|
||||
.endif
|
||||
|
|
42
emulators/vba/files/patch-src-System.h
Normal file
42
emulators/vba/files/patch-src-System.h
Normal file
|
@ -0,0 +1,42 @@
|
|||
--- src/System.h.orig 2004-05-13 22:02:43.000000000 +0800
|
||||
+++ src/System.h 2013-07-30 00:13:30.000000000 +0800
|
||||
@@ -20,30 +20,31 @@
|
||||
#ifndef VBA_SYSTEM_H
|
||||
#define VBA_SYSTEM_H
|
||||
|
||||
+#include <inttypes.h>
|
||||
#include "unzip.h"
|
||||
|
||||
#ifndef NULL
|
||||
#define NULL 0
|
||||
#endif
|
||||
|
||||
-typedef unsigned char u8;
|
||||
-typedef unsigned short u16;
|
||||
-typedef unsigned int u32;
|
||||
+typedef uint8_t u8;
|
||||
+typedef uint16_t u16;
|
||||
+typedef uint32_t u32;
|
||||
|
||||
#ifdef _MSC_VER
|
||||
typedef unsigned __int64 u64;
|
||||
#else
|
||||
-typedef unsigned long long u64;
|
||||
+typedef uint64_t u64;
|
||||
#endif
|
||||
|
||||
-typedef signed char s8;
|
||||
-typedef signed short s16;
|
||||
-typedef signed int s32;
|
||||
+typedef int8_t s8;
|
||||
+typedef int16_t s16;
|
||||
+typedef int32_t s32;
|
||||
|
||||
#ifdef _MSC_VER
|
||||
typedef signed __int64 s64;
|
||||
#else
|
||||
-typedef signed long long s64;
|
||||
+typedef int64_t s64;
|
||||
#endif
|
||||
|
||||
struct EmulatedSystem {
|
|
@ -1,6 +1,15 @@
|
|||
--- src/prof/gmon.h.orig 2007-10-04 01:06:18.000000000 +0200
|
||||
+++ src/prof/gmon.h 2007-10-04 01:06:48.000000000 +0200
|
||||
@@ -119,7 +119,7 @@
|
||||
@@ -29,6 +29,8 @@
|
||||
#ifndef gmon_h
|
||||
#define gmon_h
|
||||
|
||||
+#include <inttypes.h>
|
||||
+
|
||||
/* Size of the 4.4BSD gmon header */
|
||||
#define GMON_HDRSIZE_BSD44_32 (4 + 4 + 4 + 4 + 4 + (3 * 4))
|
||||
#define GMON_HDRSIZE_BSD44_64 (8 + 8 + 4 + 4 + 4 + (3 * 4))
|
||||
@@ -119,7 +121,7 @@
|
||||
|
||||
struct tostruct
|
||||
{
|
||||
|
|
Loading…
Reference in a new issue