Upgrade to 0.8.6b2.
Changelog at <http://sourceforge.net/project/shownotes.php?group_id=204161&release_id=645214>
This commit is contained in:
parent
af0745521e
commit
567185543b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=228834
4 changed files with 35 additions and 21 deletions
|
@ -6,13 +6,15 @@
|
|||
#
|
||||
|
||||
PORTNAME= libboard
|
||||
PORTVERSION= 0.8.2
|
||||
DISTVERSION= 0.8.6b-2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= thierry@FreeBSD.org
|
||||
COMMENT= A vector graphics C++ library
|
||||
|
||||
BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX}
|
||||
CONFIGURE_ENV= CXX=${CXX}
|
||||
|
@ -20,12 +22,14 @@ CONFIGURE_ENV= CXX=${CXX}
|
|||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:C/-.$//}
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} != i386
|
||||
CFLAGS+= -fPIC
|
||||
CXXFLAGS+= -fPIC
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
|
@ -42,6 +46,7 @@ post-install:
|
|||
.if !defined(NOPORTEXAMPLES)
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/
|
||||
cd ${WRKSRC}/bin/ && ${COPYTREE_BIN} . ${EXAMPLESDIR}/
|
||||
${RM} -rf ${EXAMPLESDIR}/.svn
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libboard-0.8.2.tar.gz) = 2360017013695c27759221d9537279a6
|
||||
SHA256 (libboard-0.8.2.tar.gz) = 7762775653f7ec2963b639faf9e894bb9f3b969173d2261291841015b8f1fe92
|
||||
SIZE (libboard-0.8.2.tar.gz) = 202025
|
||||
MD5 (libboard-0.8.6b-2.tar.gz) = d462ca619221090f72649f40aa4e0fa7
|
||||
SHA256 (libboard-0.8.6b-2.tar.gz) = b21cd08fe437d216e4a1eda54a9073785f60120e8aea734c1a9a97e0d32de7b5
|
||||
SIZE (libboard-0.8.6b-2.tar.gz) = 299488
|
||||
|
|
|
@ -1,15 +1,6 @@
|
|||
--- configure.orig 2007-12-17 11:15:52.000000000 +0100
|
||||
+++ configure 2008-11-19 19:05:16.000000000 +0100
|
||||
@@ -60,7 +60,7 @@
|
||||
##
|
||||
## Are we on a powerpc (Mac ?)
|
||||
##
|
||||
-if [ `arch` = "ppc" ]; then
|
||||
+if [ `uname -m` = "ppc" ]; then
|
||||
LDFLAGSLIB=-dynamiclib
|
||||
DYNLIB_EXTENSION=dynlib
|
||||
fi
|
||||
@@ -68,23 +68,23 @@
|
||||
--- configure.orig 2009-02-02 12:12:55.000000000 +0100
|
||||
+++ configure 2009-02-06 10:28:55.000000000 +0100
|
||||
@@ -109,23 +109,23 @@
|
||||
##
|
||||
## Are we on a 64 bits arch
|
||||
##
|
||||
|
@ -38,7 +29,7 @@
|
|||
+# return n == 0xFFFFFFFF;
|
||||
+#}
|
||||
+#EOF
|
||||
+#gcc -o is64 is64.c
|
||||
+#$(CXX) -o is64 is64.c
|
||||
+#if is64; then
|
||||
+#CXX64FLAGS="-fPIC"
|
||||
+#echo yes
|
||||
|
@ -48,5 +39,5 @@
|
|||
+#fi
|
||||
+#rm -f is64 is64.c
|
||||
|
||||
|
||||
cat > Makefile <<EOF
|
||||
|
||||
|
|
|
@ -1,20 +1,38 @@
|
|||
include/Board.h
|
||||
include/board/Board.h
|
||||
include/board/Color.h
|
||||
include/board/PSFonts.h
|
||||
include/board/Point.h
|
||||
include/board/Rect.h
|
||||
include/board/ShapeList.h
|
||||
include/board/Shapes.h
|
||||
include/board/Tools.h
|
||||
include/board/Transforms.h
|
||||
lib/libboard.a
|
||||
lib/libboard.so
|
||||
lib/libboard.so.0
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arithmetic
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arithmetic.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arrows
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arrows.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ellipse
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ellipse.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example3
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example3.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example4
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example4.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/koch
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/koch.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logo
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logo.cpp
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ruler
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ruler.cpp
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
|
||||
@dirrm include/board
|
||||
|
|
Loading…
Reference in a new issue