Update to 0.13.0.
This commit is contained in:
parent
fbf4c24557
commit
568f0f7d51
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=49882
10 changed files with 89 additions and 80 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME?= gdk-pixbuf
|
||||
PORTVERSION= 0.11.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.13.0
|
||||
CATEGORIES?= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= unstable/sources/gdk-pixbuf
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (gdk-pixbuf-0.11.0.tar.gz) = a4a61cadff79b27c0b1e1ab6e93baf79
|
||||
MD5 (gdk-pixbuf-0.13.0.tar.gz) = 6d0b1bcd9157daee3f954a1b8c7dfb9f
|
||||
|
|
|
@ -1,18 +1,17 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Fri Apr 27 02:41:47 2001
|
||||
+++ configure Fri May 18 16:03:47 2001
|
||||
@@ -3443,6 +3443,8 @@
|
||||
INSIDE_GNOME=yes
|
||||
BUILD_CANVAS=yes
|
||||
else
|
||||
+
|
||||
--- configure.orig Fri Oct 26 01:10:31 2001
|
||||
+++ configure Fri Oct 26 11:00:48 2001
|
||||
@@ -3435,6 +3435,7 @@
|
||||
|
||||
|
||||
|
||||
+if [ x"$BUILD_CANVAS" != x"no" ]; then
|
||||
|
||||
# Extract the first word of "gnome-config", so it can be a program name with args.
|
||||
# Extract the first word of "gnome-config", so it can be a program name with args.
|
||||
set dummy gnome-config; ac_word=$2
|
||||
@@ -3474,6 +3476,10 @@
|
||||
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
||||
@@ -3465,6 +3466,10 @@
|
||||
esac
|
||||
fi
|
||||
GNOME_CONFIG="$ac_cv_path_GNOME_CONFIG"
|
||||
|
@ -23,7 +22,7 @@ $FreeBSD$
|
|||
if test -n "$GNOME_CONFIG"; then
|
||||
echo "$ac_t""$GNOME_CONFIG" 1>&6
|
||||
else
|
||||
@@ -3591,8 +3597,8 @@
|
||||
@@ -3571,8 +3576,8 @@
|
||||
#define USE_GMODULE 1
|
||||
EOF
|
||||
|
||||
|
@ -34,7 +33,7 @@ $FreeBSD$
|
|||
|
||||
|
||||
echo "$ac_t""yes" 1>&6
|
||||
@@ -4468,7 +4474,7 @@
|
||||
@@ -4448,7 +4453,7 @@
|
||||
|
||||
|
||||
if test "x$with_html_dir" = "x" ; then
|
||||
|
|
|
@ -1,88 +1,110 @@
|
|||
--- gdk-pixbuf/Makefile.in.orig Thu Mar 1 18:19:34 2001
|
||||
+++ gdk-pixbuf/Makefile.in Wed Mar 7 18:34:01 2001
|
||||
@@ -123,4 +123,4 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- gdk-pixbuf/Makefile.in.orig Fri Oct 26 11:01:20 2001
|
||||
+++ gdk-pixbuf/Makefile.in Fri Oct 26 11:04:15 2001
|
||||
@@ -125,70 +125,70 @@
|
||||
# The PNG plugin.
|
||||
#
|
||||
libpixbufloader_png_la_SOURCES = io-png.c
|
||||
-libpixbufloader_png_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_png_la_LIBADD = $(LIBPNG)
|
||||
+libpixbufloader_png_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_png_la_LIBADD = $(LIBPNG) libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -130,4 +130,4 @@
|
||||
#
|
||||
# The JPEG loader
|
||||
#
|
||||
libpixbufloader_jpeg_la_SOURCES = io-jpeg.c
|
||||
-libpixbufloader_jpeg_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_jpeg_la_LIBADD = $(LIBJPEG)
|
||||
+libpixbufloader_jpeg_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_jpeg_la_LIBADD = $(LIBJPEG) libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -137,4 +137,4 @@
|
||||
#
|
||||
# The XPM loader
|
||||
#
|
||||
libpixbufloader_xpm_la_SOURCES = io-xpm.c
|
||||
-libpixbufloader_xpm_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_xpm_la_LIBADD =
|
||||
+libpixbufloader_xpm_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_xpm_la_LIBADD = libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -144,4 +144,4 @@
|
||||
#
|
||||
# The GIF loader
|
||||
#
|
||||
libpixbufloader_gif_la_SOURCES = io-gif.c
|
||||
-libpixbufloader_gif_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_gif_la_LIBADD =
|
||||
+libpixbufloader_gif_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_gif_la_LIBADD = libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -151,4 +151,4 @@
|
||||
#
|
||||
# The ICO loader
|
||||
#
|
||||
libpixbufloader_ico_la_SOURCES = io-ico.c
|
||||
-libpixbufloader_ico_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_ico_la_LIBADD =
|
||||
+libpixbufloader_ico_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_ico_la_LIBADD = libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -158,4 +158,4 @@
|
||||
#
|
||||
# The RAS loader
|
||||
#
|
||||
libpixbufloader_ras_la_SOURCES = io-ras.c
|
||||
-libpixbufloader_ras_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_ras_la_LIBADD =
|
||||
+libpixbufloader_ras_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_ras_la_LIBADD = libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -165,4 +165,4 @@
|
||||
#
|
||||
# The TIFF loader
|
||||
#
|
||||
libpixbufloader_tiff_la_SOURCES = io-tiff.c
|
||||
-libpixbufloader_tiff_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_tiff_la_LIBADD = $(LIBTIFF)
|
||||
+libpixbufloader_tiff_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_tiff_la_LIBADD = $(LIBTIFF) libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -172,4 +172,4 @@
|
||||
#
|
||||
# The PNM loader
|
||||
#
|
||||
libpixbufloader_pnm_la_SOURCES = io-pnm.c
|
||||
-libpixbufloader_pnm_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_pnm_la_LIBADD =
|
||||
+libpixbufloader_pnm_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_pnm_la_LIBADD = libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -179,4 +179,4 @@
|
||||
#
|
||||
# The BMP loader
|
||||
#
|
||||
libpixbufloader_bmp_la_SOURCES = io-bmp.c
|
||||
-libpixbufloader_bmp_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
-libpixbufloader_bmp_la_LIBADD =
|
||||
+libpixbufloader_bmp_la_LDFLAGS = -avoid-version -module
|
||||
+libpixbufloader_bmp_la_LIBADD = libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
@@ -186,3 +186,3 @@
|
||||
#
|
||||
# The XBM loader
|
||||
#
|
||||
libpixbufloader_xbm_la_SOURCES = io-xbm.c
|
||||
-libpixbufloader_xbm_la_LDFLAGS = -version-info 1:0:0 -module
|
||||
+libpixbufloader_xbm_la_LDFLAGS = -avoid-version -module
|
||||
libpixbufloader_xbm_la_LIBADD =
|
||||
@@ -227,6 +227,6 @@
|
||||
LDADDS = libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
-@INSIDE_GNOME_LIBS_TRUE@test_gdk_pixbuf_LDADD = $(LDADDS) -lgmodule
|
||||
-@INSIDE_GNOME_LIBS_FALSE@test_gdk_pixbuf_LDADD = $(LDADDS) $(GNOME_LIBS) -lgmodule
|
||||
-@INSIDE_GNOME_LIBS_TRUE@testpixbuf_LDADD = $(LDADDS) -lgmodule
|
||||
-@INSIDE_GNOME_LIBS_FALSE@testpixbuf_LDADD = $(LDADDS) $(GNOME_LIBS) -lgmodule
|
||||
+@INSIDE_GNOME_LIBS_TRUE@test_gdk_pixbuf_LDADD = $(LDADDS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
+@INSIDE_GNOME_LIBS_FALSE@test_gdk_pixbuf_LDADD = $(LDADDS) $(GNOME_LIBS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
+@INSIDE_GNOME_LIBS_TRUE@testpixbuf_LDADD = $(LDADDS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
+@INSIDE_GNOME_LIBS_FALSE@testpixbuf_LDADD = $(LDADDS) $(GNOME_LIBS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
@INSIDE_GNOME_LIBS_TRUE@testpixbuf_drawable_LDADD = $(LDADDS)
|
||||
@@ -235,4 +235,4 @@
|
||||
@INSIDE_GNOME_LIBS_FALSE@testpixbuf_scale_LDADD = $(LDADDS) $(GNOME_LIBS)
|
||||
-@INSIDE_GNOME_LIBS_TRUE@testanimation_LDADD = $(LDADDS) -lgmodule
|
||||
-@INSIDE_GNOME_LIBS_FALSE@testanimation_LDADD = $(LDADDS) $(GNOME_LIBS) -lgmodule
|
||||
+@INSIDE_GNOME_LIBS_TRUE@testanimation_LDADD = $(LDADDS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
+@INSIDE_GNOME_LIBS_FALSE@testanimation_LDADD = $(LDADDS) $(GNOME_LIBS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
|
||||
@HAVE_PNG_TRUE@PNG_LIB = libpixbufloader-png.la
|
||||
@@ -230,11 +230,11 @@
|
||||
|
||||
LDADDS = libgdk_pixbuf.la $(GLIB_LIBS) $(GTK_LIBS) $(STATIC_LIB_DEPS)
|
||||
|
||||
-test_gdk_pixbuf_LDADD = $(LDADDS) $(GNOME_LIBS) -lgmodule
|
||||
-testpixbuf_LDADD = $(LDADDS) $(GNOME_LIBS) -lgmodule
|
||||
+test_gdk_pixbuf_LDADD = $(LDADDS) $(GNOME_LIBS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
+testpixbuf_LDADD = $(LDADDS) $(GNOME_LIBS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
testpixbuf_drawable_LDADD = $(LDADDS) $(GNOME_LIBS)
|
||||
testpixbuf_scale_LDADD = $(LDADDS) $(GNOME_LIBS)
|
||||
-testanimation_LDADD = $(LDADDS) $(GNOME_LIBS) -lgmodule
|
||||
+testanimation_LDADD = $(LDADDS) $(GNOME_LIBS) `$(GLIB_CONFIG) --libs gmodule`
|
||||
|
||||
GDK_PIXBUF_LIBS = $(GLIB_LIBS) $(GTK_LIBS)
|
||||
|
||||
|
|
|
@ -1,9 +1,12 @@
|
|||
--- gdk-pixbuf-config.in.orig Mon Apr 10 20:56:56 2000
|
||||
+++ gdk-pixbuf-config.in Thu Apr 13 11:40:34 2000
|
||||
@@ -42,11 +42,11 @@
|
||||
if test @includedir@ != /usr/include ; then
|
||||
includes=-I@includedir@
|
||||
fi
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- gdk-pixbuf-config.in.orig Tue Oct 23 20:44:44 2001
|
||||
+++ gdk-pixbuf-config.in Fri Oct 26 11:06:32 2001
|
||||
@@ -40,11 +40,11 @@
|
||||
;;
|
||||
--cflags)
|
||||
includes=-I@includedir@/gdk-pixbuf-1.0
|
||||
- echo $includes `gtk-config --cflags`
|
||||
+ echo $includes `@GTK_CONFIG@ --cflags`
|
||||
;;
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
bin/gdk-pixbuf-config
|
||||
etc/gdk_pixbufConf.sh
|
||||
etc/gdk_pixbuf_xlibConf.sh
|
||||
include/gdk-pixbuf/gdk-pixbuf-features.h
|
||||
include/gdk-pixbuf/gdk-pixbuf-loader.h
|
||||
include/gdk-pixbuf/gdk-pixbuf-xlib.h
|
||||
include/gdk-pixbuf/gdk-pixbuf-xlibrgb.h
|
||||
include/gdk-pixbuf/gdk-pixbuf.h
|
||||
include/gdk-pixbuf-1.0/gdk-pixbuf/gdk-pixbuf-features.h
|
||||
include/gdk-pixbuf-1.0/gdk-pixbuf/gdk-pixbuf-loader.h
|
||||
include/gdk-pixbuf-1.0/gdk-pixbuf/gdk-pixbuf-xlib.h
|
||||
include/gdk-pixbuf-1.0/gdk-pixbuf/gdk-pixbuf-xlibrgb.h
|
||||
include/gdk-pixbuf-1.0/gdk-pixbuf/gdk-pixbuf.h
|
||||
lib/gdk-pixbuf/loaders/libpixbufloader-bmp.so
|
||||
lib/gdk-pixbuf/loaders/libpixbufloader-gif.so
|
||||
lib/gdk-pixbuf/loaders/libpixbufloader-ico.so
|
||||
|
@ -23,12 +23,7 @@ lib/libgdk_pixbuf_xlib.a
|
|||
lib/libgdk_pixbuf_xlib.so
|
||||
lib/libgdk_pixbuf_xlib.so.2
|
||||
share/aclocal/gdk-pixbuf.m4
|
||||
share/doc/gdk-pixbuf/a2605.html
|
||||
share/doc/gdk-pixbuf/a3640.html
|
||||
share/doc/gdk-pixbuf/a3652.html
|
||||
share/doc/gdk-pixbuf/a3694.html
|
||||
share/doc/gdk-pixbuf/a3716.html
|
||||
share/doc/gdk-pixbuf/book1.html
|
||||
share/doc/gdk-pixbuf/a3657.html
|
||||
share/doc/gdk-pixbuf/compiling.html
|
||||
share/doc/gdk-pixbuf/extra-configuration-options.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-animation.html
|
||||
|
@ -47,21 +42,12 @@ share/doc/gdk-pixbuf/gdk-pixbuf-util.html
|
|||
share/doc/gdk-pixbuf/gdkpixbufloader.html
|
||||
share/doc/gdk-pixbuf/gnomecanvaspixbuf.html
|
||||
share/doc/gdk-pixbuf/index.html
|
||||
share/doc/gdk-pixbuf/index.sgml
|
||||
share/doc/gdk-pixbuf/license.html
|
||||
share/doc/gdk-pixbuf/r15.html
|
||||
share/doc/gdk-pixbuf/r27.html
|
||||
share/doc/gdk-pixbuf/x2624.html
|
||||
share/doc/gdk-pixbuf/x2676.html
|
||||
share/doc/gdk-pixbuf/x3659.html
|
||||
share/doc/gdk-pixbuf/x3671.html
|
||||
share/doc/gdk-pixbuf/x3711.html
|
||||
share/doc/gdk-pixbuf/x3713.html
|
||||
share/doc/gdk-pixbuf/x3723.html
|
||||
share/doc/gdk-pixbuf/x3735.html
|
||||
share/doc/gdk-pixbuf/x3765.html
|
||||
share/doc/gdk-pixbuf/x3787.html
|
||||
share/doc/gdk-pixbuf/x3676.html
|
||||
share/doc/gdk-pixbuf/x3728.html
|
||||
@dirrm share/doc/gdk-pixbuf
|
||||
@dirrm lib/gdk-pixbuf/loaders
|
||||
@dirrm lib/gdk-pixbuf
|
||||
@dirrm include/gdk-pixbuf
|
||||
@dirrm include/gdk-pixbuf-1.0/gdk-pixbuf
|
||||
@dirrm include/gdk-pixbuf-1.0
|
||||
|
|
|
@ -25,8 +25,8 @@ NAME= gnomecanvaspixbuf
|
|||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/${NAME}Conf.sh ${PREFIX}/etc
|
||||
cd ${WRKSRC}/gdk-pixbuf/.libs && \
|
||||
${MKDIR} ${PREFIX}/include/gdk-pixbuf/ && \
|
||||
${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf/ && \
|
||||
${MKDIR} ${PREFIX}/include/gdk-pixbuf-1.0/gdk-pixbuf && \
|
||||
${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf-1.0/gdk-pixbuf && \
|
||||
${INSTALL_DATA} lib${NAME}.a ${PREFIX}/lib && \
|
||||
${INSTALL_PROGRAM} lib${NAME}.so.1 ${PREFIX}/lib && \
|
||||
${LN} -sf lib${NAME}.so.1 ${PREFIX}/lib/lib${NAME}.so
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
etc/gnomecanvaspixbufConf.sh
|
||||
include/gdk-pixbuf/gnome-canvas-pixbuf.h
|
||||
include/gdk-pixbuf-1.0/gdk-pixbuf/gnome-canvas-pixbuf.h
|
||||
lib/libgnomecanvaspixbuf.a
|
||||
lib/libgnomecanvaspixbuf.so
|
||||
lib/libgnomecanvaspixbuf.so.1
|
||||
|
|
|
@ -25,8 +25,8 @@ NAME= gnomecanvaspixbuf
|
|||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/${NAME}Conf.sh ${PREFIX}/etc
|
||||
cd ${WRKSRC}/gdk-pixbuf/.libs && \
|
||||
${MKDIR} ${PREFIX}/include/gdk-pixbuf/ && \
|
||||
${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf/ && \
|
||||
${MKDIR} ${PREFIX}/include/gdk-pixbuf-1.0/gdk-pixbuf && \
|
||||
${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf-1.0/gdk-pixbuf && \
|
||||
${INSTALL_DATA} lib${NAME}.a ${PREFIX}/lib && \
|
||||
${INSTALL_PROGRAM} lib${NAME}.so.1 ${PREFIX}/lib && \
|
||||
${LN} -sf lib${NAME}.so.1 ${PREFIX}/lib/lib${NAME}.so
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
etc/gnomecanvaspixbufConf.sh
|
||||
include/gdk-pixbuf/gnome-canvas-pixbuf.h
|
||||
include/gdk-pixbuf-1.0/gdk-pixbuf/gnome-canvas-pixbuf.h
|
||||
lib/libgnomecanvaspixbuf.a
|
||||
lib/libgnomecanvaspixbuf.so
|
||||
lib/libgnomecanvaspixbuf.so.1
|
||||
|
|
Loading…
Reference in a new issue