diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index 004e3b6aa86e..cff4e685aaef 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -7,7 +7,7 @@
PORTNAME= WebMagick
PORTVERSION= 2.03p3
-PORTREVISION= 47
+PORTREVISION= 48
PORTEPOCH= 1
CATEGORIES= www graphics
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}-beta/2.03pre3
diff --git a/www/WebMagick/files/patch-aa b/www/WebMagick/files/patch-aa
index f86d073ab7fd..8b369984036b 100644
--- a/www/WebMagick/files/patch-aa
+++ b/www/WebMagick/files/patch-aa
@@ -2,15 +2,15 @@ Index: webmagick.in
===================================================================
RCS file: /cvsroot/webmagick/WebMagick/webmagick.in,v
retrieving revision 1.117
-retrieving revision 1.170
-diff -u -r1.117 -r1.170
+retrieving revision 1.172
+diff -u -r1.117 -r1.172
--- webmagick.in 23 Oct 2002 16:14:47 -0000 1.117
-+++ webmagick.in 11 Dec 2011 22:46:56 -0000 1.170
++++ webmagick.in 14 Dec 2011 18:58:00 -0000 1.172
@@ -1,6 +1,6 @@
#! @PERL@
#
-# $Id: webmagick.in,v 1.117 2002/10/23 16:14:47 clindell Exp $
-+# $Id: webmagick.in,v 1.170 2011/12/11 22:46:56 ache Exp $
++# $Id: webmagick.in,v 1.172 2011/12/14 18:58:00 ache Exp $
#
# You are looking at the main PERL script for WebMagick, a package to
# intelligently create HTML and JavaScript index files and imagemaps
@@ -1147,7 +1147,7 @@ diff -u -r1.117 -r1.170
}
else
{
-@@ -2423,143 +2674,104 @@
+@@ -2423,143 +2674,105 @@
}
print( INDEX
"\n" )
if( "$opt_metacharset" ne '' );
- print( PICHTML "
$pic\n" );
-+ print( PICHTML " ${altlabel}\n" );
++ print( PICHTML " ${altfinallabel}\n" );
# Meta tags
- print( PICHTML " \n" );
@@ -1330,7 +1331,7 @@ diff -u -r1.117 -r1.170
+ if ($pic =~ /\.(jpg|jpeg?|gif|xbm|png|bmp|ico)$/i) {
+ print( PICHTML "")
+ if ($opt_pichtmllink ne '');
-+ print( PICHTML "" );
++ print( PICHTML "" );
+ print( PICHTML "")
+ if ($opt_pichtmllink ne '');
} else {
@@ -1347,7 +1348,7 @@ diff -u -r1.117 -r1.170
}
print( PICHTML "$opt_pichtmlbottom\n") if ("$opt_pichtmlbottom" ne '');
-@@ -2570,15 +2782,15 @@
+@@ -2570,15 +2783,15 @@
unless ($opt_tables)
{
@@ -1367,7 +1368,7 @@ diff -u -r1.117 -r1.170
}
}
-@@ -2590,7 +2802,7 @@
+@@ -2590,7 +2803,7 @@
print INDEX "";
}
@@ -1376,17 +1377,17 @@ diff -u -r1.117 -r1.170
if ($opt_pichtml) {
print (INDEX "");
-@@ -2601,17 +2813,34 @@
+@@ -2601,17 +2814,34 @@
# TODO: make sure the thumbnails are created, and get some image sizes
# TODO: save the labels in a new array, maybe same with sizes
if ( $thumbImageSizes{$pic}) {
- print (INDEX "");
+ print (INDEX "");
++ "\" $thumbImageSizes{$pic} ALT=\"${altfinallabel}\" TITLE=\"${altfinallabel}\" BORDER=0>");
} else {
- print (INDEX "");
+ print (INDEX "");
++ "\" ALT=\"${altfinallabel}\" TITLE=\"${altfinallabel}\" BORDER=0>");
}
- print (INDEX "
" . $tableImageLabels{$imageNames[$pageNumber - 1][$imageNum]} . "\n");
@@ -1416,7 +1417,7 @@ diff -u -r1.117 -r1.170
} # if ($opt_tables)
} # for each picture
-@@ -2622,6 +2851,13 @@
+@@ -2622,6 +2852,13 @@
{
print INDEX "
";
}
@@ -1430,7 +1431,7 @@ diff -u -r1.117 -r1.170
print (INDEX "\n")
} else {print( INDEX "\n" );}
}
-@@ -2630,6 +2866,9 @@
+@@ -2630,6 +2867,9 @@
# Print Copyright info on non-blank pages.
if( $numimages > 0 ) {
@@ -1440,7 +1441,7 @@ diff -u -r1.117 -r1.170
if( "${opt_address}" ne '' ) {
print( INDEX "
${opt_address}\n" );
}
-@@ -2642,13 +2881,17 @@
+@@ -2642,13 +2882,17 @@
# If anonymous, don't show copyright and address info
if( ! $opt_anonymous ) {
print( INDEX "
\n${opt_msg_produced_by} " );
@@ -1460,7 +1461,7 @@ diff -u -r1.117 -r1.170
}
print( INDEX "