- Add MASTER_SITES
- Use ECHO_MSG, SUB_FILES - Switch to PLIST_FILES PR: ports/172043 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
This commit is contained in:
parent
b5f3820240
commit
5745335656
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=307283
4 changed files with 21 additions and 15 deletions
|
@ -1,30 +1,29 @@
|
||||||
# New ports collection makefile for: tdetect
|
# Created by: shipley@dis.org
|
||||||
# Date created: Sun Jan 31, 1997
|
|
||||||
# Whom: shipley@dis.org
|
|
||||||
#
|
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
#
|
|
||||||
|
|
||||||
PORTNAME= tdetect
|
PORTNAME= tdetect
|
||||||
PORTVERSION= 0.2
|
PORTVERSION= 0.2
|
||||||
CATEGORIES= net
|
CATEGORIES= net
|
||||||
MASTER_SITES= # disappeared
|
MASTER_SITES= PACKETSTORM/UNIX/loggers
|
||||||
|
|
||||||
MAINTAINER= ports@FreeBSD.org
|
MAINTAINER= ports@FreeBSD.org
|
||||||
COMMENT= Utility for detecting traceroutes and reporting them via syslog
|
COMMENT= Utility for detecting traceroutes and reporting them via syslog
|
||||||
|
|
||||||
|
PLIST_FILES= sbin/tdetect etc/rc.d/tdetect.sh
|
||||||
|
SUB_FILES= pkg-message
|
||||||
|
|
||||||
pre-configure:
|
pre-configure:
|
||||||
${REINPLACE_CMD} -e 's/trdetect/tdetect/g' ${WRKSRC}/config.h
|
@${REINPLACE_CMD} -e 's/trdetect/tdetect/g' ${WRKSRC}/config.h
|
||||||
${REINPLACE_CMD} -e 's/LOG_AUTHPRIV/LOG_SECURITY/g' ${WRKSRC}/config.h
|
@${REINPLACE_CMD} -e 's/LOG_AUTHPRIV/LOG_SECURITY/g' ${WRKSRC}/config.h
|
||||||
|
|
||||||
do-install:
|
do-install:
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/tdetect ${PREFIX}/sbin/tdetect
|
${INSTALL_PROGRAM} ${WRKSRC}/tdetect ${PREFIX}/sbin/tdetect
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
@if [ ! -f ${PREFIX}/etc/rc.d/tdetect.sh ]; then \
|
@if [ ! -f ${PREFIX}/etc/rc.d/tdetect.sh ]; then \
|
||||||
${ECHO} "Installing ${PREFIX}/etc/rc.d/tdetect.sh startup file."; \
|
${ECHO_MSG} "Installing ${PREFIX}/etc/rc.d/tdetect.sh startup file."; \
|
||||||
${INSTALL_SCRIPT} -m 750 ${FILESDIR}/tdetect.sh ${PREFIX}/etc/rc.d/tdetect.sh; \
|
${INSTALL_SCRIPT} -m 750 ${FILESDIR}/tdetect.sh ${PREFIX}/etc/rc.d/tdetect.sh; \
|
||||||
${SED} -e 's,/usr/local,${PREFIX},g' ${PKGMESSAGE}; \
|
${CAT} ${PKGMESSAGE}; \
|
||||||
fi
|
fi
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
--- Makefile.orig Wed Oct 22 16:58:23 2003
|
--- Makefile.orig 1998-08-13 17:17:57.000000000 +0900
|
||||||
+++ Makefile Wed Oct 22 16:58:37 2003
|
+++ Makefile 2012-09-08 03:33:04.000000000 +0900
|
||||||
@@ -1,11 +1,11 @@
|
@@ -1,11 +1,11 @@
|
||||||
# Makefile
|
# Makefile
|
||||||
|
|
||||||
|
@ -14,3 +14,12 @@
|
||||||
OBJS=main.o null.o ether.o ip.o
|
OBJS=main.o null.o ether.o ip.o
|
||||||
LIBS= -lpcap
|
LIBS= -lpcap
|
||||||
SRC=$(OBJS:%.o=%.c)
|
SRC=$(OBJS:%.o=%.c)
|
||||||
|
@@ -13,7 +13,7 @@
|
||||||
|
all: tdetect
|
||||||
|
|
||||||
|
tdetect: $(OBJS)
|
||||||
|
- $(CC) $(OBJS) $(LIBS) $(DEBUG) -s -o tdetect
|
||||||
|
+ $(CC) $(OBJS) $(LIBS) $(DEBUG) -o tdetect
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f *.o tdetect *.b
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
|
|
||||||
IMPORTANT!
|
IMPORTANT!
|
||||||
|
|
||||||
Dont forget to edit /usr/local/etc/rc.d/tdetect.sh
|
Dont forget to edit %%PREFIX%%/etc/rc.d/tdetect.sh
|
||||||
and set ETHERNETDEV to the name of the ethernet device you wish to monitor
|
and set ETHERNETDEV to the name of the ethernet device you wish to monitor
|
||||||
|
|
|
@ -1,2 +0,0 @@
|
||||||
sbin/tdetect
|
|
||||||
etc/rc.d/tdetect.sh
|
|
Loading…
Reference in a new issue