The Parse::Lex.pm module for perl5 is an object-oriented generator of
lexical analyzers. PR: ports/62936 Submitted by: Jim Pirzyk <pirzyk@uiuc.edu>
This commit is contained in:
parent
5f99dd95e8
commit
57a3e704b3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116905
7 changed files with 73 additions and 0 deletions
|
@ -907,6 +907,7 @@
|
|||
SUBDIR += p5-Parse-PerlConfig
|
||||
SUBDIR += p5-Parse-RecDescent
|
||||
SUBDIR += p5-Parse-Yapp
|
||||
SUBDIR += p5-ParseLex
|
||||
SUBDIR += p5-PatchReader
|
||||
SUBDIR += p5-Path-Class
|
||||
SUBDIR += p5-Penguin
|
||||
|
|
26
devel/p5-ParseLex/Makefile
Normal file
26
devel/p5-ParseLex/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# New ports collection makefile for: p5-ParseLex
|
||||
# Date created: 16 February 2004
|
||||
# Whom: Jim Pirzyk <pirzyk@uiuc.edu>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ParseLex
|
||||
PORTVERSION= 2.15
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= Parse
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= pirzyk@freebsd.org
|
||||
COMMENT= Object-oriented generator of lexical analyzers
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
|
||||
MAN3= Parse::Lex.3 Parse::Token.3 Parse::YYLex.3 Parse::LexEvent.3 Parse::CLex.3 Parse::Template.3
|
||||
|
||||
post-patch:
|
||||
@${RM} ${WRKSRC}/lib/Parse/*.orig
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/p5-ParseLex/distinfo
Normal file
1
devel/p5-ParseLex/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (ParseLex-2.15.tar.gz) = aeb0bb36454485d28214aad0907d5c92
|
17
devel/p5-ParseLex/files/patch-lib-Parse-Template.pm
Normal file
17
devel/p5-ParseLex/files/patch-lib-Parse-Template.pm
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- lib/Parse/Template.pm.orig Thu Sep 23 12:16:28 1999
|
||||
+++ lib/Parse/Template.pm Fri Aug 20 16:03:23 2004
|
||||
@@ -1,4 +1,4 @@
|
||||
-use strict
|
||||
+use strict;
|
||||
require 5.004;
|
||||
package Parse::Template;
|
||||
$Parse::Template::VERSION = '0.32';
|
||||
@@ -132,7 +132,7 @@
|
||||
}
|
||||
# evaluated expressions are not always available in (caller(1))[6];
|
||||
if (defined($1) and $1 ne '') {
|
||||
- $expr = $1; # what is the template expression?
|
||||
+ my $expr = $1; # what is the template expression?
|
||||
{ package DB; # what is the part name?
|
||||
@DB::caller = caller(2); # why is this needed? /ee?
|
||||
@DB::caller = caller(1);
|
8
devel/p5-ParseLex/files/patch-t-test4.t
Normal file
8
devel/p5-ParseLex/files/patch-t-test4.t
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- t/test4.t.orig Fri Aug 20 16:06:52 2004
|
||||
+++ t/test4.t Fri Aug 20 16:07:08 2004
|
||||
@@ -54,4 +54,4 @@
|
||||
[main::lexer|Parse::CLex] Token read (NEWLINE, \n):
|
||||
|
||||
[main::lexer|Parse::CLex] Token read (ERROR, .*): this is an invalid string with a "" in it"
|
||||
-can't analyze: "this is an invalid string with a "" in it"" at examples/ctokenizer.pl line 17, <DATA> chunk 4.
|
||||
+can't analyze: "this is an invalid string with a "" in it"" at examples/ctokenizer.pl line 17, <DATA> line 4.
|
7
devel/p5-ParseLex/pkg-descr
Normal file
7
devel/p5-ParseLex/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
The Parse::Lex.pm module for perl5 is an object-oriented generator of
|
||||
lexical analyzers.
|
||||
|
||||
This distribution includes Parse::YYLex (writed by Vladimir Alexiev)
|
||||
a lexer generator that you can use with yacc parsers.
|
||||
|
||||
WWW: http://search.cpan.org/~pverd
|
13
devel/p5-ParseLex/pkg-plist
Normal file
13
devel/p5-ParseLex/pkg-plist
Normal file
|
@ -0,0 +1,13 @@
|
|||
%%SITE_PERL%%/Parse/Lex.pm
|
||||
%%SITE_PERL%%/Parse/ALex.pm
|
||||
%%SITE_PERL%%/Parse/LexEvent.pm
|
||||
%%SITE_PERL%%/Parse/YYLex.pm
|
||||
%%SITE_PERL%%/Parse/Template.pm
|
||||
%%SITE_PERL%%/Parse/CLex.pm
|
||||
%%SITE_PERL%%/Parse/Trace.pm
|
||||
%%SITE_PERL%%/Parse/Token.pm
|
||||
%%SITE_PERL%%/Parse/Token-t.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Lex/.packlist
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Lex 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/Parse 2>/dev/null || true
|
Loading…
Reference in a new issue