o Update to 0.90 rc5 [1]
o Add WITH_FAAD knob [1] [2] PR: 50188 [1], 50246 [2] Submitted by: maintainer [1], David Yeske <dyeske@yahoo.com> [2]
This commit is contained in:
parent
eda741f818
commit
57ffe5056b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77488
4 changed files with 34 additions and 27 deletions
|
@ -127,6 +127,9 @@
|
|||
# WITH_XVID
|
||||
# default: autodetect
|
||||
#
|
||||
# WITH_FAAD
|
||||
# default: autodetect
|
||||
#
|
||||
# WITHOUT_WIN32_CODECS
|
||||
# default: undefined
|
||||
# By default, mplayer depends on and uses the win32-codecs collection.
|
||||
|
@ -145,8 +148,7 @@
|
|||
# to be installed.
|
||||
|
||||
PORTNAME= mplayer
|
||||
PORTVERSION= 0.90.0.104
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.90.0.105
|
||||
CATEGORIES= multimedia audio
|
||||
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
|
||||
http://www2.mplayerhq.hu/MPlayer/releases/ \
|
||||
|
@ -156,7 +158,7 @@ MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
|
|||
ftp://ftp2.mplayerhq.hu/MPlayer/releases/ \
|
||||
ftp://ftp.lug.udel.edu/MPlayer/releases/ \
|
||||
http://www.rrr.de/~riggs/mplayer/
|
||||
DISTNAME= MPlayer-0.90rc4
|
||||
DISTNAME= MPlayer-0.90rc5
|
||||
|
||||
MAINTAINER= riggs@rrr.de
|
||||
COMMENT= High performance media player/encoder supporting many formats
|
||||
|
@ -192,6 +194,10 @@ DOCFILES= bugreports.html cd-dvd.html codecs-in.html \
|
|||
encoding.html formats.html sound.html \
|
||||
users_against_developers.html \
|
||||
video.html
|
||||
TOOLFILES= calcbpp.pl countquant.pl \
|
||||
dvd2divxscript.pl menc2pass \
|
||||
mencvcd mp.pl sws-test w32codec_dl.pl \
|
||||
x2mpsub.sh
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -251,6 +257,10 @@ WITH_LIVEMEDIA= yes
|
|||
WITH_XVID= yes
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libfaad.so)
|
||||
WITH_FAAD= yes
|
||||
.endif
|
||||
|
||||
.if defined(WITH_OPTIMIZED_CFLAGS)
|
||||
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
|
||||
.endif
|
||||
|
@ -367,6 +377,11 @@ CONFIGURE_ARGS+= --enable-xvid \
|
|||
LIB_DEPENDS+= xvidcore.0:${PORTSDIR}/graphics/xvid
|
||||
.endif
|
||||
|
||||
.if defined(WITH_FAAD)
|
||||
CONFIGURE_ARGS+= --enable-faad
|
||||
LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
|
||||
.endif
|
||||
|
||||
.if defined(WITH_FREETYPE)
|
||||
CONFIGURE_ARGS+= --with-extraincdir=${LOCALBASE}/include/freetype2 \
|
||||
--enable-freetype
|
||||
|
@ -445,9 +460,14 @@ pre-configure:
|
|||
post-install:
|
||||
@${MKDIR} ${DATADIR}
|
||||
@${CHMOD} 755 ${DATADIR}
|
||||
@${MKDIR} ${DATADIR}/tools
|
||||
@${CHMOD} 755 ${DATADIR}/tools
|
||||
.for conf in ${CONFFILES}
|
||||
${INSTALL_DATA} ${WRKSRC}/etc/${conf} ${DATADIR}
|
||||
.endfor
|
||||
.for tool in ${TOOLFILES}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/TOOLS/${tool} ${DATADIR}/tools
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${CHMOD} 755 ${DOCSDIR}
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (MPlayer-0.90rc4.tar.bz2) = 4976575433d5b0ad526ca1733f5cab26
|
||||
MD5 (MPlayer-0.90rc5.tar.bz2) = 056c2cd23286ca5464a70defd4649134
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
--- libmpdemux/demux_mov.c.orig Sat Feb 8 11:31:57 2003
|
||||
+++ libmpdemux/demux_mov.c Sat Feb 8 11:32:29 2003
|
||||
@@ -597,7 +597,10 @@
|
||||
unsigned int fourcc=stream_read_dword_le(demuxer->stream);
|
||||
if(len<8) break; // error
|
||||
mp_msg(MSGT_DEMUX,MSGL_V,"MOV: %*s desc #%d: %.4s (%d bytes)\n",level,"",i,&fourcc,len-16);
|
||||
- if(!i){
|
||||
+ if(fourcc!=trak->fourcc && i)
|
||||
+ mp_msg(MSGT_DEMUX,MSGL_WARN,MSGTR_MOVvariableFourCC);
|
||||
+ //if(!i)
|
||||
+ {
|
||||
trak->fourcc=fourcc;
|
||||
// read type specific (audio/video/time/text etc) header
|
||||
// NOTE: trak type is not yet known at this point :(((
|
||||
@@ -605,8 +608,6 @@
|
||||
trak->stdata=malloc(trak->stdata_len);
|
||||
stream_read(demuxer->stream,trak->stdata,trak->stdata_len);
|
||||
}
|
||||
- if(fourcc!=trak->fourcc && i)
|
||||
- mp_msg(MSGT_DEMUX,MSGL_WARN,MSGTR_MOVvariableFourCC);
|
||||
if(!stream_seek(demuxer->stream,pos+len)) break;
|
||||
}
|
||||
break;
|
|
@ -22,10 +22,20 @@ lib/mplayer/vidix/mga_vid.so
|
|||
lib/mplayer/vidix/pm3_vid.so
|
||||
lib/mplayer/vidix/radeon_vid.so
|
||||
lib/mplayer/vidix/rage128_vid.so
|
||||
share/mplayer/tools/calcbpp.pl
|
||||
share/mplayer/tools/countquant.pl
|
||||
share/mplayer/tools/dvd2divxscript.pl
|
||||
share/mplayer/tools/menc2pass
|
||||
share/mplayer/tools/mencvcd
|
||||
share/mplayer/tools/mp.pl
|
||||
share/mplayer/tools/sws-test
|
||||
share/mplayer/tools/w32codec_dl.pl
|
||||
share/mplayer/tools/x2mpsub.sh
|
||||
share/mplayer/codecs.conf
|
||||
share/mplayer/example.conf
|
||||
share/mplayer/input.conf
|
||||
share/mplayer/menu.conf
|
||||
@dirrm share/mplayer/tools
|
||||
@unexec rmdir %D/share/mplayer 2>/dev/null || true
|
||||
%%PORTDOCS%%@dirrm share/doc/mplayer
|
||||
@dirrm lib/mplayer/vidix
|
||||
|
|
Loading…
Reference in a new issue