Fix build with freetype2-2.1.7.
Reported by: bento via kris
This commit is contained in:
parent
927c1bd82b
commit
5800193a29
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=104998
3 changed files with 47 additions and 3 deletions
|
@ -1,5 +1,5 @@
|
|||
--- configure.orig Wed Feb 12 13:06:57 2003
|
||||
+++ configure Sat Dec 13 16:06:49 2003
|
||||
--- configure.orig Tue Feb 11 23:06:57 2003
|
||||
+++ configure Mon Mar 22 23:22:46 2004
|
||||
@@ -7699,7 +7699,7 @@
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
|
@ -18,7 +18,27 @@
|
|||
|
||||
fi
|
||||
|
||||
@@ -10538,3 +10538,4 @@
|
||||
@@ -7964,7 +7964,8 @@
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
$ac_includes_default
|
||||
-#include <freetype/freetype.h>
|
||||
+#include <ft2build.h>
|
||||
+#include FT_FREETYPE_H
|
||||
_ACEOF
|
||||
rm -f conftest.$ac_objext
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
||||
@@ -7999,7 +8000,8 @@
|
||||
cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
-#include <freetype/freetype.h>
|
||||
+#include <ft2build.h>
|
||||
+#include FT_FREETYPE_H
|
||||
_ACEOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
|
||||
(eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
|
||||
@@ -10538,3 +10540,4 @@
|
||||
|
||||
ln -s $ac_aux_dir/Makefile.deps . 2>/dev/null
|
||||
ln -s $ac_aux_dir/install-sh . 2>/dev/null
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
--- plugins/image_filter/text/if_text.cpp.orig Mon Mar 22 23:23:31 2004
|
||||
+++ plugins/image_filter/text/if_text.cpp Mon Mar 22 23:23:43 2004
|
||||
@@ -18,7 +18,8 @@
|
||||
|
||||
#include <cmath>
|
||||
#include <string.h>
|
||||
-#include <freetype/freetype.h>
|
||||
+#include <ft2build.h>
|
||||
+#include FT_FREETYPE_H
|
||||
#include "llapi/file.h"
|
||||
#include "llapi/scene.h"
|
||||
#include "if_text.h"
|
12
graphics/py-imaging/files/patch-_imagingft.c
Normal file
12
graphics/py-imaging/files/patch-_imagingft.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- _imagingft.c.orig Mon Mar 22 23:27:33 2004
|
||||
+++ _imagingft.c Mon Mar 22 23:28:03 2004
|
||||
@@ -15,7 +15,8 @@
|
||||
#include "Python.h"
|
||||
#include "Imaging.h"
|
||||
|
||||
-#include <freetype/freetype.h>
|
||||
+#include <ft2build.h>
|
||||
+#include FT_FREETYPE_H
|
||||
|
||||
#if PY_VERSION_HEX < 0x01060000
|
||||
#define PyObject_DEL(op) PyMem_DEL((op))
|
Loading…
Reference in a new issue